Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Mikrotik porta 3128 thundercache

    Boa tade.

    estou com um pc mikrotik aqui, e com um ubuntu server com thundercache.

    preciso redirecionar a porta 80 do mikrotik para a porta 3128 do thundercache para o thunder cachea.

    os meus clientes estão na faixa 192.168.0.0/24 e meu thundercache esta em 192.168.2.1... meu mikrotik pinga normalmete para o thundercache.

    mas não estou conseguindo redirecionar os clientes para salvar a pagina no thundercache e requisita.

    ajuda por favor tenho que fazer esse trabalho hoje as 2 horas da tarde.

    OBRIGADO!!

  2. #2

    Padrão

    cara vc poderia postar ai como fez esse servidor de cache?



  3. #3

    Padrão

    cara é muito simples, fiz no ubuntu server procurei na internet que tem varios tutorias sobre.

    alguem que possa me ajudar?
    Última edição por thefox; 16-04-2010 às 09:08.

  4. #4
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    La no forum do Thunder tem as regras certinhas de como fazer o que você quer, nao tem erro é bem facil


    Abraços e boa sorte



  5. #5

    Padrão

    Simples, se usar pppoe desvia o trafego atravez de uma regra de nat fazendo um dst-nat da porta 80 para o ip do thunder.

    Se vc usa hotsp-ot , basta ir em IP > Hotspot > Servers > profile e alterar o ip do proxi para o ip do thunder

  6. #6

    Padrão

    ok fernando vou testa isso hoje... tentei uma regra mais não deu certo essa \/

    add chain=dstnat src-address=192.168.253.0/24 dst-address=!192.168.10.250 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.10.250 \
    to-ports=3128 comment="proxy for HTTP requests" disabled=no


    Onde está grifado de vermelho coloque a faixa de ip's de sua rede



  7. #7

    Padrão

    Eu estava tendo esse problema aqui com meu servidor. Depois de quebrarmos a cabeça resolvemos mudar de porta. Por algum motivo a porta 3128 do MK estava bloqueada, nós não a bloqueamos. Tente mudar de porta para ver se funciona.

    Att

  8. #8

    Padrão

    pantanero o que você fez depois de ter mudado a porta ? fernando fiz o que você falou pois eu uso hotspot e não funcionou agora vou muda a porta do proxy... pra tenta novamente.



  9. #9

    Padrão

    bom galera já tentei o que você citaram aqui já tentei a regra>>

    add chain=dstnat src-address=192.168.88.150 dst-address=!10.1.1.2 protocol=tcp dst-port=80 action=dst-nat to-addresses=10.1.1.2 to-ports=3128

    mas nada funciona mudei a porta para 3127, e nada... as vezes configuro o thunder funciona mais a net não, a net funciona mais o thunder não. por favor ajudem.

  10. #10
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Thefox como esta ligado esse servidor no mk?
    Pelo que entendi vc ja conseguiu fazer o mk se comunicar com ele.
    Tem uma masquerade para ele no mk ?
    No cache esta configurado para o ip do mk ser gateway dele?
    Configurou o dns no cache ?
    Passa as config pra ver se a gente consegue te ajudar melhor

    Abraços



  11. #11

    Padrão

    bom cara o cache esta funcionando pinga pra host na internet normal, mas não configurei no proxy para o mk ser gateway dele, pois não sabia dessa configuração... o ip do thundercache é 192.168.2.1 o ip do mikrotik esta na faixa 192.168.0.0/24 o mikrotik pinga pra o thundercache normal, e vice-versa já tentei todas as regras validas de redirecionamento sobre o assunto as vezes a regra funciona a internet mais o thundercache cai, não entra as vezes o thundercache funciona mais a internet cai, quando configuro o proxy direto no navegador funciona perfeitamente. como faço pra fazer essa configuração no proxy ? sendo que o ip do mk esta na faixa 192.168.0.0/24 e o proxy esta em 192.168.2.1 ? obrigado pela ajuda.
    Última edição por thefox; 16-04-2010 às 23:59.

  12. #12
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Entao Faz o seguinte, na placa de rede do mk que esta ligado o linux coloca o ip do mk em 192.168.2.253/24, no linux você vai deixar o ip em:
    ip="192.168.2.1"
    mask=255.255.255.0
    network=192.168.2.0
    broadcast=192.168.2.255
    gateway=192.168.2.253

    No mk vai fazer uma nat pro linux :
    ip firewall nat
    add chain=srcnat src-address=192.168.2.1 protocol=tcp action=masquerade \comment="THUNDER" disabled=no

    add chain=dstnat src-address=192.168.1.0/24 dst-address=!192.168.2.1 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.1 \
    to-ports=3128 comment="" disabled=no

    Onde esta em vermelho é a faixa de rede dos seus clientes.
    Lembrando que essa regra vale pra quando o mk esta como gateway da rede ok

    Testa e diga se funcionou.

    Abraços e boa sorte



  13. #13

    Padrão

    ok... irei testa, quanto o ip do ubuntu server? eu terei que troca na config do squid e do thunder?

    mudando o ip terei que edita tudo no squid/thunder? correto?

    sudo nano /etc/network/interfaces

    Troque o texto abaixo....
    auto eth0
    iface eth0 inet dhcp
    .... pelo texto
    auto eth0
    iface eth0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.1.10
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Última edição por thefox; 17-04-2010 às 13:49.

  14. #14
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Citação Postado originalmente por thefox Ver Post
    ok... irei testa, quanto o ip do ubuntu server? eu terei que troca na config do squid e do thunder?

    mudando o ip terei que edita tudo no squid/thunder? correto?

    sudo nano /etc/network/interfaces

    Troque o texto abaixo....
    auto eth0
    iface eth0 inet dhcp
    .... pelo texto
    auto eth0
    iface eth0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.1.10
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Acho que nao fui claro o suficiente.

    auto eth0
    iface eth0 inet static
    address 192.168.2.1
    netmask 255.255.255.0
    network 192.168.2.0
    broadcast 192.168.2.255
    gateway 192.168.2.253

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.2.253
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Isso ai vai ficar no linuz(UBUNTU) OK.

    No mikrotik 192.168.2.253/24 na placa exclusiva pro Linux(UBUNTU)

    Ainda no Mikrotik
    ip firewall nat
    add chain=srcnat src-address=192.168.2.1 protocol=tcp action=masquerade \comment="THUNDER" disabled=no

    Ainda no Mikrotik
    ip firewall nat
    add chain=dstnat src-address=192.168.1.0/24 dst-address=!192.168.2.1 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.1 \
    to-ports=3128 comment="" disabled=no

    Onde esta em vermelho é a faixa de rede dos seus clientes.

    Espero ter sido mais claro agora.

    Lembrando que no squid e nas conf do thunder tem que ser o ip do Linux(UBUNTU)
    192.168.2.1 oks

    Qualquer coisa posta ai
    Última edição por edcomrocha; 17-04-2010 às 14:25.



  15. #15

    Padrão

    ok,obrigado.

    \comment="THUNDER" disabled=no

    não entendi "disabled=no", seria um comentario?

  16. #16
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Citação Postado originalmente por thefox Ver Post
    ok,obrigado.

    \comment="THUNDER" disabled=no

    não entendi "disabled=no", seria um comentario?
    O comentario é somente o THUNDER, o disable=no, quer dizer que a regra esta ativa
    se fosse disable=yes quando você colocasse a regra ela ficaria desabilitada, isso sendo feito por terminal no mk.



  17. #17

    Padrão

    isso feito no terminal, ok.

    só muda o ip que esta em vermelho, para a rede dos clientes.

    e copia e cola no terminal.

  18. #18
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Citação Postado originalmente por thefox Ver Post
    isso feito no terminal, ok.

    só muda o ip que esta em vermelho, para a rede dos clientes.

    e copia e cola no terminal.
    Sim isso mesmo, as vezes copiar e colar nao rola depende da versao que vc esta usando, mais se observar a regra e ir adicinando pelo winbox mesmo vc consegue e assim entende melhor o que a regra faz



  19. #19

    Padrão

    ok, vou testa amanha. e posto os resultados.

    não vou adiciona pelo terminal vou seguir a regra, e ir adicionando.

  20. #20

    Padrão

    bom...

    fiz todas as regras,corretamente como você mandou quando tento acessar a internet. aparenta o erro abaixo \/ o que pode esta acontecendo? meu erro é mais ou menos como esta na imagem.

    ERROR

    The requested URL could not be retrieved

    Clique na imagem para uma versão maior

Nome:	         erro.jpg
Visualizações:	156
Tamanho: 	119,8 KB
ID:      	10808
    https://under-linux.org/images/misc/pencil.png
    Última edição por thefox; 19-04-2010 às 23:41.