+ Responder ao Tópico



  1. Bom dia!!, pessoal atualizei o meu kernel no meu Debian 5 lenny, problema que o ao rodar o alsamixer da a seguinte mesg

    Código :
    alsamixer: function snd_ctl_open failed for default: No such file or directory

    Procurei no google e não consegui achar uma solução então resolvi compilar novamente o driver do alsa já que meu kernel é customizado..

    Do kernel e alsa
    Código :
    kernel 2.6.32.11
    nome customizado -alice- 
    alsa driver alsa-driver-1.0.9rc4a

    Da compilação
    Código :
    ./configure --with-cards=all
     
    linhas finais 
    checking for PC9800 support in kernel... "no"
    checking for parallel port support... "yes"
    checking for which soundcards to compile driver for... all
    configure: creating ./config.status
    config.status: creating version
    config.status: creating Makefile.conf
    config.status: creating snddevices
    config.status: creating utils/alsa-driver.spec
    config.status: creating utils/buildrpm
    config.status: creating toplevel.config
    config.status: creating utils/alsasound
    config.status: creating utils/alsasound.posix
    config.status: creating include/config.h
    config.status: creating include/config1.h
    config.status: creating include/version.h
    config.status: include/version.h is unchanged
    config.status: creating include/autoconf-extra.h
    Hacking autoconf.h...

    Do make
    Código :
    In file included from hpetimer.c:30:
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h: At top level:
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h:75: error: expected specifier-qualifier-list before ‘mode_t’
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h: In function ‘snd_info_set_text_ops’:
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h:142: error: ‘snd_info_entry_t’ has no member named ‘private_data’
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h:143: error: ‘snd_info_entry_t’ has no member named ‘c’
    /usr/src/alsa-driver-1.0.9rc4a/include/sound/info.h:144: error: ‘snd_info_entry_t’ has no member named ‘c’
    In file included from hpetimer.c:31:
    /lib/modules/2.6.32.11-alice-/build/include/linux/hpet.h: At top level:
    /lib/modules/2.6.32.11-alice-/build/include/linux/hpet.h:13: error: expected specifier-qualifier-list before ‘u64’
    hpetimer.c: In function ‘snd_hpet_open’:
    hpetimer.c:41: warning: implicit declaration of function ‘hpet_register’
    hpetimer.c:44: warning: implicit declaration of function ‘hpet_control’
    hpetimer.c:44: error: expected expression before ‘unsigned’
    hpetimer.c: In function ‘snd_hpet_close’:
    hpetimer.c:51: warning: implicit declaration of function ‘hpet_unregister’
    hpetimer.c:52: error: invalid use of undefined type ‘struct hpet_task’
    hpetimer.c: In function ‘hpetimer_init’:
    hpetimer.c:88: error: ‘EINVAL’ undeclared (first use in this function)
    hpetimer.c:99: error: invalid use of undefined type ‘struct hpet_task’
    hpetimer.c:100: error: invalid use of undefined type ‘struct hpet_task’
    hpetimer.c: At top level:
    hpetimer.c:121: warning: excess elements in struct initializer
    hpetimer.c:121: warning: (near initialization for ‘__param_frequency’)
    hpetimer.c:121: warning: excess elements in struct initializer
    hpetimer.c:121: warning: (near initialization for ‘__param_frequency’)
    hpetimer.c:121: warning: excess elements in struct initializer
    hpetimer.c:121: warning: (near initialization for ‘__param_frequency’)
    hpetimer.c:121: warning: excess elements in struct initializer
    hpetimer.c:121: warning: (near initialization for ‘__param_frequency’)
    hpetimer.c:121: error: extra brace group at end of initializer
    hpetimer.c:121: error: (near initialization for ‘__param_frequency’)
    hpetimer.c:121: warning: excess elements in struct initializer
    hpetimer.c:121: warning: (near initialization for ‘__param_frequency’)
    make[1]: ** [hpetimer.o] Erro 1
    make[1]: Saindo do diretório `/usr/src/alsa-driver-1.0.9rc4a/acore'
    make: ** [compile] Erro 1

    esse ultimo é muito grande se precisar eu posto ele completo

    Alguem pode dar uma luz ae?

  2. Pessoal problema resolvido, a noobagem foi que o cara aqui pegou o drive não estável do alsa. Ao descobrir peguei o correto e a compilação se deu normal
    depois so seguir esses passos

    Código :
    [FONT=Courier, Monospaced] [/FONT]Certifique-se que possue os pacotes instalados: 
    # aptitude install mpg123 mpg321 vorbis-tools sox oss-compat libesd-alsa0 libsox-fmt-all 
     
    Carregue esses modulos: 
    # modprobe snd_mixer_oss 
    # modprobe snd_pcm_oss 
     
    feito isso vamos atualizar o alsa para a versão 1.0.20, baixar o tarball do link abaixo:
    - alsa-driver [URL="ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.20.tar.bz2"]ftp://ftp.alsa-project.org/pub/driver/a ... 20.tar.bz2[/URL]
     
     
     
     
     Descompactar o arquivo:
     tar xvjf alsa-driver-1.0.20.tar.bz2
     
     
     
     
    Atenção: Antes de iniciar a compilação, verificar se os Sources e Headers do seu kernel estão instalados e em caso negativo fazer a instalação através dos comandos (como root): 
     
     
     
     aptitude install linux-kbuild-`uname -r | cut -f1 -d-` libncurses5-dev  
     aptitude install build-essential module-assistant linux-headers-`uname -r` linux-source-`uname -r | cut -f1 -d-`
     Compilar o alsa-driver assim:  
     
     
     			 		 		 			 				$ ./configure --with-card-options=all 
    $ 				make 
    # make install
     
     
     
    Executar também o script .snddevices que está no diretório do alsa-driver-1.0.20: 
     
     
     
     # ./snddevices 
     
     
    Depois disso tudo executar o alsaconf e depois de reiniciar veja se tudo está correto 
    Caso necessário executar o alsamixer e regular o nível dos volumes de alguns itens.

    fonte utilizada
    Debian 5 sem som (mais um)-[Resolvido] - FórumGdH






Tópicos Similares

  1. É possivel ter um kernel novo com KDE velho?
    Por uerta no fórum Servidores de Rede
    Respostas: 2
    Último Post: 22-08-2003, 14:04
  2. Problemas para instalar o PPTP(.tar.gz)! Não compila nada!
    Por LinuxAthos no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-08-2003, 08:09
  3. RH 8.1 Phoebe beta não compila o Mysql!
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-01-2003, 22:24
  4. Nao Compila RH 8 !!!!
    Por PedroNasc no fórum Servidores de Rede
    Respostas: 4
    Último Post: 16-12-2002, 15:16
  5. PHP não compila.....
    Por Futuremax no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-11-2002, 14:42

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L