Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Log de Navegação dos Clientes

    Galera como faço para saber o que os meus Clientes estão navegando?
    Uso Servidor MK 3.30.

    Obrigado aos mais experientes!

  2. #2
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão

    instala o MK AUTH para autenticação que ele te fala a data o horário o dia e todas as conexões e todos os sites que o cliente conectar!



  3. #3

  4. #4

    Padrão

    Se quer log somente da navegação, use o Proxylizer:
    Proxylizer - MikroTik Wiki

    Se quer logar todo tipo de acesso, use o Calea:
    CALEA - MikroTik Wiki



  5. #5

    Padrão

    Pois é, mas esse procedimento requer o uso do Web-proxy do MK Server e esse Web-proxy conflitou com minhas regras de Controle de Conexões.
    Alguém já passou por isso?

  6. #6

    Padrão

    será que teria outra maneira de obter esses logs?



  7. #7

  8. #8
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão

    eplo winbox não tem como!



  9. #9

    Padrão

    o log do mk e muito curto. como obter um maior?

  10. #10
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão

    tbm preciso de obter essa informação! sei que não é da minha conta! mais pra que quer o log dos clientes ?!



  11. #11

    Padrão

    o log q falo e aquele q mostra erros do sistema,acesso via web,ssh e as tentativas de invasão pq ele apaga muito rapido e é curto...mais vlw aiii

  12. #12
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão Re: Log de Navegação dos Clientes

    a sim entendii!! rsrsrsrsrsrsrsrs! meu amigo é se vc esta sempre acessando seu servidor basta clicar na Opção LOG e pronto! ai vc olha se estiver algo de errado você olha na hora! entendi ?? seria bem mais prático!

    Abraço amigãO!



  13. #13

    Padrão Re: Log de Navegação dos Clientes

    vlw cara...

  14. #14

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por Nando Ver Post
    o log q falo e aquele q mostra erros do sistema,acesso via web,ssh e as tentativas de invasão pq ele apaga muito rapido e é curto...mais vlw aiii
    Este log pode ser salvo em arquivo dentro do proprio MK ou em um servidor de log remoto.

    Leia isto:
    http://www.mikrotik.com/testdocs/ros...em/logging.php



  15. #15

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por agrinfo Ver Post
    Pois é, mas esse procedimento requer o uso do Web-proxy do MK Server e esse Web-proxy conflitou com minhas regras de Controle de Conexões.
    Alguém já passou por isso?
    Explique melhor

  16. #16

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por netosdr Ver Post
    Explique melhor
    Se eu ativo o WEB-PROXY (ou seja, a origem para se conseguir os LOG´s de ACCOUNT onde fica registrado o que os Clientes estão acessando/navegando) a minha regra de FIREWALL para LIMITE DE CONEXÕES SIMULTÂNEAS não funciona.

    Esse meu LIMITE está setado para 30 conexões e passa muito disso no TORCH se o WEB-PROXY está ativado.

    Você já passou por isso?



  17. #17

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por agrinfo Ver Post
    Se eu ativo o WEB-PROXY (ou seja, a origem para se conseguir os LOG´s de ACCOUNT onde fica registrado o que os Clientes estão acessando/navegando) a minha regra de FIREWALL para LIMITE DE CONEXÕES SIMULTÂNEAS não funciona.

    Esse meu LIMITE está setado para 30 conexões e passa muito disso no TORCH se o WEB-PROXY está ativado.

    Você já passou por isso?
    O motivo é que as conexões HTTP, quando vc ativa o proxy no mesmo servidor, passam a ser de SAIDA (output) e a regra controla somente FORWARD.

    Outra coisa, não é aconselhado aplicar o limite de conexões a navegação HTTP (TCP 80) e HTTPS (TCP 443) pois pode comprometer a qualidade da navegação.

  18. #18

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por netosdr Ver Post
    O motivo é que as conexões HTTP, quando vc ativa o proxy no mesmo servidor, passam a ser de SAIDA (output) e a regra controla somente FORWARD.

    Outra coisa, não é aconselhado aplicar o limite de conexões a navegação HTTP (TCP 80) e HTTPS (TCP 443) pois pode comprometer a qualidade da navegação.
    Tens razão! Vou liberar essas portas e também a 110, 25, 1863.

    Então você aconselha o proxy em separado?



  19. #19

    Padrão Re: Log de Navegação dos Clientes

    Citação Postado originalmente por agrinfo Ver Post
    Tens razão! Vou liberar essas portas e também a 110, 25, 1863.

    Então você aconselha o proxy em separado?
    É aconselhado manter SMTP (TCP 25) e POP3 (TCP 110) DENTRO do controle de conexões, pois tem muitos tipos de virus que utilizam estas portas.

    Quanto ao proxy em separado vai depender da sua necessidade, mas não é necessário, é só na regra de limitação de conexões vc especificar as portas 53, 80 e 443 como excessão a regra.

  20. #20

    Padrão Re: Log de Navegação dos Clientes

    se tiver algum espertinho na rede dele e fiz alguma coisa em um servidor e ter problemas com a justiça, como vai saber quem é da sua rede?


    Citação Postado originalmente por marlon Ver Post
    tbm preciso de obter essa informação! sei que não é da minha conta! mais pra que quer o log dos clientes ?!
    existe uma maneira de fazer usando o the dude. O mk gera um log e manda para um servidor onde esta instalado o the dude. as regras são:

    Código :
    /ip firewall filter
    add action=log chain=forward comment="LOG DA MOÇADA" disabled=no dst-port=21,22,23,25,80,110,139,143,443,445 log-prefix=192.168.2.x protocol=tcp src-address=192.168.2.0/24
    add action=log chain=forward comment="" disabled=no dst-port=21,22,23,25,80,110,139,143,443,445 log-prefix=192.168.3.x protocol=tcp src-address=192.168.3.0/24
    add action=log chain=forward comment="" disabled=no dst-port=21,22,23,25,80,110,139,143,443,445 log-prefix=192.168.5.x protocol=tcp src-address=192.168.5.0/24
    add action=log chain=forward comment="" disabled=no dst-port=21,22,23,25,80,110,139,143,443,445 log-prefix=172.169.0.x protocol=tcp src-address=172.169.1.0/24

    o codigo acima pede para o mk gerar log das portas principais de navegação e marcar um prefixo.

    depois em

    Código :
    /system logging action
    set remote bsd-syslog=no name=remote remote=172.16.10.2:514 src-address=0.0.0.0 syslog-facility=daemon syslog-severity=info target=remote

    o ip 172.16.10.2:514 é o servidor onde rodo o thedude como syslog configurado para receber os logs na porta 514

    Código :
    /system logging
    add action=remote disabled=no prefix=172.169.1.x topics=!debug,!web-proxy,!system
    add action=remote disabled=no prefix=192.168.2.x topics=!debug,!web-proxy,!system
    add action=remote disabled=no prefix=192.168.6.x topics=!debug,!web-proxy,!system
    add action=remote disabled=no prefix=192.168.3.x topics=!debug,!web-proxy,!system

    obs. O ideal seria ele fazer o log de todas as portas porque se alguem acessar um servidor com a porta 33333 ele naõ vai gravar o log, porem quando eu deixo todas as portas meu log fica de 40GB por dia, por isto restringi somente as portas de navegação mais utilizadas.

    o arquivo de log ficaria mais ou menos assim:

    Código :
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 172.169.10.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK,PSH), 192.168.2.247:1181->209.85.195.104:443, len 107
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.33.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK,PSH), 192.168.2.247:1181->209.85.195.104:443, len 107
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.65.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK,PSH), 192.168.2.247:1181->209.85.195.104:443, len 107
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.32.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK,PSH), 192.168.2.247:1181->209.85.195.104:443, len 107
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 172.169.10.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK), 192.168.2.247:1181->209.85.195.104:443, len 32
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.33.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK), 192.168.2.247:1181->209.85.195.104:443, len 32
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.65.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK), 192.168.2.247:1181->209.85.195.104:443, len 32
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 192.168.32.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK), 192.168.2.247:1181->209.85.195.104:443, len 32
    2010.04.27-06:13:57 <172.16.10.1>: firewall,info 172.169.10.x: 192.168.32.x forward: in:LAN out:WAN GLOBAL, src-mac 00:0a:52:7b:3d:7d, proto TCP (ACK), 192.168.2.247:1181->209.85.195.104:443, len 20
    Última edição por byosni; 01-05-2010 às 11:38.