+ Responder ao Tópico



  1. #1

    Red face Script desativar regra Proxy Paralelo

    Bom dia pessoal, venho aqui pedir a ajuda dos ilustres amigos, estou com um pequeno problema em meu servidor proxy (lusca + thunder), as vezes eles esta travando o lusca, sei q é o hd, já solucionei o problema, mas queria me prevenir, como ?
    Bom qndo o lusca travava, parava a navegação dos clientes, e o pior q aconteceu num fim de semana, gostaria de saber se algum amigo tem ou pode ajudar a fazer um script q monitore o squid no caso por porta e se estiver off ele desativar a regra nat q redireciona, assim os clientes nao ficam sem internet.

    Grato desde já pela ajuda de todos.

  2. #2

    Padrão Re: Script desativar regra Proxy Paralelo

    eu tive faserdo testes aqui com mesmo systema mais tb o lusca tarava um pergunta voce esta usando o mk-auth para isto ?
    eu aqui fis varios teste com ele a o lusca ficava off laine a mas com os tenste q fis nao éra o hd mas sim uma algus comandos no systema q nao consegi encomtrar mas logo q achar eu coloco aqui um passo a passo ok



  3. #3

    Padrão Re: Script desativar regra Proxy Paralelo

    Nao amigo, uso debian5 AMD64 + Lusca + Thundercache3.
    Procuros esse script como precaução, alguns amigos, montam um proxy em uma maquina comproblema e volta e meia trava. Pra esses casos q procuro um script q monitore a porta e nao o IP do servidor.

    Grato

  4. #4
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Script desativar regra Proxy Paralelo

    Bem, eu tentei fazer algo assim pelo SSH, o linux checava e mandava desativar as regras no servidor.
    Algo como 'ps aux | grep squid' e 'netstat -tnap | grep squid', mas isso faz tempo.



  5. #5

    Padrão Re: Script desativar regra Proxy Paralelo

    Ola pessoal, desculpa reativar esse topico, mas procurei e nao achei nadinha a respeito. Bom vamos la, instalei o FreeBSD com Thunder Cache em um servidor, ate seguindo o esquema do EasyThunderCachePro do proprio site do Thundercache, porem, o servidor andou travando o servico do thunder (ainda nao solucionei) e ghostaria de saber se alguemteria o script de desativar o redirecionamento quando a tal porta 8080 parasse de responder ou algo do tipo, assim meus clientes nao ficam sem navegar e o servidor ligado gera relatorios para q eu descubra o que esta travando ele. Obrigado

  6. #6

    Padrão Re: Script desativar regra Proxy Paralelo

    10.10.20.1.= proxy
    192.10.30.0 = rede local
    5128 = porta proxy
    /ip firewall mangle
    add action=add-dst-to-address-list address-list=\
    "SERVICO INDISPONIVEL P: 5128" address-list-timeout=20s chain=prerouting \
    comment=MANUT disabled=no protocol=tcp src-address=10.10.20.1 src-port=\
    5128 tcp-flags=rst

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="===== ACESSO - LINUX" disabled=no \
    dst-port=80 in-interface=LAN protocol=tcp src-address=192.10.30.0/24 \
    src-address-list="!SERVICO INDISPONIVEL P: 5128" to-addresses=10.10.20.1 \
    to-ports=5128



  7. #7

    Padrão Re: Script desativar regra Proxy Paralelo

    Voce podia pelo mesno dar o crédito ao amigo Guilherme do speedr, pois foi só ele posta no forum dele que a mesma ja apareceu aki.

  8. #8

    Padrão Re: Script desativar regra Proxy Paralelo

    Hahahaha.. ai Int21, cita pelo menos a referencia onde vc encontrou o material.

    A ideia nao foi copiada de lugar nenhum nao, fui eu mesmo que tive. Parece que vc chegou
    independentemente a mesma solucao ne?



  9. #9
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Script desativar regra Proxy Paralelo

    Citação Postado originalmente por int21 Ver Post
    10.10.20.1.= proxy
    192.10.30.0 = rede local
    5128 = porta proxy
    /ip firewall mangle
    add action=add-dst-to-address-list address-list=\
    "SERVICO INDISPONIVEL P: 5128" address-list-timeout=20s chain=prerouting \
    comment=MANUT disabled=no protocol=tcp src-address=10.10.20.1 src-port=\
    5128 tcp-flags=rst

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="===== ACESSO - LINUX" disabled=no \
    dst-port=80 in-interface=LAN protocol=tcp src-address=192.10.30.0/24 \
    src-address-list="!SERVICO INDISPONIVEL P: 5128" to-addresses=10.10.20.1 \
    to-ports=5128
    Apesar de não ser só quando uma porta está fechada que manda TCP RST, até que é engenhoso!

  10. #10

    Padrão Re: Script desativar regra Proxy Paralelo

    Cara, uso isso ja faz tempo PRACACETE pra serviços em redes internas no ramo industrial.
    Portanto desculpe, mas não há cópia nenhuma nisso! Quem estuda UM POUQUINHO de tcp sabe
    que os flags são visiveis pelo MK e entende como manipula-los.



  11. #11

    Padrão Re: Script desativar regra Proxy Paralelo

    Sim, sim.. Int21.. Foi exatamente isso que eu disse.
    É so uma coincidencia o topico existir a 7 meses e vc mandar essas suas regras
    logo depois de eu ter postado no forum do speedr.. haha

    Eu tinha ate dito isso no meu post, "voce chegou independentemente a solucao",
    so que por coincidencia vc postou num topico de qse 1 ano atras exatamente uns 10 dias
    depois que eu postei a ideia.. as coincidencias sao tantas..

  12. #12

    Padrão Re: Script desativar regra Proxy Paralelo

    tenho esta que uso no mk, se o mk nao consegui pingar o ip do servidor, ele desativa a regra, no meu caso esta no mangle, tem que altera o ip e a sequencia da regra 0,1...
    /tool netwatch
    add comment="" disabled=no down-script="/ip firewall mangle { disable 0 }" host=\
    187.33.236.150 interval=5s timeout=1s up-script=\
    "/ip firewall mangle { enable 0 }"



  13. #13

    Padrão Re: Script desativar regra Proxy Paralelo

    Pena que não se patenteia métodos né!

  14. #14

    Padrão Re: Script desativar regra Proxy Paralelo

    Int21,

    Voce tem toda razão vc é o cara parabéns e sucesso. Concerteza o usuário que abriu o topico deva estar feliz por ter conseguido ver como resolve seu problema.