Quantcast
Virtualização para substituir 3 servidores

Visite: BR-Linux ·  VivaOLinux ·  LinuxSecurity ·  Dicas-L ·  NoticiasLinux ·  SoftwareLivre.org

Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico

  1. Pessoal,

    tenho hoje 3 servidores sendo 2 windows 2003 e um linux então estou com uma máquina nova com a seguinte configuração:

    Dell power edge xeon 2.4ghz 4mb l2
    4GB ddr2 800mhz
    2xhds 250GB sata II
    rede broadcom 1Gb/s
    e etc...


    bom estou pensando em instalar o debian 64 bits nessa máquina sem interface gráfica e dentro dele rodar os 2 windows 2003 + o linux debian que vai ser meu firewall, proxy, thundercache e etc...


    minha pergunta é: roda tranquilo? os usuários vão notar perda de desempenho ao rodar em máquinas separadas?

    pergunto isso pois nunca instalei o xen no linux e só testei o wmware no windows e macbook rodando linux e windows virtualmente e eles rodam mais lentos do que o normal pois também usam os drives do wmware.

    o melhor seria o xen? onde encontro um tutorial pois serial assim:

    o dell seria o ip 10.0.1.1 e as máquinas virtuais teriam uma faixa de IP só para os usuários acessárem os aplicativos como se fossem 3 servidores em uma rede só.


    Aguardo a ajuda de vcs.


  2.    Publicidade


  3. Bem para o teu caso precisas saber o numero médio de usuário que utilizarão o servidor ao mesmo tempo e quanto uma requisição do cliente consome no servidor. e fazer um cálculos matemáticos.
    Mas se deres 2 gb de ram ao sever 2003 e com o iis instalado pode ter mais ou menos entre 100 á 200 clientes sem perdas considerareis.(0pnião própria).

  4. pouquissimos usuários...nos windows 2003 em media 25 usuários por server e no linux 30.

    então com o xen vou sentir performace boa? pergunto mais uma vez porque testei o windows dentro o wmware usando um macbook com processador 2.26ghz 1066mhz, 4GB ddr3(2GB para windows) e disco sata 320GB e ele fica lento as vezes e não é a mesma coisa de instalado direto em uma máquina real.

  5. não sei qual versão do vmware usaste. eu uso maquina virtuais wind... xp e debian leny e funcionam sem problemas, mas a se eu usar a maq... fisica para com muita frequencia ficam pequenos travamentos.
    uso duas maq... virtuais sem problemas, mas quando vou além disto tenho alguns problemas de lentidão, mas na maquina fisica (o s.o fica lento), as maquinas virtuais funcionam bem até que ponha o meu hardware a funcionar muito.

  6. o xen munca usei. basta testares.

  7. Rapaz, em termor de proxy, a performance tem que ser alta, thundercache então nem se fala, acho que tem pouca memoria, coloca mais 4 que roda ok, e tbm dependendo dos seu numero de clientes, o hd pro thunder seria melhor um de 500GB! por experiência lhe digo que pelo menos a memoria tem que ser maior!

    até mais!



    Citação Postado originalmente por lfernandosg Ver Post
    Pessoal,

    tenho hoje 3 servidores sendo 2 windows 2003 e um linux então estou com uma máquina nova com a seguinte configuração:

    Dell power edge xeon 2.4ghz 4mb l2
    4GB ddr2 800mhz
    2xhds 250GB sata II
    rede broadcom 1Gb/s
    e etc...


    bom estou pensando em instalar o debian 64 bits nessa máquina sem interface gráfica e dentro dele rodar os 2 windows 2003 + o linux debian que vai ser meu firewall, proxy, thundercache e etc...


    minha pergunta é: roda tranquilo? os usuários vão notar perda de desempenho ao rodar em máquinas separadas?

    pergunto isso pois nunca instalei o xen no linux e só testei o wmware no windows e macbook rodando linux e windows virtualmente e eles rodam mais lentos do que o normal pois também usam os drives do wmware.

    o melhor seria o xen? onde encontro um tutorial pois serial assim:

    o dell seria o ip 10.0.1.1 e as máquinas virtuais teriam uma faixa de IP só para os usuários acessárem os aplicativos como se fossem 3 servidores em uma rede só.


    Aguardo a ajuda de vcs.

  8. Amigo, nesse caso use VMware ESXi. Ele é free e é dedicado para Virtualização! vai por mim!!!

    Abraços

  9. algum how to para eu instalar no debian ou centos?

  10. o ESXi é um S.O. especifico de Virtualização.

    Free VMware vSphere Hypervisor: Bare Metal Hypervisor (Based on VMware ESXi)

    Baixe, instale, e me diga!

  11. Thiago, estou usando e estou gostando agora tenho 2 dúvidas:

    1)Se o sistema exsi não iniciar, como faço para entrar tipo com um live cd e pegar as máquinas virtuais e restaurar em outro?
    2)Se a primeira opção não for possível, então como faço para fazer backups das máquinas virtuais e restaurar em um exsi recém instalado(no caso de precisar reinstalar o sistema exsi que deu pau)?

  12. Amigo, para fazer a restauração, é necessario adquirir o Sistema de Backup da propria VMWare.

    O que voce pode fazer é, um script que faça a copia por SSH (SCP por ex) para um outro servidor.

    Ou Usar o Converter para transferir as maquinas mesmo online para outro server, no entanto voce teria que fazer isso regularmente.

    Ou ainda melhor, comprar a licença vCenter e programa-la para fazer sempre isso.

  13. blz...vc tem esse script ou algum how to para eu entrar via ssh no server pois tenho outros server linux e posso mandar para ele via backup e quando precisar reinstalar o exsi e restaurar para via ssh(isso é possível ne?)

  14. Amigo, tudo isso é possivel sim.

    No entanto, recomendo voce, a ler BEM todas as informações no site da VMware.

    Mexa bastante e depois poste aqui suas duvidas

  15. blz..thiago obg.

    só preciso de um help...estou coloando ip statico + alterando o nome do hots até aí blz clico em "esc" e depois clico em "Y" para salvar ele fica com esse ip por um tempo depois volta para o dhcp e o nome para localhost, sabe dizer o que é isso? estou na última versão e segui esse how to:

    Como instalar o VMware ESXi : Blog do Vicente

    OBS>: na verdade ele perde as configurações que fiz como senha de root, ip estático e volta do zero sozinho.

  16. Bom, vamos recapitular ok?

    Esta usando VMware ESXi 4.1 correto?

    Para alterar o IP, voce nao deve esquecer de salvar. Veja se voce esta salvando corretamente.

    Voce pode ir em "Restart Management Network". Assim, ele dará um restart na conexão de rede.

    Ele NAO PODE alterar sozinho de Estatico para Dinamico.

    Depois reinicie o servidor, veja se ele vai mudar.

    Poste aqui o resultado.

  17. até agora está normal..não alterou para dhcp. valeu.

    Agora chegou hoje o servidor que vai ser produção para o exsi: dell opteron 2.1ghz/8GB/Hd 1TB/rede broadcom 1GB/s.

    instalei nele blz...mas ao entrar com o cliente o HD não aparece não tenho opção de criar o datastore...será que ele não é compatível?

    lá em storage adapters só aparece o cdrom + a fita dat scsi em vmhba não mostra nada.

  18. Ok, voce não terá mais problemas com a "rede".

    Sobre o HD, pelo visto é SATA certo?

    Eu recomendo voce pegar a versão 3.5i e fazer o upgrade para 4.0, e depois atraves do esxupgrade fazer o upgrade manualmente para o 4.1.

    Tendo em vista que seu Servidor esta OK, porem não é reconhecido pela VMware sua unidade de HD.

    Mas antes, ligue para a Dell, e confirme, veja se seu Dell não esta homologado para Vmware.

  19. Isso sata II. A dell confirmou a virtualização e compatibilidade com o vmware.Agora não achei link para baixar a versão mais antiga 3.5i.Vc recomenda algum?

  20. Bom, se ela afirmar que esta compativel (o que eu tambem acho) então veja se reconhece a unidade sem problemas no Win2003 (na instalação) e no win2008 tambem.

    Uma coisa muito importante, é voce verificar na Bios do servidor, se esta habilitada a opção "Cpu Virtualizartion - ENABLE" (ou algo do tipo)

    Caso contrario dará o mesmo erro, só que relacionado a CPU.

  21. pois..por conhecidência estava testando isso agora...o windows 2003 e 2008 que tenho cds pois usamos na empresa foi normal..testei tb com centos os 64 bits que está instalado agora no HD.

  22. Certo, então de fato nao existe problemas por parte da controladora.

    Veja na Bios, se esta ativa a Virtualização

  23. não vi essa opção mas falei com a dell e disseram que já habilitado por padrão se não eu não conseguiria instalar o exsi.

    engraçado, já até coloquei outro HD mas acho que o problema está em reconhecer a controladora..mas o que me deixa encucado é dentro do viclient ele não reconhecer o Hd mas instala o exsi normal e reconhece o dvd-rom(sata) e a unidade de fita dat(scsi)

  24. Mas perai, voce falou que não conseguiu instalar o ESXi certo? Dava um Erro correto?

    De fatom, verifique na BIOS se esta habilitado. Por que de fato, voce NAO esta conseguindo instalar o ESXi.

    ==============================================

    RETIFICANDO:

    Desculpe pelo equivoco, voce então consgeuiu SIM instalar a VM, correto? No entanto não consegue adicionar um novo Datastore?

    Esse data store é um HD separado do HD que esta instalado a VM?

  25. Isso! ele está instalado mas não consigo add um datastore para poder criar uma máquina virtual.

    O datastore está sendo criado no mesmo HD que foi instalado o exsi.

    Quando mando criar ele não acha nada.

  26. Ahhhhhhhhhhhhhhh...

    Entao ta!!

    Voce não tem que adicionar NENHUM datastore a mais, tendo em vista que esta usando o mesmo HD para ele, ele ja faz os particionamentos necessarios.

    Agora é só Adicionar uma Nova Maquina Virtual, e configura-la.

    Para voce adicionar um Storage, voce precisar ter uma OUTRA unidade, diferente da que voce esta usando, entendeu?

  27. então esse é o problema..vou direto em criar máquina virtual, coloco o nome dela e o proximo passo ele pede para marcar o datastore só que está em branco entendeu?

    olha a imagem em anexo para vc ver.
    Clique na imagem para uma versão maior

Nome:	         Captura de tela 2011-01-07 s 15.31.01.jpg
Visualizações:	46
Tamanho: 	77,5 KB
ID:      	18467

  28. Interessante...

    Faça assim.

    Abre o vSphere Client, e va em "Configuration" e ao lado esquerdo em "Storage"

    Me de um Print dessa tela.

    E em "Storage Adpters" tambem.

    Em "Summary" me de um Print Screen tambem.

  29. segue
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Captura de tela 2011-01-07 s 15.49.13.jpg
Visualizações:	40
Tamanho: 	71,3 KB
ID:      	18468   Clique na imagem para uma versão maior

Nome:	         Captura de tela 2011-01-07 s 15.47.47.jpg
Visualizações:	39
Tamanho: 	51,2 KB
ID:      	18469   Clique na imagem para uma versão maior

Nome:	         Captura de tela 2011-01-07 s 15.47.26.jpg
Visualizações:	38
Tamanho: 	56,2 KB
ID:      	18470  

  30. Interessante.

    No minimo interessante.

    Faça 2 coisas.

    Nas opções de Storage

    1 - Clique em RESCAN ALL...

    Veja se aparece

    Nesse mesmo local, clique em Devices, e veja se aparece corretamente.

    Se nada disso der certo, sugiro, que use um DVD do Win7, e exclua todas as partições,
    e faça a instalação do Zero.

  31. testei o rescan e nada...já instalei em outro HD e nada...muito estranho mesmo.

    Estou baixando o citrix xen server para testar e ve se reconhece o HD normal.


  32.    Publicidade




Tópicos Similares

  1. Duvida com virtualização para 20 terminais
    Por Lincoln no fórum Serviços
    Respostas: 1
    Último Post: 09-10-2008, 08:37
  2. Sugestão para substituir o Nagios...
    Por darkwarrior no fórum Serviços
    Respostas: 2
    Último Post: 04-04-2008, 11:42
  3. Preciso de um script para renomear / substituir
    Por rogerim no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 31-10-2006, 11:31
  4. Respostas: 0
    Último Post: 15-07-2006, 14:09
  5. substituir todos os terminais para linux
    Por icefox no fórum Serviços
    Respostas: 1
    Último Post: 18-07-2004, 10:35