+ Responder ao Tópico



  1. #1

    Padrão Ddns

    Galera, estou com um MK 3.30 com PCC balanceando 2 Links PPPoE Dinamico e gostaria de publicar os dois IP´s em nomes de host diferentes.

    Alguem tem algum script que rode no 3.30 e eu consiga setar a interface que hospeda o endereço publico?

    PS.: Utilizo changeip.com

    Obrigado!

  2. #2

    Padrão Re: Ddns

    Eu tentei fazer isso que vc quer mais comigo não funcionou, mesmo setando o a interface pppoe...



  3. #3
    Avatar de ultralaser
    Ingresso
    May 2007
    Localização
    Presidente Prudente
    Posts
    176
    Posts de Blog
    1

    Padrão Re: Ddns

    para cada interface vc seta um ddns
    tenho no blog o script para um vc apenas deve fazer outro script setando para outra interface, faça o teste pois acho q deva funcionar

  4. #4

    Padrão Re: Ddns

    Citação Postado originalmente por ultralaser Ver Post
    para cada interface vc seta um ddns
    tenho no blog o script para um vc apenas deve fazer outro script setando para outra interface, faça o teste pois acho q deva funcionar
    Qual é a url do blog?

    Obrigado!



  5. #5

    Padrão Re: Ddns

    Citação Postado originalmente por rogeriodj Ver Post
    Eu tentei fazer isso que vc quer mais comigo não funcionou, mesmo setando o a interface pppoe...
    Vlw obrigado!

  6. #6



  7. #7

    Padrão Re: Ddns

    Citação Postado originalmente por ultralaser Ver Post
    Amigo, não consegui fazer funcionar com o seu script, mas encontrei um no forum do MK.com que funcionou, vou postar o code para quem precisar... Obrigado!
    -
    -
    -
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "YourChangeIPUserID"
    :global ddnspass "PASSWORD"
    :global ddnshost "MyRouterHostname.example.org"
    :global ddnsinterface "ether1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip

    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }

    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = "nothing" ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No changes necessary."

    }

    }