Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Alguém sabe como envio 02 arquivos anexados no mesmo email .
    Exemplo , tenho um arquivo backup.backup e outro backup.rsc , e gostaria que esses arquivos ficassem anexados no mesmo email .

    Valeu...

  2. Criar Script Chamado Backup e marcar todas as Policy o conteudo será:


    :global bkpname ([/system identity get name] . "-" . [/system clock get time]);
    :global assunto ("Backup-".[/system identity get name]);
    :global mailde "gzanatta@dominio.com.br";
    :global mailpara "backup@dominio.com.br";
    :global ipserver [:resolve "mail.dominio.com.br"];
    :global texto ("Arquivo Gerado dia: " . [/system clock get date] . " as: " . [/system clock get time] . "hs");
    :global arquivobkp "yes";
    :global arquivorsc "yes";

    :log info "Iniciando Procedimento de backup automatico por: Gustavo Zanatta"

    :log info "Efetuando Backup"
    :if ($arquivobkp = "yes") do={/system backup save name=$bkpname}
    :if ($arquivorsc = "yes") do={/export file=$bkpname}

    :delay 10s

    :log info "Configurando e enviando e-mails"
    /tool e-mail set server=$ipserver from="$mailde"
    :if ($arquivobkp = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-bkp" file="$bkpname.backup" body=$texto}
    :if ($arquivorsc = "yes") do={/tool e-mail send to=$mailpara subject="$assunto-rsc" file="$bkpname.rsc" body=$texto}

    :delay 10s
    :log info "E-mails enviado, removendo arquivos de Backup"

    :if ($arquivobkp = "yes") do={/file remove "$bkpname.backup"}
    :if ($arquivorsc = "yes") do={/file remove "$bkpname.rsc"}

    :log info "Backup Concluido"


    # Fim ------------------------------------

    Copiar e Colcar no New Terminal

    /system scheduler add name="Backup" start-date=dec/12/2009 start-time=00:00:01 interval=3d on-event="Backup" \
    policy=reboot,read,write,policy,test,password,sniff,sensitive


    -------------------

    Corra para o Abraço amigo



  3. Acho , que não e bem isso que estou querendo veja o script que uso para o envio do Backup:

    /tool e-mail send to=mikrotik@dominio.com.br subject=backup_teste file=backup.backup

    na opção " file " é onde eu informo o arquivo a ser anexado ao email , justamente nessa opção tenho como adicionar alguma regra para colocar outro arquivo anexado?

  4. Amigo presciso de ajuda nesse script o meu funcionou certino, mas o backup nao vai para o email vai somente o arquivo .rsc



  5. Provavelmente lá em file o arquivo backup.backup não está criado , vc precisa criar o arquivo para poder enviar .....
    criar arquivo ,utilize esse script abaixo:
    /system backup save name=backup
    depois que gerar o arquivo vc utiliza o scrip de envio por email.






Tópicos Similares

  1. Error script para enviar backup por email
    Por enternetinformatica no fórum Redes
    Respostas: 1
    Último Post: 26-04-2007, 21:16
  2. Respostas: 3
    Último Post: 03-03-2007, 11:19
  3. Backup por Email no MikroTik
    Por Mr_Dom no fórum Redes
    Respostas: 1
    Último Post: 06-04-2006, 09:13
  4. Backup por email
    Por Cybexy no fórum Redes
    Respostas: 1
    Último Post: 29-03-2006, 19:09
  5. Mandar log de backup por email
    Por Bolinhazin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-06-2005, 15:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L