Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde caros usuários do Under Linux, sou novato por aqui e ainda não consegui contribuir com informações devido ao pouco conhecimento que tenho, mas as informações obtidas foram de grande valia e desde já agradeço a todos que compartilham do seu conhecimento com pessoas como eu, desejo em breve estar podendo contribuir com novos usuários como eu.

    No momento a dúvida que tenho é sobre balanceamento de link no mikrotik com divisão por link, para ser mais claro minha situação é a seguinte:

    Hoje tenho atualmente um link de 1 mega full e dois adsl de 8 megas cada com 400 de UP, a divisão que desejo fazer é deixar toda a parte boa da internet no link full, ou seja, sites de bancos, uol, terra, msn, emails saindo por este link de 1 mega full e a parte "podre" saindo pelo adsl (lembrando que irei ficar com apenas uma adsl) orkut, p2p, downloads de arquivos exe, rar, zip, iso, youtube, e outras coisas mais que possam ser consideradas ruins saindo pelo link da adsl.

    Já procurei no forum porem encontrei so scripts explicando, mas como meu conhecimento é pouco sobre mikrotik não consegui implementar as regras, se alguém puder me ajudar em como procedo tal configuração atraves da parte grafica do mikrotik ficarei imensamente grato pela contruibuição.

    Também estou em dúvida se utilizo um computador com mikrotik instalao ou se uso um router 450g ou 750G qual deste me indicariam para esta função.

    Desde já agradeço a todos aqueles que puderem contribuirem para sanar minha dúvida.
    Última edição por elielton; 09-05-2010 às 15:37.

  2. Citação Postado originalmente por BillGates Ver Post
    10º Parte:

    LoadBalance:

    Servidor Mikrotik LoadBalance:

    Primeiramente vamos nomear nossas interfaces,lembre-se que estamos seguindo o cenário descrito no inicio do topico!

    Interfaces:
    Ficara parecido com a figura abaixo:
    http://img29.imageshack.us/img29/4194/tutorial04r.jpg

    Certo...

    O Cenário dos modens sera:
    1 Modem em Modo Bridge com DHCP Desativado e Endereço de IP: 192.168.1.1 Mascara 24/30...
    1 Modem em Modo Router com DHCP Desativado e Endereço de IP: 192.168.2.1 Mascara 24/30...
    1 Modem em Modo Router com DHCP Desativado e Endereço de IP: 192.168.3.1 Mascara 24/30...

    Agora em Ip address vamos adicionar nossos modens:
    "Iremos adicionar apenas os 2 modens que estão em router!"
    http://img269.imageshack.us/img269/4928/tutorial05.jpg

    e...

    http://img522.imageshack.us/img522/5834/tutorial06.jpg

    Tudo certo,então vamos criar um endereço para o novo Servidor Mikrotik LB:
    Ex.:
    http://img18.imageshack.us/img18/7788/tutorial07.jpg

    Criado os endereços em /ip address,iremos adicionar nossos modens no /ip routes

    Ficara conforme abaixo:
    http://img199.imageshack.us/img199/570/tutorial08.jpg

    e...

    http://img32.imageshack.us/img32/3696/tutorial09.jpg

    Pronto!Routes adicionados...

    Ow,pera ae... ta faltando um modem nessa história ai!!!
    E esta mesmo é o nosso modem em modo bridge 192.168.1.1,então vamos adiciona-lo!

    Básicamente o PPPoE Client,vamos mandar o MK discar...
    http://img20.imageshack.us/img20/4241/tutorial10.jpg

    Resumindo...


    Nesse Servidor Mikrotik LB teremos 4 placas de rede que serão distribuidas da seguinte forma:
    1 Placa de rede para nosso servidor LB se conectar ao Servidor Controle;
    3 Placas de rede para os modens.

    Então esse nosso servidor LB atuara como um modem,ou seja ele recebera os links e controlara as rotas de saida para cada serviço.
    Vamos fazer uma marcação de rotas e portas.


    Continua...
    Bill Gates !



  3. Citação Postado originalmente por BillGates Ver Post
    11º Parte:

    Regras para o LoadBalance:

    É isso ai pessoal,tamuh ae em pé acordado e deitado sem dormir!!!

    Vamos continuar com o tuto...

    Bom,nesse momento ja temos nosso servidor MK LB ou BL como preferir,então vamos às regras:

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL2 pela rede." \
    disabled=no src-address=192.168.2.1
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL3 pela rede." \
    disabled=no src-address=192.168.3.1
    add action=accept chain=forward comment=\
    "Total do Trafego gerado entre todos os Links" disabled=no out-interface=\
    Link-Gerenciado

    Regras 1 e 2: São para impedir o acesso ao modem pela rede.
    (Nosso amigo Demo Bill,sugeriu logo acima um tipo de regra um pouco mais complexa para o bloqueio de acesso aos modens.Estas citadas por mim estão correspondendo perfeitamente.).

    Regra 3: É para mostrar apenas o trafego total gerado pelos links.(Opcional)

    Vejam que não adicionei o modem DSL1 para a regra de bloqueio,uma vez que não consegui acessa-lo via browser nem pinga-lo.Deve ser pelo fato dele estar em modo bridge ou até mesmo porque não foi adicionado ao /ip address(Por estar sendo discado pelo MK,não é necessário adicionar ao /ip address).Irei fazer mais alguns testes e caso necessário teremos que adicionar ele às regras de bloqueio.
    Obs.:
    REGRAS ABERTAS A COMENTÁRIOS

    /ip firewall nat
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-1" disabled=no \
    out-interface=Internet
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-2" disabled=no \
    out-interface=Modem-DSL2
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-3" disabled=no \
    out-interface=Modem-DSL3

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Navegacao em FTP-Downloads" \
    disabled=no dst-port=21 new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=22 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=23 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=25 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Protocolo responsavel por resolucao de DNS" disabled=yes dst-port=53 \
    new-routing-mark=Link-2 passthrough=yes protocol=udp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em sites http e downloads" disabled=no dst-port=80 new-routing-mark=\
    Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=110 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=1080 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="Pacotes marcados para o Link-2" \
    disabled=no new-packet-mark=Link-2 passthrough=yes routing-mark=Link-2
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em sites https-encriptados" disabled=no dst-port=443 new-routing-mark=\
    Link-3 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em messenger - Windows Lime Messenger" disabled=no dst-port=1863 \
    new-routing-mark=Link-3 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em WebCam - Windows Live Messenger" disabled=no dst-port=6891 \
    new-routing-mark=Link-3 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="Pacotes marcados para o Link-3" \
    disabled=no new-packet-mark=Link-3 passthrough=yes routing-mark=Link-3

    Repare que a marcação para a regra da porta 53 esta desativada,em testes que estou realizando aqui,achei por bem deixar esta porta saindo pelo link default mesmo.REGRA EM TESTES

    Veja abaixo como ficara nossa tabela filter rules:
    http://img132.imageshack.us/img132/2785/tutorial14.jpg
    e...

    Veja abaixo como ficara nossa tabela Nat:
    http://img7.imageshack.us/img7/5981/tutorial13hrc.jpg
    e...

    Veja abaixo como ficara nossa tabela mangle:
    http://img406.imageshack.us/img406/6260/tutorial12.jpg

    Foi adicionando alguns comentários em algumas portas,então os colegas podem sugerir comentários para as que estão sem e até mesmo alguma correção para algum comentário feito.

    "Sugiro desabilitar o redirecionamento da porta 21(FTP),em testes aqui,percebi que alguns downs não estavam sendo iniciados devido a este redirecionamento,então caso alguém encontre problemas com FTP,deixe esta porta saindo pelo link default mesmo,ou seja,não faça nenhum redirecionamento desta porta"

    Continua...
    2 parte

    Autor: BillGates

  4. O Mkgaruja está ficando show de bola o topico, mas surgiu uma dúvida, como faço para colocar essas regras no MK, de que forma add elas, tem algum programa que exporta essas regras para o MK?

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL2 pela rede." \
    disabled=no src-address=192.168.2.1
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL3 pela rede." \
    disabled=no src-address=192.168.3.1
    add action=accept chain=forward comment=\
    "Total do Trafego gerado entre todos os Links" disabled=no out-interface=\
    Link-Gerenciado



  5. Amigo faz manualmente, entra no winbox..vai em ip>firewall> filter.

    Ai so seguir o Tuto,

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL2 pela rede." \
    disabled=no src-address=192.168.2.1
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL3 pela rede." \
    disabled=no src-address=192.168.3.1
    add action=accept chain=forward comment=\
    "Total do Trafego gerado entre todos os Links" disabled=no out-interface=\
    Link-Gerenciado

    t+






Tópicos Similares

  1. Respostas: 5
    Último Post: 07-05-2014, 08:02
  2. Squid - liberar sites proibidos por horario
    Por eng.cmp no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-05-2006, 12:02
  3. Relatórios dos sites acessados e hora com Squid
    Por haas no fórum Servidores de Rede
    Respostas: 4
    Último Post: 27-06-2005, 10:59
  4. Log de Site acessados
    Por edinaldojunior no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-08-2003, 10:51
  5. Respostas: 3
    Último Post: 19-01-2003, 10:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L