Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão hotspot + brazilfw

    Olá a todos, muito bom dia.

    bom... estou com o brazilfw rodando perfeitamente com o ip 192.168.0.2.

    e o mikrotik que esta trabalhando como hotspot, mas... quando tento autentica no hotspot.

    a conexão passa direto, o que fazer ? o ip do mikrotik faixa 192.168.0.0/24.

    o brazilfw que esta gerando dhcp para toda a rede.

    mikrotik esta como bridge, e quero o hotspot no mikrotik para autenticação.

    o que fazer ? para funciona perfeitamente com o hotspot ?

  2. #2

    Padrão Re: hotspot + brazilfw

    Amigo, o mikrotik que tem que gerar o dhcp server emcima do hotspot. Tire o dhcp do seu BrazilFw, e coloca e cria o novo servidor hotspot, e criar um servidor dhcp no IP> DHCP Server.



  3. #3

    Padrão Re: hotspot + brazilfw

    o brazilfw esta recebendo o link... o hotspot tava pegando com o dhcp do mikrotik mas não estava redirecionando o trafego, coloquei a regra de nat de redirecionamento mas a regra estava muito lenta. 800bps, 700bps.

  4. #4

    Padrão Re: hotspot + brazilfw

    thefox, você esta ligando o brazilfw ao mikrotik como ?? cabo cross?
    Qual a velocidade do seu link ?
    Assim que você faz a nat ele ja redireciona o trafego para o brazilfw.



  5. #5

    Padrão Re: hotspot + brazilfw

    o meu mikrotik esta no pc, pc-ap.

    o brazilfw esta ligado no mikrotik por cabo pc-pc.

    meu link é 4mb.

    preciso fazer apenas a regra do nat ou mais alguma regra de qeue e mangle ?

    as regras que apliquei, foi de um topico que criei aqui.

    a regra é essa que esta apresentado lentidão.\/

    add chain=dstnat src-address=192.168.10.0/24 dst-address=!192.168.0.2 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.2 \
    to-ports=3128 comment="" disabled=no

  6. #6

    Padrão Re: hotspot + brazilfw

    Então vc ta usando o brazilfw como proxy tambem ? eu pensei que você recebia o link no brasilfw.. e entra no mk e depois autentica os clientes por hotspot. A regra esta certa sim, mais vc tem que verificar se a porta é a 3128 mesmo. Você fazer o redirect você tambem pode fazer a marcação de cachefull no mangle e controlar a velocidade no queue tree se quiser posto as regra mais tarde.



  7. #7

    Padrão Re: hotspot + brazilfw

    Amigo segue as regras abaixo:

    Mangle:

    0 ;;; Squid - Cache Full
    chain=prerouting action=mark-connection new-connection-mark=proxy-hits
    passthrough=yes dscp=12
    1 chain=prerouting action=mark-packet new-packet-mark=proxy-squid
    passthrough=no connection-mark=proxy-hits

    Queue Tree

    0 name="SquidCache-Down" parent=global-out packet-mark=proxy-squid
    limit-at=2M queue=cache priority=8 max-limit=3M burst-limit=0
    burst-threshold=0 burst-time=0s
    1 name="SquidCache-Up" parent=global-in packet-mark=proxy-squid limit-at=2M
    queue=cache priority=8 max-limit=3M burst-limit=0 burst-threshold=0
    burst-time=0s

  8. #8

    Padrão Re: hotspot + brazilfw

    O mikrotik tem de ser o gateway da sua rede pra poder funcionar corretamente!!!



  9. #9

    Padrão Re: hotspot + brazilfw

    estou usando como proxy, tambem quero redirecionar todo o trafego mas como lhe falei a regra esta lenta.

    vou adicionar a regra do cache full... a porta do cache é 3128.

    obrigado pela ajuda, imediata brigadão mesmo.

  10. #10

    Padrão Re: hotspot + brazilfw

    Aqui eu fazia da seguinte forma entes.
    Colocava um a um pra Funcionar. depois juntava tudo. e só ai começava a mexer com cache dhcp e essas coisas. fica mais fácil achar os problemas dessa forma.
    E outra o hotspot do mk é automático cria ele e ele já lança os nats / mangles necessários para o básico.
    Aqui só éra necessário intervir manualmente nas versões antigas as novas não.
    Abraços.



  11. #11

    Padrão Re: hotspot + brazilfw

    bem... o brazilfw já esta funcionando normalmente, o modem ta como bridge o brazilfw disca.

    e sai internet para o mikrotik, só que, o cache do brazilfw só funciona normalmente quando ele gera o dhcp para os clientes.

    quando o mikrotik gera o dhcp para os clientes, e crio o redirecionamento por nat o redirecionamento é muito lento, fica 600bps, 700bps... e então pra isso precisa de mais alguma regra no queue ou no mangle para que a regra de redirecionamento funcione normalmente, tipo 1500kbps, 800kbps, por ai...

  12. #12

    Padrão Re: hotspot + brazilfw

    ok, tudo certo mais um problema, espero a ajuda de todos.

    o hotspot não esta controlando a banda do clientes.

    com a regra do proxy.



  13. #13

    Padrão Re: hotspot + brazilfw

    Mais você setou o tx / rx no profile?? em queue simple aparece o interface cliente hotspot?
    existe duas opções. setar no profile, ou deixar ele em default e criar o queue no ip de cada cliente, criar nos ips fica mais facil para colocar regras randonicas, tipo cliente pedro 512k até 00hr ai das 00hr até 6hr 2megas. entendeu?

  14. #14

    Padrão Re: hotspot + brazilfw

    Código :
    /ip firewall nat add chain=dstnat src-address=10.111.1.2  dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept 
     
    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80  action=dst-nat to-address=10.111.1.2 to-ports=3128

    Configuração de firewall mangle:

    Código :
    /ip firewall mangle chain=forward action=mark-connection  new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT 
     
    /ip firewall mangle chain=forward action=mark-packet  new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits 
     
    /ip firewall mangle chain=postrouting action=mark-connection  new-connection-mark=proxy-hits passthrough=yes tos=48  
     
    /ip firewall mangle chain=postrouting action=mark-packet  new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits

    Queue tree:

    Código :
    /queue tree add name="cache_hits" parent=global-out  packet-mark=proxy-squid limit-at=0 queue=default priority=8  max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s 
     
    /queue tree add 27   name="cache" parent=global-out  packet-mark=cache-hits limit-at=0 queue=default priority=8  max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s

    as regras que usei foi essa.

    criei o hotspot e limitei a banda por perfil.

    300/300 perfil basico.

    só que o perfil basico quando cito as regras não controla a banda.
    Última edição por osmano807; 08-06-2010 às 18:16.



  15. #15

    Padrão Re: hotspot + brazilfw

    Mais cade o codigo do profile? aparece algo em queue simple? se aparece desativa a marcação mangle pra ver se sem ela passa. pois não sei como funciona o bfw. se ele marcar tudo como hit vai passar tudo a full.

  16. #16

    Padrão Re: hotspot + brazilfw

    eu desabilitando a regra mangle, a velocidade do redirecionamento não será baixa?



  17. #17

    Padrão Re: hotspot + brazilfw

    Amigo acho que você não está entendendo, Quando uma coisa não funciona, Pela lógica tem que revisar item a item relacionado.
    ou seja não deixe passar a full nada, e veja se a velocidade é controlada pelo profile. e isso se faz desativando ou as regras mangle ou a do queue tree.
    veja no queue simple, se tem a regra criada pelo profile se não tiver não vai controlar nada.
    de um export total no mk cole em um .txt e anexe no post, que já te falo o que está errado.

  18. #18

    Padrão Re: hotspot + brazilfw

    ok... assim que pode posto as config aqui.

    obrigado, pela ajuda.



  19. #19

    Padrão Re: hotspot + brazilfw

    uso mk com hotspot, e instalei o brazilfw. agora queria integrar um ao outro para poder ser feito o cache. qual seria a regra no MK para poder um conversar com o outro ?
    Citação Postado originalmente por RobertoLima Ver Post
    Amigo acho que você não está entendendo, Quando uma coisa não funciona, Pela lógica tem que revisar item a item relacionado.
    ou seja não deixe passar a full nada, e veja se a velocidade é controlada pelo profile. e isso se faz desativando ou as regras mangle ou a do queue tree.
    veja no queue simple, se tem a regra criada pelo profile se não tiver não vai controlar nada.
    de um export total no mk cole em um .txt e anexe no post, que já te falo o que está errado.

  20. #20

    Padrão Re: hotspot + brazilfw

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    Configuração de firewall mangle:

    /ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT

    /ip firewall mangle chain=forward action=mark-packet new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits

    /ip firewall mangle chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes tos=48

    /ip firewall mangle chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits


    Queue tree:

    /queue tree add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=0 queue=default priority=8 max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s

    /queue tree add 27 name="cache" parent=global-out packet-mark=cache-hits limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    Considerações finais

    Bem pessoal, é isto aí, abaixo um exemplo de configuração de mangle e queue tree:

    Clique na imagem para uma versão maior

Nome:	         thumb_img2.JPG
Visualizações:	136
Tamanho: 	13,4 KB
ID:      	13510

    O que esta em vermelho seria o ip do seu proxy a ser redirecionado e em azul a porta do seu squid, confira a regra.