+ Responder ao Tópico



  1. Ola companheiros.
    Estou tentando a alguns dias fazer com que o Gentoo esteja funcional um servidor com uma controladora RAID (RAID bus controller: Intel Corporation 82801JIR (ICH10R) SATA RAID Controller)

    Segui os seguintes tutoriais na net,e tenho lido muito sobre o assunto:
    Gentoo Linux Documentation -- Gentoo Linux AMD64 Handbook
    RAID/Onboard - Gentoo Linux Wiki
    Gentoo Linux Documentation -- Gentoo/x86 Installation Tips & Tricks
    Gentoo Linux Documentation -- Gentoo Linux x86 with Software Raid and LVM2 Quick Install Guide
    RAID/Software - Gentoo Linux Wiki

    O Gentoo não reconhecia o RAID 1, em vez disso via os dois discos separados, sem espelhar.
    Depois de algumas batalhas, agora enxerga, e da boot. O boot carrega normalmente, contudo o sistema não consegue enxergar a partição onde esta localizado o /root
    O problema eh que o sistema, a cada reinicialização, altera o caminho das partições, que ficam no /dev/mapper.

    Antes era
    ddf1_4c53492020202020808629250000000039250214000014506
    e depois mudou para
    ddf1_4c5349202020202080862925000000003925070c000014506
    e depois
    ddf1_4c53492020202020808629250000000039250c4c000014506
    e assim a cada boot.

    No /dev/disk/by-id/ também ficam ponteiros/links para as particoes.
    Código :
    lrwxrwxrwx 1 root root  9 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R -> ../../sdb
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part1 -> ../../sdb1
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part2 -> ../../sdb2
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part3 -> ../../sdb3
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part4 -> ../../sdb4
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part5 -> ../../sdb5
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part6 -> ../../sdb6
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ41M3R-part7 -> ../../sdb7
    lrwxrwxrwx 1 root root  9 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G -> ../../sda
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part1 -> ../../sda1
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part2 -> ../../sda2
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part3 -> ../../sda3
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part4 -> ../../sda4
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part5 -> ../../sda5
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part6 -> ../../sda6
    lrwxrwxrwx 1 root root 10 May 19 10:02 scsi-SATA_ST31000340NS_9QJ4XJ5G-part7 -> ../../sda7

    #ls -l /dev/sd*
    Código :
    sda   sda1  sda2   sda3  sda4  sda5  sda6  sda7 sdb   sdb1  sdb2    sdb3  sdb4  sdb5  sdb6  sdb7
    O boot esta na particao 6

    Tentei montar o /dev/sda6 mas aparece
    Código :
    /dev/sda6 already mounted or /mnt/teste/ busy
    O mesmo erro aparece se eu tentar colocar o caminho no grub.

    Código :
    default 0
     timeout 30
     splashimage=(hd0,0)/boot/grub/splash.xpm.gz
     
     title Gentoo Linux kernel-x86_64-2.6.33-gentoo-r2
     kernel (hd0,0)/kernel-genkernel-x86_64-2.6.33-gentoo-r2 root=/dev/ram0  real_root=/dev/sda6 init=/linuxrc ramdisk=8192 dodmraid udev
     initrd (hd0,0)/initramfs-genkernel-x86_64-2.6.33-gentoo-r2
    Deveria seguir este caminho:
    Código :
    title Gentoo Linux kernel-x86_64-2.6.33-gentoo-r2
     kernel (hd0,0)/kernel-genkernel-x86_64-2.6.33-gentoo-r2 root=/dev/ram0  real_root=/dev/mapper/ddf1_4c53492020202020808629250000000039250214000014506   init=/linuxrc ramdisk=8192 dodmraid udev
     initrd (hd0,0)/initramfs-genkernel-x86_64-2.6.33-gentoo-r2
    Se alguém tiver uma ideia, apreciarei e muito!!
    Irei vencer essa quebra de braço.

    Ab, Duca
    Última edição por Duca; 19-05-2010 às 09:59.

  2. Consegui com outra controladora da Intel e fiz um tutorial:
    Instalando Gentoo em Servidor com Intel Corporation 82801 SATA RAID Controller - Blogs - Under-Linux.org

    Assim que conseguir com a controladora 82801JIR, farei algo parecido.

    Ab, Duca.






Tópicos Similares

  1. erro ao montar cdrom
    Por Dedao no fórum Servidores de Rede
    Respostas: 7
    Último Post: 27-09-2006, 12:43
  2. Erro ao montar CDROM
    Por Celio-Ctba no fórum Servidores de Rede
    Respostas: 2
    Último Post: 09-05-2006, 16:51
  3. Erro ao montar CDROM...
    Por ba no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 24-04-2006, 10:59
  4. Erro ao montar particao via NFS
    Por odbc no fórum Servidores de Rede
    Respostas: 11
    Último Post: 26-11-2004, 00:05
  5. ERRO AO MONTAR HD na inicializacao
    Por epf no fórum Servidores de Rede
    Respostas: 7
    Último Post: 01-10-2004, 16:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L