+ Responder ao Tópico



  1. #1

    Unhappy Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Olá, sou novo no fórum e nunca postei um tópico na minha vida, intaum... qualquer coisa me corrijam ae por favor, e quero agradecer desde já a ajudas que me derem.

    pessoal é o seguinte, tenho uma RB433 configurada com HotSpot na interface wireless, e outro na interface ethernet, essa RB

    recebe um cabo de um computador com mikrotik configurado com cache full, e esse mikrotik recebe um cabo de um moden adsl, só

    que o cache não está funcionando o cache para os clientes do hotspot... vou passar as configurações tanto do HotSpot quanto do Cache para vcs verem como td está configurado.


    SERVIDOR COM CACHE FULL
    Código :
    / ip firewall filter 
    add chain=input in-interface=internet protocol=tcp dst-port=3128 action=drop \
        comment="Bloqueio externo proxy" disabled=no
     
    / ip firewall nat 
    add chain=srcnat out-interface=internet action=masquerade comment="" \
        disabled=no 
    add chain=dstnat in-interface=rede protocol=tcp dst-port=80 action=redirect \
        to-ports=3128 comment="" disabled=no
     
    / ip firewall mangle 
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
        action=mark-connection new-connection-mark=squid-connection-HIT \
        passthrough=yes comment="Cache Squid" disabled=no 
    add chain=output connection-mark=squid-connection-HIT action=mark-packet \
        new-packet-mark=squid-packet-HIT passthrough=yes comment="" disabled=no 
     
     
    / ip web-proxy 
     
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy-ppnetwork" transparent-proxy=yes parent-proxy=0.0.0.0:0 \
        cache-administrator="PomPomNetworks" max-object-size=20480KiB cache-drive=system max-cache-size=36700160KiB \
        max-ram-cache-size=none 
     
    / ip web-proxy access 
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" disabled=no 
     
    / ip web-proxy cache 
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no
     
     
    / ip address 
    add address=192.168.5.254/24 network=192.168.5.0 broadcast=192.168.5.255 interface=rede comment="" disabled=no
     
    /dhcp-client
    add interface=internet add-default-route=yes use-peer-dns=yes use-peer-ntp=yes comment="" disabled=no 
     
     
    / queue tree 
    add name="Cache-full" parent=global-out packet-mark=squid-packet-HIT limit-at=1024000 queue=default priority=8 \
        max-limit=1024000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no 
    add name="upstream" parent=global-in packet-mark=test-up limit-at=1024000 queue=default priority=8 max-limit=1024000 \
        burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
     
    / queue simple 
    add name="teste" target-addresses=192.168.5.0/24 dst-address=0.0.0.0/0 interface=all parent=none direction=both priority=8 \
        queue=default-small/default-small limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no 
     
    / ip dhcp-server 
    add name="dhcp1" interface=rede lease-time=3d address-pool=dhcp_pool1 bootp-support=static authoritative=after-2sec-delay \
        disabled=no 
    / ip dhcp-server config 
    set store-leases-disk=5m 
    / ip dhcp-server lease 
    / ip dhcp-server network 
    add address=192.168.5.0/24 gateway=192.168.5.254 comment=""

    RB 433 COM HOTSPOT

    Código :
    /ip hotspot profile
     
    set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 \
        login-by=cookie,http-chap name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    add dns-name="" hotspot-address=192.168.2.254 html-directory=hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 \
        login-by=mac,cookie,http-chap mac-auth-password="" name=hsprof1 rate-limit="" smtp-server=0.0.0.0 split-user-domain=\
        no use-radius=no
    add dns-name="" hotspot-address=192.168.1.254 html-directory=hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 \
        login-by=mac,cookie,http-chap mac-auth-password="" name=hsprof2 rate-limit="" smtp-server=0.0.0.0 split-user-domain=\
        no use-radius=no
     
     
    /ip hotspot
     
    add address-pool=range-ip-clientes-wireless addresses-per-mac=1 disabled=no idle-timeout=5m interface=clientes \
        keepalive-timeout=none name="clientes rede wireless" profile=hsprof1
    add address-pool=range-ip-rede addresses-per-mac=1 disabled=no idle-timeout=1h interface=rede keepalive-timeout=1h name=\
        "clientes rede cabeada" profile=hsprof2
     
     
    /ip hotspot user profile
    set default idle-timeout=none keepalive-timeout=2m name=default shared-users=1 status-autorefresh=1m transparent-proxy=no
    add advertise=no idle-timeout=1h keepalive-timeout=1h name=profile-128k open-status-page=always rate-limit=80k/128k \
        shared-users=1 status-autorefresh=1m transparent-proxy=yes
    add advertise=no idle-timeout=1h keepalive-timeout=1h name=profile-256k open-status-page=always rate-limit=128k/256k \
        shared-users=1 status-autorefresh=1m transparent-proxy=yes
     
     
    /ip hotspot ip-binding
     
    add comment="R\E1dio AutoCar" disabled=no mac-address=00:4F:62:03:65:FD server="clientes rede wireless"
    /ip hotspot service-port
    set ftp disabled=no ports=21
     
    /ip address
    add address=192.168.2.254/24 broadcast=192.168.2.255 comment="" disabled=no interface=clientes network=192.168.2.0
    add address=192.168.1.254/24 broadcast=192.168.1.255 comment="" disabled=no interface=rede network=192.168.1.0
     
    /ip dhcp-client
    add add-default-route=yes comment="" default-route-distance=0 disabled=no interface=internet use-peer-dns=yes \
        use-peer-ntp=yes
     
    /ip dhcp-server
     
    add address-pool=range-ip-clientes-wireless authoritative=after-2sec-delay bootp-support=static disabled=no interface=\
        clientes lease-time=1h name=dhcp1
    add address-pool=range-ip-rede authoritative=after-2sec-delay bootp-support=static disabled=no interface=rede lease-time=\
        1h name=dhcp2
     
    /ip dhcp-server config
    set store-leases-disk=5m
     
    /ip dhcp-server network
    add address=192.168.1.0/24 comment="hotspot network" gateway=192.168.1.254
    add address=192.168.2.0/24 comment="hotspot network" gateway=192.168.2.254
     
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=no src-address=192.168.2.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=no src-address=192.168.1.0/24
     
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s \
        tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
        tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s

  2. #2

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Amigo eu nao manjo muito de proxy no mikrotik, entao vo deixar dois link que achei aqui no forum muito bom, eu acho que vai tirar suas duvida.

    LinuxAP - Cache Full

    Vídeo: Como fazer o cache-full no mikrotik - Blogs - Under-Linux.org

    Todos encontrado no blog do nosso Grande amigo AlexandreCorrea.



  3. #3

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    obrigado mktguaruja, vou olhar agora mesmo.

  4. #4

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    esqueci de comentar pessoal, é o seguinte, se eu ligar um pc direto no cache, ele faz cache normal, a questão eh quando ligo a RB no cache, dai naum funciona.



  5. #5

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Amigo, eu acho que você tem que fazer o redirect para a sua RB,

    add action=dst-nat chain=dstnat comment=">> Proxy <<" disabled=no \
    dst-address=!192.168.100.2 dst-port=80 protocol=tcp src-address=\
    10.1.1.0/24 to-addresses=192.168.100.2 to-ports=3128

    Amigo não é certeza, pois eu uso em proxy paralelo essa regra mais você ta fazendo o paralelo o mk não custa tenta.

    A Classe 192.168.100.2 é o ip do meu proxy.
    A porta 3128 é a do squid.
    E a classe 10.1.1.0/24 é a dos clientes.

  6. #6

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Citação Postado originalmente por mktguaruja Ver Post
    Amigo, eu acho que você tem que fazer o redirect para a sua RB,

    add action=dst-nat chain=dstnat comment=">> Proxy <<" disabled=no \
    dst-address=!192.168.100.2 dst-port=80 protocol=tcp src-address=\
    10.1.1.0/24 to-addresses=192.168.100.2 to-ports=3128

    Amigo não é certeza, pois eu uso em proxy paralelo essa regra mais você ta fazendo o paralelo o mk não custa tenta.

    A Classe 192.168.100.2 é o ip do meu proxy.
    A porta 3128 é a do squid.
    E a classe 10.1.1.0/24 é a dos clientes.

    mktguaruja, obrigado pela atenção novamente, segui sua dica de fazer a regra de redirecionamento da RB para o cache, acontece que quando add a regra e coloco ela no topo da lista, não consigo abrir nenhum site, e quando coloca ela abaixo das regras que o HotSpot criou automaticamente, ela naum funciona. Qual versão do MK vc usa? Antes eu usava a versão 2.9... alguma coisa, e agora q mudei para essa 3.15 notei q o HotSpot cria várias regras, e algumas ficam vermelhas, será q se eu esxcluir essas regras e deixa soh uma para o redirecionamento para o proxy, e outra regra do NAT funcionaria?



  7. #7

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Amigo você usa hotspot, tenta usar como pre-host, abre a regra vai em extras depois hotspot e coloque auth, apos isso volte para o o geral e coloco pre-host. t+

  8. #8

    Thumbs up Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    mktguaruja, vou viajar daki a pouco, mas assim q eu chegar vou fazer oq vc citou, obrigado pela força.



  9. #9

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Pessoal, consegui resolver o problema, fiz da seguinte forma, na maquina que está intalada o mikrotik com cache full, eu instalei o hotspot tbm, e deixei minha RB apenas em bridge, fazendo o redirecionamento do tráfego para o cache com a regra que o mktguaruja me passou. Ficou funcionando ok. Vou deixar assim provisóriamente até eu terminar de estudar slackware e aprender a mexer bem no squid, daí vou deixar hotspot na RB mesmo e deixar o squid fazendo Cache. Agradeço a ajuda do mktguaruja, e espero contribuir com muitos aqui no fórum, abraço a todos.

    quando consigo resolver o problema tenho que fechar este tópico aqui? ou não precisa fazer nada?

  10. #10

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Que bom amigo, sucesso ai pra ti, você conseguiu economicar link ? como fico a velocidade no cliente?



  11. #11

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    bom dia, com relação a economia de link, nos primeiros 5 dias foi quase que imperceptível a economia, mas agora segundo meus cálculos, estou tendo uma economia de uns 20 á 35%, pois antes meu link de entrada sempre ficava na faixa de uns 900kb, agora na hora de pico, geralmente vai para faixa de 600 a 700kb.

  12. #12

    Padrão Re: Ajuda para revisão/correção de rede com RB433 + MK OS cache full

    Boa noite, consegui economizar link sim mktguaruja, segundo meus cálculos aki estou tendo uma economia de uns 30% quando todo o pessoal do escritório está navegando, meu link é de 2mb, minha operadora consegue me mandar sempre 1,8mb, quando baixa muito cai para 1,5mb, e meu tráfego da internet ficava sempre no vermelho, depois desses 10 dias mais ou menos, vejo q em determinados horários, principalmente quando o pessoal aki do escritório está trabalhando, q meu consumo do link fica na faixa dos 1,4mb, e vejo o tráfego na rede do mikrotik bem alto, muitas requisições no proxy, e está atendendo muito minha nescessidade. Obrigado pelo ajuda, abraço, qualquer coisa estamos por ae.