+ Responder ao Tópico



  1. Olá pessoal, estou tentando colocar um servidor radius para rodar em eminha rede, porém estou tendo problema para fazer minha AP MK fazer a validação do mac e da chave WPA2.

    O seguinte teste eu fiz direto no prompt:

    radtest 00:08:9F:7F:FE:6C 00:08:9F:7F:FE:6C 127.0.0.1:1812 0 testing123

    Retorno:

    Sending Access-Request of id 6 to 127.0.0.1 port 1812
    User-Name = "00:08:9F:7F:FE:6C"
    User-Password = "00:08:9F:7F:FE:6C"
    NAS-IP-Address = 10.0.1.202
    NAS-Port = 0
    rad_recv: Access-Accept packet from host 127.0.0.1 port 1812, id=6, length=44
    Mikrotik-Wireless-PSK = "A56d1b75s9ww7c34"

    Tudo perfeito!

    Fiz ainda outro teste usando o programa NTRadPing direto do meu computador e conectado no mesmo ap, que deverá conversar com o radius.

    Retorno no radius.log:

    Auth: Login OK: [00:08:9F:7F:FE:6C/00:08:9F:7F:FE:6C] (from client base-serra port 0)

    Funciona também. Só que quando coloco o profile wpa2-raius da AP pra buscar no radius, eu não consigo conectar na AP.

    No log do radius.log não aparece o log nem de Login Ok, muito menos de Login incorrect, porém olhando nos logs do diretorio radacct vi o sequinte:

    Sat May 29 16:23:13 2010
    Service-Type = Framed-User
    NAS-Port-Id = "wlan1"
    User-Name = "00:08:9F:7F:FE:6C"
    Acct-Session-Id = "82100007"
    Acct-Authentic = Local
    Acct-Status-Type = Start
    NAS-Identifier = "AP-TESTE"
    NAS-IP-Address = 10.0.1.28
    Acct-Delay-Time = 0
    Acct-Unique-Session-Id = "86b6aa71aaf30233"
    Timestamp = 1275160993
    Request-Authenticator = Verified

    Sat May 29 16:23:18 2010
    Service-Type = Framed-User
    NAS-Port-Id = "wlan1"
    User-Name = "00:08:9F:7F:FE:6C"
    Acct-Session-Id = "82100007"
    Acct-Authentic = Local
    Acct-Status-Type = Stop
    Acct-Terminate-Cause = Port-Error
    Acct-Session-Time = 5
    Acct-Input-Octets = 0
    Acct-Input-Gigawords = 0
    Acct-Input-Packets = 0
    Acct-Output-Octets = 645
    Acct-Output-Gigawords = 0
    Acct-Output-Packets = 5
    NAS-Identifier = "AP-TESTE"
    NAS-IP-Address = 10.0.1.28
    Acct-Delay-Time = 0
    Acct-Unique-Session-Id = "86b6aa71aaf30233"
    Timestamp = 1275160998
    Request-Authenticator = Verified

    Já briguei com esse problema hoje o dia todo, nas pesquisas que fiz aqui no forum, não encontrei nenhum problema proximo do meu.

    Se alguém puder ajudar fico grato.

    Abraços a todos

  2. vc adicionou Mikrotik-Wireless-PSK ao dicionario do mikrotik no freeradius ??



  3. Olá Pedro.

    ATTRIBUTE Mikrotik-Wireless-PSK 16 string

    Se for isso adicionei sim no meu dicionary.mikrotik

    Grato

    Citação Postado originalmente por pedrovigia Ver Post
    vc adicionou Mikrotik-Wireless-PSK ao dicionario do mikrotik no freeradius ??






Tópicos Similares

  1. Problema freeradius
    Por colcci no fórum Servidores de Rede
    Respostas: 11
    Último Post: 14-02-2009, 12:13
  2. FreeRadius+MySql+DialUP Admin = Problema!!!!!
    Por hdad no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 26-05-2006, 09:06
  3. Problemas com Freeradius 1.05
    Por japaeye4u no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-09-2005, 17:42
  4. Problema com freeradius
    Por sarna no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-04-2005, 14:52
  5. Problemas com FreeRadius e MySql
    Por TheHawk no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-03-2005, 09:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L