+ Responder ao Tópico

  1. Boa tarde pessoal, gostaria de contar com a ajuda de vocês. Tenho um servidor no qual realizo acesso remoto via ssh porêm gostaria de realizar o acesso via Vnc ou qualquer outro ambiente gráfico mais eis que começa minha dor de cabeça. Toda vez que tento inicializar meu X remotamente pelo ssh acontece um problema como mostrado na imagem abaixo e toda vez que acesso o terminal via Vnc a tela fica somente preta. Não sei o que pode estar ocorrendo muito obrigado a quem leu disposto a ajudar. Grande abraço.
    http://img41.imageshack.us/img41/4914/gdh.png

    Mensagem ao tentar carregar X:

    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
    Current Operating System: Linux hostname47681.theplanet.host 2.6.18-128.1.6.el5 #1 SMP Wed Apr 1 09:19:18 EDT 2009 i686
    Build Date: 13 May 2010
    Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sat May 29 11:14:55 2010
    (EE) Unable to locate/open config file
    New driver is "ati"
    (==) Using default built-in configuration (55 lines)
    (EE) open /dev/fb0: No such file or directory
    FATAL: Module mach64 not found.
    [drm] failed to load kernel module "mach64"
    (EE) ATI(0): [dri] DRIScreenInit Failed
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    > Warning: Multiple symbols for level 1/group 1 on key <I5F>
    > Using XF86Sleep, ignoring XF86Standby
    > Warning: Symbol map for key <I5F> redefined
    > Using last definition for conflicting fields
    Errors from xkbcomp are not fatal to the X server
    Could not init font path element unix/:7100, removing from list!
    localuser:root being added to access control list
    No profile for user 'root' found
    Warning: Missing charsets in String to FontSet conversion
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.
    /usr/bin/twm: warning: font for charset JISX0208.1983-0 is lacking.
    /usr/bin/twm: warning: font for charset KSC5601.1987-0 is lacking.
    /usr/bin/twm: warning: font for charset GB2312.1980-0 is lacking.
    /usr/bin/twm: warning: font for charset JISX0201.1976-0 is lacking.
    /usr/bin/twm: warning: font for charset ISO10646-1 is lacking.


  2.    Publicidade


  3. Bem, pelo que estou vendo, o X iniciou. Parece que não tem é gerenciador de janelas. Instalou algum? (KDE, GNOME, XFCE)

  4. Citação Postado originalmente por osmano807 Ver Post
    Bem, pelo que estou vendo, o X iniciou. Parece que não tem é gerenciador de janelas. Instalou algum? (KDE, GNOME, XFCE)
    Como posso saber isso amigo? Obrigado pela ajuda.

    Amigo seguindo esse tutorial abaixo agora o erro é outro:
    Instalar a interface grafica numa instalcao do centos/fedora/redhat que foi instalado sem gnome



    • yum update (atualizar o yum);
    • yum upgrade (baixar e instalar os pacotes mais novos);
    • yum install system-config-display (instalar ferramenta para configurar a resolução gráfica do monitor);
    • execute [system-config-display];
    • yum install gnome-desktop gnome-session switchdesk (baixar e instalar o Gnome);
    • execute [switchdesk gnome] (para informar que o ambiente a ser utilizado será o Gnome);
    • instale também o gerenciador de sessões graficas, gdm:
    • yum install gdm
    • execute [startx] (para entrar no Gnome);

    O erro:
    root@hostname47681 [/]# startx
    xauth: creating new authority file /root/.serverauth.4386

    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
    Current Operating System: Linux hostname47681.theplanet.host 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:09:10 EDT 2010 i686
    Build Date: 13 May 2010
    Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 4 13:42:45 2010
    (EE) Unable to locate/open config file

    New driver is "ati"
    (==) Using default built-in configuration (55 lines)
    (EE) open /dev/fb0: No such file or directory
    FATAL: Module mach64 not found.
    [drm] failed to load kernel module "mach64"
    (EE) ATI(0): [dri] DRIScreenInit Failed
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    > Warning: Multiple symbols for level 1/group 1 on key <I5F>
    > Using XF86Sleep, ignoring XF86Standby
    > Warning: Symbol map for key <I5F> redefined
    > Using last definition for conflicting fields
    Errors from xkbcomp are not fatal to the X server
    Could not init font path element unix/:7100, removing from list!
    localuser:root being added to access control list
    No profile for user 'root' found
    SESSION_MANAGER=local/hostname47681.theplanet.host:/tmp/.ICE-unix/4424
    Window manager warning: Failed to read theme from file /usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml: Failed to open file '/usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml': No such file or directory
    Window manager warning: Failed to load theme "Clearlooks": Failed to open file '/usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml': No such file or directory
    Gnome-Message: gnome_execute_async_with_env_fds: returning -1
    Gnome-Message: gnome_execute_async_with_env_fds: returning -1
    libnotify-Message: Unable to get session bus: Failed to execute dbus-launch to autolaunch D-Bus session
    ** Message: Could not connect to power manager: Failed to execute dbus-launch to autolaunch D-Bus session

    ** (gnome-panel:4456): WARNING **: panel-applet-frame.c:1287: failed to load applet OAFIID:GNOME_Panel_TrashApplet:
    Failed to resolve, or extend '!prefs_key=/apps/panel/applets/trash_applet/prefs;background=none:;orient=up;size=x-small;locked_down=false
    Unable to open desktop file /usr/share/applications/redhat-email.desktop for panel launcher: No such file or directory
    Unable to open desktop file /usr/share/applications/openoffice.org-1.9-writer.desktop for panel launcher: No such file or directory
    Unable to open desktop file /usr/share/applications/openoffice.org-1.9-impress.desktop for panel launcher: No such file or directory
    Unable to open desktop file /usr/share/applications/openoffice.org-1.9-calc.desktop for panel launcher: No such file or directory

    ** (gnome-panel:4456): WARNING **: panel-applet-frame.c:1287: failed to load applet OAFIID:GNOME_MixerApplet:
    Failed to resolve, or extend '!prefs_key=/apps/panel/applets/mixer/prefs;background=none:;orient=down;size=x-small;locked_down=false
    libnotify-Message: Unable to get session bus: Failed to execute dbus-launch to autolaunch D-Bus session
    Error: unable to initialize pynotify
    could not attach to desktop process

    Quando pressionei Ctrl+C apareceu essa mensagem.

    waiting for X server to shut down The application 'bt-applet' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    The application 'puplet' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    Window manager warning: Lost connection to the display ':0.0';
    most likely the X server was shut down or you killed/destroyed
    the window manager.
    The application 'gnome-panel' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.


    xinit: unexpected signal 2.


    Resolvi fazer isto para ver se resolve.
    editei o arquivo /etc/inittab (+/- linha 18)

    de
    id:3:initdefault:
    para
    id:5:initdefault:

    5 corresponde ao modulo grafico.

    eu tentei até yum groupinstall “X Window System” “GNOME Desktop Environment”

    Parece que o X com Gnome está funcionando mas como meu acesso é remoto via ssh não tenho como testar somente pelo Vnc no qual a tela ainda permanece preta.

    Amigos passei só para avisar que resolvi o problema e agradecer pelo espaço cedido.
    Última edição por helioaff; 07-06-2010 às 10:35. Razão: resolvido


  5.    Publicidade




Visite: BR-Linux ·  VivaOLinux ·  Dicas-L