+ Responder ao Tópico



  1. Olá, já pesquisei bastante, fiz alterações, mudei a interface....

    Segui este tutorial https://under-linux.org/f134/servido...cional-132192/

    Fiz algumas alterações, mas no mais é isso.

    Criei 2 arquivos:
    /etc/sysconfig/cbq/cbq-0002.cristian.in
    /etc/sysconfig/cbq/cbq-0003.cristian.out

    Código :
    DEVICE=eth0,10Mbit,1Mbit
    RATE=50K
    WEIGHT=5Kbit
    PRIO=5
    RULE=192.168.0.181
    BOUNDED=yes
    ISOLATED=no
    Código :
    DEVICE=eth1,10Mbit,1Mbit
    RATE=50K
    WEIGHT=5Kbit
    PRIO=5
    RULE=192.168.0.181,
    BOUNDED=yes
    ISOLATED=no
    Código :
    [root@servidor ~]# cbq compile
    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.
     
    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.
     
    /sbin/tc qdisc del dev eth0 root
    /sbin/tc qdisc add dev eth0 root handle 1 cbq bandwidth 10Mbit avpkt 3000 cell 8
    /sbin/tc class change dev eth0 root cbq weight 1Mbit allot 1514
     
    /sbin/tc qdisc del dev eth1 root
    /sbin/tc qdisc add dev eth1 root handle 1 cbq bandwidth 10Mbit avpkt 3000 cell 8
    /sbin/tc class change dev eth1 root cbq weight 1Mbit allot 1514
     
    /sbin/tc class add dev eth0 parent 1: classid 1:2 cbq bandwidth 10Mbit rate 50K weight 5Kbit prio 5 allot 1514 cell 8 maxburst 20 avpkt 3000 bounded
    /sbin/tc qdisc add dev eth0 parent 1:2 handle 2 tbf rate 50K buffer 10Kb/8 limit 15Kb mtu 1500
    /sbin/tc filter add dev eth0 parent 1:0 protocol ip prio 100 u32 match ip dst 192.168.0.181 classid 1:2
     
    /sbin/tc class add dev eth1 parent 1: classid 1:3 cbq bandwidth 10Mbit rate 50K weight 5Kbit prio 5 allot 1514 cell 8 maxburst 20 avpkt 3000 bounded
    /sbin/tc qdisc add dev eth1 parent 1:3 handle 3 tbf rate 50K buffer 10Kb/8 limit 15Kb mtu 1500
    /sbin/tc filter add dev eth1 parent 1:0 protocol ip prio 100 u32 match ip src 192.168.0.181 classid 1:3
    Código :
    [root@servidor ~]# cbq start
    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.
     
    find: warning: you have specified the -maxdepth option after a non-option argument (, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.
    Abraços.

  2. Bom Dia...

    Primeiramente nas suas Confs, adicione Kbit ao lado do RATE e não só K....

    Depois nas linhas RULE, vc precisa dizer a mascara também, no caso se é para apenas um PC a limitação vc pode colocar IP/32...

    no seu caso RULE=192.168.0.181/32

    Faz este teste.... não tenho certeza se isso já resolve... mas ....

    Qualquer coisa poste aqui...

    Att
    Tiago Iahn



  3. Olá,

    Fiz as alterações:

    Código :
    DEVICE=eth0,10Mbit,1Mbit
    RATE=50Kbit
    WEIGHT=5K[COLOR=Red]bit[/COLOR]
    PRIO=5
    RULE=192.168.0.181/[COLOR=Red]32[/COLOR]
    BOUNDED=yes
    ISOLATED=no

    Código :
    DEVICE=eth1,10Mbit,1Mbit
    RATE=50K[COLOR=Red]bit[/COLOR]
    WEIGHT=5Kbit
    PRIO=5
    RULE=192.168.0.181/[COLOR=Red]32[/COLOR],
    BOUNDED=yes
    ISOLATED=no

    O Download ficou limitado de acordo, já o upload ficou sem limite.

    Tentei fuçando mesmo fazer alterações, até p/ eth0 mudei, sempre testando a velocidade, dando stop|compile|start.

    O Upload continuou sem limite.

    Obrigado pela ajuda.

  4. Na verdade não havia repara nas placas, mas ja que você falou.... utilize em ambas configurações IN e OUT a mesma interface... no caso a Interna....

    Ja limite na entrada do servidor e não na saida.... teste isto que deve funcionar....

    Entendeu o que eu quis dizer (talvez falei meio enrolado)? Coloca a ETHx (interna) nas duas cofigs...

    Valew...

    Att
    Tiago Iahn



  5. Olá, entendi, alterei para eth0 como já havia testado.

    eth0 é a interna.

    Continuou na mesma.

    Segunda pesquiso sobre este problema, agora ta meio corrido.

    Abraço.






Tópicos Similares

  1. Mikrotik nao esta limitando velocidade! Ajuda
    Por Tainã Sieben Cezar no fórum Redes
    Respostas: 40
    Último Post: 03-02-2017, 23:56
  2. IPFW não esta limitando velocidade!!!!
    Por CEP no fórum Sistemas Operacionais
    Respostas: 6
    Último Post: 21-02-2006, 20:45
  3. cbq não está limitando banda
    Por rootmaster no fórum Servidores de Rede
    Respostas: 12
    Último Post: 24-01-2006, 12:17
  4. :: Script Bandlimit :: Não está limitando a banda direito
    Por petrolina360graus no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-11-2005, 09:43
  5. :: Bandlimit não está limitando a banda direito ::
    Por petrolina360graus no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-11-2005, 10:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L