Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Load Balnced PCC 3 Links em Bridge+Failover

    Bom amigos após testar varias soluções de balanço cheguei a esta configuração,Considerando que funcionam bem.
    Esta configuração também permite fallover no caso de qualquer uma das conexões pppoe cair ou desconectar, A primeira seção das regras de mangle são feitas explicitamente para permitir conexões de entrada como Winbox / ftp / http / etc, basicamente, qualquer coisa que você deseja transmitir para um usuário interno irá funcionar correctamente e ser enviadas de volta o mesmo link (incluindo qualquer coisa adicionado por regras upnp).
    Antes de mais nada gostaria de ressaltar pra nao usar copiar e colar,entender as regras e adaptar as suas necessidades e fundamental para um bom funcionamento do sistema.

    Clique na imagem para uma versão maior

Nome:	         diagrama.JPG
Visualizações:	685
Tamanho: 	18,5 KB
ID:      	12312

  2. #2

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    regras
    *******************************************************************
    /ip route
    add check-gateway=arp comment="WAN 3 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan3
    add check-gateway=arp comment="WAN 2 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 1 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 1 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 2 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 3 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan3
    add check-gateway=arp comment="WAN 1 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 2 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 3 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan3
    add check-gateway=arp comment="Default Route - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    add check-gateway=arp comment="Default Route - Distance 2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe
    add check-gateway=arp comment="Default Route - Distance 3" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=arp comment="Rota estática - WAN1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=static-wan1
    add check-gateway=arp comment="Rota estática - WAN2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=static-wan2
    add check-gateway=arp comment="Rota estática - WAN3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=static-wan3
    ###########################################################

    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=201.7.176.0/20 comment="Vdeos - Globo" disabled=no list=loopback
    add address=208.84.247.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.154.56.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    add address=200.201.166.0/24 comment="" disabled=no list=loopback
    add address=200.201.173.0/24 comment="" disabled=no list=loopback
    add address=200.201.174.0/24 comment="" disabled=no list=loopback
    add address=200.141.207.3 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback

    ###########################################################

    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOAD BALACED" disabled=no dst-address-list=loopback in-interface=lan
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan1" connection-state=new disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 \
    passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan2" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 \
    passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan3" connection-state=new disabled=no in-interface=wan3-pppoe new-connection-mark=wan3 \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan1" connection-state=established disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan2" connection-state=established disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan3" connection-state=established disabled=no in-interface=wan3-pppoe \
    new-connection-mark=wan3 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan1" connection-state=related disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan2" connection-state=related disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan3" connection-state=related disabled=no in-interface=wan3-pppoe \
    new-connection-mark=wan3 passthrough=yes
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan1" connection-mark=wan1 disabled=no new-routing-mark=static-wan1 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan2" connection-mark=wan2 disabled=no new-routing-mark=static-wan2 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan3" connection-mark=wan3 disabled=no new-routing-mark=static-wan3 passthrough=no
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (3 possibilidades) - opção 1" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (3 possibilidades) - opção 2" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (3 possibilidades) - opção 3" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan3_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/2
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (3 possibilidades) - opção 1" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:3/0
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (3 possibilidades) - opção 2" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:3/1
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (3 possibilidades) - opção 3" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan3_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:3/2
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (3 possibilidades) - opção 1" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (3 possibilidades) - opção 2" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (3 possibilidades) - opção 3" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan3_pcc_conn passthrough=yes per-connection-classifier=both-addresses:3/2
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 1" connection-mark=wan1_pcc_conn disabled=no new-routing-mark=wan1 passthrough=\
    yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 2" connection-mark=wan2_pcc_conn disabled=no new-routing-mark=wan2 passthrough=\
    yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 3" connection-mark=wan3_pcc_conn disabled=no new-routing-mark=wan3 passthrough=\
    yes

    *******************************************************************

    bom e isso ai galera ja estou usando a 2 meses e esta muito bom! nao esqueça de clicar na estrelinha para agradecer vlw.



  3. #3

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Muito bom amigo...

  4. #4

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Amigo isso era justamento o q eu estava procurando, qual RB o amigo me indica para usar com essa configuração? vai apenas isso dentro do MK ou precisa colocar mais alguma coisa desculpe as perguntas mas eu nao tenho muita experiencia em configurar MK, muito obrigado, depois eu posto os resultados.



  5. #5

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    amigo eu uso uma rb750 e funciona muito bem nela, sobre as regras cada caso e um caso eu uso em 3 link de 2M,seria bom vc adaptar as suas necessidades,vc precisaria apenas fazer pppoe cliente e os respectivos mascaramentos.

  6. #6
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    "~Load Balance PCC 3 Links em Bridge+Failover~"

    Parabéns caros! Muitas pessoas já procuraram posts que vão direto ao assunto igual ao seu, coisa que era difícil de encontrar agora o forun esta evoluindo com posts mais fáceis de entender, infelizmente não dei a sorte de você ter postado uns tempos atras passei um pouco de raiva para solucionar o meu problema que era um balance mas graças a deus consegui e parabéns novamente pois pessoas não vão passar o tanto de raiva que eu passei. E de mim você leva uma qualificação positiva.

    -----------------------------------------------------------------------------

    Para melhoress Informações ligue: (27) 9981-1136 "Malon Bolzan"

    Msn: [email protected]


    Provedor de Internet Livre Wi-Fi "Conectando Você ao Mundo...!"

    Suporte Mikrotik RouterOs

    Páginas de Bloqueio, Páginas de Login Personalizadas e Etc...
    Última edição por marlon; 18-06-2010 às 09:34.



  7. #7

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Citação Postado originalmente por sostenes Ver Post
    amigo eu uso uma rb750 e funciona muito bem nela, sobre as regras cada caso e um caso eu uso em 3 link de 2M,seria bom vc adaptar as suas necessidades,vc precisaria apenas fazer pppoe cliente e os respectivos mascaramentos.
    Vlw amigo muito obrigado vou testar e depois posto aqui os resultado e se quiser me adicionar no msn [email protected]

  8. #8

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Ola "sostenes" muito bom as regras, so uma questao, gostaria um poco mais d explicaçao,, sobre o FAILOVER... vc ta utilizando check-gateway=ARP .. pq ARP ??
    Sobre o PCC no mangle vc pra fazer o FAILOVER usou as mesmas regras, so q em connection-state=new , related, stabelecid. isso q faz o Failover ativar certo...? quando cai um dos links ele assume o related, isso, essa parte q eu nao entendi, pois o PCC usa a sequencia q esta no per-connection-classifier=both-addresses:X/X correto, entao como ele vai verificar quem esta no ar, e ativar correto?? so essa parte amigo gostaria de sua explicaçao se possivel obrigado... pq pelas regras isso vai virar um WIKI.



  9. #9

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    e ai amigo aka2005 tudo blz? bom como eu disse acima testei varias formular de balaço pcc numa delas tinha a forma de checar a conexao pppoe seria com arp (nao sei como,mas funciona)se vc descobrir e divulgar ficarei grato.
    Com as rotas que eu listei no exemplo,cada um tem duas rotas de backup que ele vai para failover se um ou mais não estão funcionando.
    Por exemplo: se a linha adsl3 desconecta e fica offline,as rotas com "distância = 1 'agora será marcada como inválida / por isso vai cair a qualquer rotas mais distantes (distância = 2 e, em seguida, distância = 3 e assim por diante).
    Neste caso, temos dado a cada um dos eixos WAN1, WAN2, wan3, duas rotas de backup para cada .. assim, além das ligações ao utilizador final e quebrando a re-ligação (msn, VPN etc) você não tem tempo de inatividade real apenas como tudo muda ao longo de uma das outras conexões até que o Adsl volte a ficar online.

    nota: marcas adicionadas estáticas de roteamento para o tráfego de entrada, como de entrada nunca deve cair sobre as rotas de backup, enquanto que de saída deve passar por cima de tudo que está disponível.
    Última edição por sostenes; 19-06-2010 às 11:56.

  10. #10

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Opa entendindo a parte de marcaçao de rotas e sobre a distancia, q ele assume a sequencia la.. 1, distancia 2, e 3, quando elas cairem... ate ai OK... o q nao entendi é o PCC...
    O PCC pega as rotas wan1, wan2 e wan3, e marca e joga elas em quencia no peer la certo, a cada conexao solicitada ele joga pra marcaçao 1, 2 e 3... bom suponhando q a adsl 2 caia... nao entendi como ele ve q ela caiu la no mangle, e tiro ela da sequencia la, sendo q ta sendo peer-conection 3/0, 3/1 e 3/2... ele ainda vai fica jogando trafico pra rota parada... ali q nao entendi o q vc fez colega.



  11. #11

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    ola grande aka2005,esse pcc nao segue o wikki,a grande sacada sao os rands de 3 possibilidades ele faz uma qualificação dos pacotes que descartado do classificador, pelos teste qu fiz aki e isso que o corre ,a marcação e somente um fluxo que o corre na interface clientes. quando desabilito uma conexão pppoe ou desligo um dos modens ,o consumo dos restantes continua balanceado na media.

  12. #12

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    ha ia me esquecendo em testes aki esse balance ficou mais efetivo na versao 3.30 do mk



  13. #13

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Ok, vo observa o andamento dessas configuraçoe, por enquanto ta ok aki... vlw pelas dicas ai...

  14. #14

    Smile Re: Load Balnced PCC 3 Links em Bridge+Failover

    Kara!!!! Muito bom!!!! Era exatamente isso que eu estava procurando!!! PERFEITO!!!! Parabéns!!!! Muito obrigado pela contribuição a comunidade under!!!



  15. #15

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    ok pra agradecer clique na estrelinha.

  16. #16

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Amigo, só uma dúvida... se os três links forem da mesma operadora tem algum problema??? Gostaria de fazer com três links da oi de 1MB todos ADSL residencial.
    Última edição por Godfather; 21-06-2010 às 15:19.



  17. #17

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    nao tem problema, amigo essa classificação e para 3 links de proporção igual ou seja 3 links de mesmo valor.

  18. #18

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Amigo e se os adsl's forem de velocidade diferentes ? tipo de 1 e 4 mb ?
    Outra coisa vc poderia me passar uma mp com valor que vc cobra para implantar essas regras ?



  19. #19

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Estou vendo e irei testar a de 4 links.
    valeu meu nobre por disponibilzar as regras!!
    Última edição por zipfile; 27-06-2010 às 22:03.

  20. #20

    Padrão Re: Load Balnced PCC 3 Links em Bridge+Failover

    Caro amigo eu uso 3 links aDSL de 8MB e autenticacao dos meus clientes é por HotSpot isso faria alguma diferenca?

    Num PCC q eu tinha o check-gateway=ping e o seu é arp, qual a diferença entre um e outro?

    Faltaram algumas coisas e eu fiz na orelhada sera q alguem poderia conferir pra mim para ver se esta tudo correto?

    Tem que ter mais alguma coisa na RB ou só é isso mesmo?

    regras
    *******************************************************************

    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:71:80:AB master-port=none mtu=1500 name=wan1 speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:71:80:AC master-port=none mtu=1500 name=wan2 speed=100Mbps
    set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:71:80:AD master-port=none mtu=1500 name=wan3 speed=100Mbps
    set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:71:80:AE master-port=none mtu=1500 name=ether4 speed=100Mbps
    set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:71:80:AF master-port=none mtu=1500 name=ether5 speed=100Mbps
    ###########################################################

    /ppp profile
    set default change-tcp-mss=yes comment="" name=default only-one=default use-compression=default use-encryption=default use-vj-compression=default
    set default-encryption change-tcp-mss=yes comment="" name=default-encryption only-one=default use-compression=default use-encryption=yes use-vj-compression=default
    ###########################################################

    /ip address
    add address=10.0.10.1/30 broadcast=10.0.10.3 comment="" disabled=no interface=ether5 network=10.0.10.0
    ###########################################################

    /ip firewall filter
    add action=accept chain=input comment="" disabled=no in-interface=!wan1 src-address=10.0.10.0/30
    add action=accept chain=input comment="" disabled=no in-interface=!wan2 src-address=10.0.10.0/30
    add action=accept chain=input comment="" disabled=no in-interface=!wan3 src-address=10.0.10.0/30
    ###########################################################

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan3
    ###########################################################

    /ip firewall mangle
    add action=mark-connection chain=input comment="Marca nova conexo de entrada wan1" connection-state=new disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexo de entrada wan2" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexo de entrada wan3" connection-state=new disabled=no in-interface=wan3-pppoe new-connection-mark=wan3 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada estabelecidas wan1" connection-state=established disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada estabelecidas wan2" connection-state=established disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada estabelecidas wan3" connection-state=established disabled=no in-interface=wan3-pppoe new-connection-mark=wan3 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada relacionadas wan1" connection-state=related disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada relacionadas wan2" connection-state=related disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexo de entrada relacionadas wan3" connection-state=related disabled=no in-interface=wan3-pppoe new-connection-mark=wan3 passthrough=yes
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan1" connection-mark=wan1 disabled=no new-routing-mark=static-wan1 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan2" connection-mark=wan2 disabled=no new-routing-mark=static-wan2 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan3" connection-mark=wan3 disabled=no new-routing-mark=static-wan3 passthrough=no
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opo 1" connection-mark=wan1_pcc_conn disabled=no new-routing-mark=wan1 passthrough=yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opo 2" connection-mark=wan2_pcc_conn disabled=no new-routing-mark=wan2 passthrough=yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opo 3" connection-mark=wan3_pcc_conn disabled=no new-routing-mark=wan3 passthrough=yes
    ###########################################################

    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=201.7.176.0/20 comment="Vdeos - Globo" disabled=no list=loopback
    add address=208.84.247.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.154.56.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    add address=200.201.166.0/24 comment="" disabled=no list=loopback
    add address=200.201.173.0/24 comment="" disabled=no list=loopback
    add address=200.201.174.0/24 comment="" disabled=no list=loopback
    add address=200.141.207.3 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback
    ###########################################################

    /ip route
    add check-gateway=arp comment="WAN 1 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 3 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan3
    add check-gateway=arp comment="WAN 2 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan2
    add check-gateway=arp comment="Rota esttica - WAN3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=static-wan3
    add check-gateway=arp comment="WAN 3 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan3
    add check-gateway=arp comment="WAN 3 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan3
    add check-gateway=arp comment="WAN 2 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 1 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan1
    add check-gateway=arp comment="Rota esttica - WAN2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=static-wan2
    add check-gateway=arp comment="WAN 2 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan2
    add check-gateway=arp comment="Default Route - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    add check-gateway=arp comment="Default Route - Distance 2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe
    add check-gateway=arp comment="Rota esttica - WAN1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=static-wan1
    add check-gateway=arp comment="WAN 1 - Distance 3" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=wan3-pppoe routing-mark=wan1
    add check-gateway=arp comment="Default Route - Distance 3" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe

    *******************************************************************
    Última edição por maxmelo; 28-06-2010 às 01:07. Razão: Acrescentar mais algumas linhas