Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Políticas de rotas com PCC e 4 links roteados

    Bom amigos após testar varias soluções de balanço cheguei a esta configuração,Considerando que funcionam bem.
    Esta configuração também permite fallover no caso de qualquer uma dos Links cair ou Desligar, A primeira seção das regras de mangle são feitas explicitamente para permitir conexões de entrada como Winbox / ftp / http / etc, basicamente, qualquer coisa que você deseja transmitir para um usuário interno irá funcionar correctamente e ser enviadas de volta o mesmo link (incluindo qualquer coisa adicionado por regras upnp).
    Antes de mais nada gostaria de ressaltar pra nao usar copiar e colar,entender as regras e adaptar as suas necessidades e fundamental para um bom funcionamento do sistema.

    *******************************************************************
    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan1
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan2
    add address=10.113.0.2/24 network=10.113.0.0 broadcast=10.113.0.255 interface=wlan3
    add address=10.114.0.2/24 network=10.114.0.0 broadcast=10.114.0.255 interface=wlan4

    ###########################################################
    / ip firewall mangle
    add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
    add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
    add chain=input in-interface=wlan3 action=mark-connection new-connection-mark=wlan3_conn
    add chain=input in-interface=wlan4 action=mark-connection new-connection-mark=wlan4_conn
    add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wlan1
    add chain=output connection-mark=wlan2_conn action=mark-routing new-routing-mark=to_wlan2
    add chain=output connection-mark=wlan3_conn action=mark-routing new-routing-mark=to_wlan3
    add chain=output connection-mark=wlan4_conn action=mark-routing new-routing-mark=to_wlan4
    add chain=prerouting dst-address=10.111.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.112.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.113.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=10.114.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:4/0 \
    action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:4/1 \
    action=mark-connection new-connection-mark=wlan2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:4/2 \
    action=mark-connection new-connection-mark=wlan3_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:4/3 \
    action=mark-connection new-connection-mark=wlan4_conn passthrough=yes
    add chain=prerouting connection-mark=wlan1_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan1
    add chain=prerouting connection-mark=wlan2_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan2
    add chain=prerouting connection-mark=wlan3_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan3
    add chain=prerouting connection-mark=wlan4_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan4
    add chain=prerouting connection-mark=wlan3_conn in-interface=Local action=mark-routing new-routing-mark="http1" dst-port=80 protocol=tcp
    add chain=prerouting connection-mark=wlan4_conn in-interface=Local action=mark-routing new-routing-mark="http2" dst-port=80 protocol=tcp

    ###########################################################
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_wlan1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark=to_wlan2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.113.0.1 routing-mark=to_wlan3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.114.0.1 routing-mark=to_wlan4 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark="http1" check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark="http2" check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.113.0.1 distance=3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.114.0.1 distance=4 check-gateway=ping

    ******************************************************************
    / ip firewall nat
    add chain=srcnat out-interface=wlan1 action=masquerade
    add chain=srcnat out-interface=wlan2 action=masquerade
    add chain=srcnat out-interface=wlan3 action=masquerade
    add chain=srcnat out-interface=wlan4 action=masquerade
    ******************************************************************
    nao esqueça de clicar na Estrelinha para agradecer.

  2. #2

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Sostenes, vendo as regras que vc postou para 3 links, vi que nao postou as regras abaixo, sao necessárias?
    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=201.7.176.0/20 comment="Vdeos - Globo" disabled=no list=loopback
    add address=208.84.247.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.154.56.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    add address=200.201.166.0/24 comment="" disabled=no list=loopback
    add address=200.201.173.0/24 comment="" disabled=no list=loopback
    add address=200.201.174.0/24 comment="" disabled=no list=loopback
    add address=200.141.207.3 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback

    valeu
    Última edição por zipfile; 07-07-2010 às 08:45.



  3. #3

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    sim amigo,elas servem para esses sites sairem somente pelo link defult.
    outra coisa, vc precisa de adicionar uma regra acima de todas no mangle.
    ****************************************************************************************/ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOAD BALACED" disabled=no dst-address-list=loopback in-interface=lan
    ****************************************************************************************
    onde "lan" e a inteface que vai para seus clientes.

  4. #4

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    e impressao minha ou as regras para os 3 links vc fez com mais carinho? tudo comentada e tal, tem mais detalhes la que nao encontrei aqui.
    abraçao



  5. #5

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por sostenes Ver Post
    Antes de mais nada gostaria de ressaltar pra nao usar copiar e colar,entender as regras e adaptar as suas necessidades e fundamental para um bom funcionamento do sistema.
    amigo nao e que fiz com mais carinho,a ideia e a mesma, so muda a marcação das interfaces.
    fiz assim pro pessoal comparar , analisar e aprender com as regras.
    Última edição por sostenes; 30-06-2010 às 01:36.

  6. #6
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por sostenes Ver Post
    amigo nao e que fiz com mais carinho,a ideia e a mesma, so muda a marcação das interfaces.
    fiz assim pro pessoal comparar , analisar e aprender com as regras.
    amigo sostenes, para entender mais Failover, seria quando um link caiu o outro assumir todo o trabalho só, mais onde ou qual é a regra q faz isso, que é responsável por esta parte.



  7. #7

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por sostenes
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_wlan1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark=to_wlan2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.113.0.1 routing-mark=to_wlan3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.114.0.1 routing-mark=to_wlan4 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark="http1" check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark="http2" check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.113.0.1 distance=3 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.114.0.1 distance=4 check-gateway=ping
    sao essas.

  8. #8
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por sostenes Ver Post
    sao essas.

    muito obrigado pela informação, fica com DEUS.



  9. #9

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    sostenes meu nobre, vc poderia da uma olhada no meu pcc e da uma dica do que posso fazer para melhorar? segundo um conhecido estar toda bugada.
    muito agradecido.
    Arquivos Anexos Arquivos Anexos

  10. #10

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    ola amigo, essa assimetria nos links e normal,per connection classifier trata os pacote do começo ao fim,sobre sua regras nao deu pra ver,mas se seu "conhecido" diz que as regras estao erradas ele deveria apontar os erros.
    te aconselho a tentar entender como funciona essa tipo de balanço,aki no fórum ja esta saturado de material PCC.



  11. #11

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por sostenes Ver Post
    ola amigo, essa assimetria nos links e normal,per connection classifier trata os pacote do começo ao fim,sobre sua regras nao deu pra ver,mas se seu "conhecido" diz que as regras estao erradas ele deveria apontar os erros.
    te aconselho a tentar entender como funciona essa tipo de balanço,aki no fórum ja esta saturado de material PCC.

    sostenes, valeu pelas regras e dicas.

    fiquei com uma dúvida, apenas para esclarecimento, pois a regras funcionaram sim.

    o que fazem exatamente essas regras aqui:
    / ip firewall mangle
    add chain=prerouting connection-mark=wlan3_conn in-interface=Local action=mark-routing new-routing-mark="http1" dst-port=80 protocol=tcp
    add chain=prerouting connection-mark=wlan4_conn in-interface=Local action=mark-routing new-routing-mark="http2" dst-port=80 protocol=tcp
    e logo em ip route, essas daqui:
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark="http1" check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark="http2" check-gateway=ping
    Sendo que as regras que você postou são para 4 links roteados, e vc criou apenas essas duas routing-marks "http1" e "http2"

    valeu!
    Última edição por BraZuky; 25-09-2010 às 19:01.

  12. #12

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Show de bola,,, vou fazer para dois link's,,, seguindo os conceitos,, e regras,,,

    estrelinha sim,, rs..



  13. #13

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Olá, em meu caso estou a provar uma RB 1100 na qual estou a realizar em balanço PCC com 3 ADSL de 4 MB a cada uma e tenho 2 HotSpot e uma rede local..... minha dúvida consiste em como aplicar o balanço a meus 3 redes isto é que todo o trafico que se gere nos 2 HotSpot e na rede local entrem ao balanço... agradecere suas respostas

    Clique na imagem para uma versão maior

Nome:	         RB 1100 BALANCEO PCC Y 3 REDES.jpg
Visualizações:	125
Tamanho: 	40,5 KB
ID:      	14594

  14. #14

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    ola amigo,te aconselho a usar uma outra rb so pra o balanço,e entregar tudo balanceado pra sua rb1100,balanço pcc com hotspot ou proxy junto sempre tem problemas.



  15. #15

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Olá sostenes, obrigado por responder se tenho leido o que comentas, aqui em meu caso mas adiante penso implementar um PROXY externo.... o que perguntava em meu pós anterior: minha dúvida consiste em como aplicar o balanço a meus 3 redes isto é que todo o trafico que se gere nos 2 HotSpot e na rede local entrem ao balanço, é para efeitos de aprendizagem, suponho eu que habria que aplicar algumas regras de mangle nas outras interfaces? agradecere as valiosas respostas

    saludos

  16. #16

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Uma pergunta Sostenes:
    Sendo que as regras que você postou são para 4 links roteados, e vc criou apenas essas duas routing-marks "http1" e "http2"

    Agora uma pergunta idiota aonde esta "http1" e "http2" é pra deixar deste jeito ou pra substituir por um endereco na web? tipo "h ttp://www.google.com.br" e "h ttp://www.uol.com.br" ?



  17. #17

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por maxmelo Ver Post
    Uma pergunta Sostenes:
    Sendo que as regras que você postou são para 4 links roteados, e vc criou apenas essas duas routing-marks "http1" e "http2"

    Agora uma pergunta idiota aonde esta "http1" e "http2" é pra deixar deste jeito ou pra substituir por um endereco na web? tipo "h ttp://www.google.com.br" e "h ttp://www.uol.com.br" ?
    Eu também fiz essa pergunta mais acima. Até agora nada.
    Se alguém souber, poste aqui por favor.

    um abraço

  18. #18

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Citação Postado originalmente por BraZuky Ver Post
    Eu também fiz essa pergunta mais acima. Até agora nada.
    Se alguém souber, poste aqui por favor.

    um abraço
    Sostenessss!!



  19. #19

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    Sostenes.. pelas regras suas, o FAIL-OVER... funciona pelas marcaçoes de Rota, ate ai blz... so q vc marca a porta 80, pra 2 rotas,, wan3 e wan4.... e sendo q como ta balanceando 4 links,, e um deles cai, a marcaçao no MANGLE, PREROUTING para... entao o failover pelas rotas nao funciona correto.

    O Failover.. so funcionara,, se caso um dos link cair, algum outro substituir ele... e sendo assim nao tem nenhuma regra, q mude no prerouting, a marcaçao de saida peer-conectio 4/0 la...

  20. #20

    Padrão re: Políticas de rotas com PCC e 4 links roteados

    sim isto mesmo,sendo que os links 3 e 4 sao links dedicados e os links 1 e 2 sao adsl.
    fiz esses lb para um cliente a algum tempo,ele tem 2links dedicados e 2 adsl e esta funcionando perfeito ate hj nesses lb ele direciona todo trafego da porta 80 para os links dedicados,meu intuito neste post nao foi fazer um tutorial ,e sim fazer a galera pensar e adaptar as suas necessidades.
    Última edição por sostenes; 21-10-2010 às 11:44.