Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Usando Mikrotik para bloquear bit torrent

    O veneno da maioria dos ISPs é Peer to Peer tráfego (p2p). p2p será a sua principal fonte de problemas. Em alguns casos, medidas extremas, devem ser tomadas.
    A primeira coisa a fazer é encontrar o tráfico ilícito.

    Primeiro, bloquear as pessoas de encontrar torrents Usando MTKs (L7), que correspondem pedidos HTTP GET para sites bit torrent e sites relacionados. Aqui está o meu regex:

    Código :
    ^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*$
    Aqui está o código CLI, você pode simplesmente colar:
    Código :
    /ip firewall layer7-protocol
    add comment="" name=torrent-wwws regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|de\
        monoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|f\
        enopy|gpirate|commonbits).*\$"
    Este regex corresponde a maioria dos sites populares torrent. Você vai notar que a palavra torrent também está lá. Se você for ao google e digitar torrent, ele vai corresponder ao pedido chegar ... o quê! hehehe. Isto significa que mesmo se eles tentarem google por um torrent que irá receber correspondência. Então, agora vamos colocar em uma regra de firewall para bloquear com este L7.
    Código :
    /ip firewall filter
    add action=drop chain=forward comment="block torrent wwws" disabled=no layer7-protocol=\
        torrent-wwws
    Como você pode ver, eu adicionei o torrent L7-WWWS, que foi definido anteriormente. Isto significa que qualquer tentativa para procurar qualquer um dos nossos sites torrent especificado pouco vai ficar bloqueado.
    Agora vamos bloquear o DNS para torrent
    regex:
    Código :
    ^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*$
    Código para copiar e colar no CLI:
    Código :
    /ip firewall layer7-protocol
    add comment="" name=torrent-dns regexp="^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjun\
        kie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirat\
        e|commonbits).*\$"
    Regra de firewall para bloquear:
    Código :
    /ip firewall filter
    add action=drop chain=forward comment="block torrent dns" disabled=no dst-port=53 \
        layer7-protocol=torrent-dns protocol=udp
    Repare que eu estou bloqueando a porta UDP 53,dessa forma, se eles usarem um proxy web, eles ainda vão ficar bloqueados!
    Se seu cliente tenta fazer qualquer resolução que atendam essa coisa , ele vai ficar bloqueado também.
    Usando o método acima para bloqueio, juntamente com o correspondente padrão p2p, você pode economizar cerca de 25% - a utilização de 50% no tráfego. Porém, o que as crianças fazem quando não pode fazer o download de pornografia e seus filmes ... Acho que a internet não tem outro uso? hehehe

    nao esqueça da estrelinha para agradecer.

  2. #2

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    "você pode economizar cerca de 25% - a utilização de 50% no tráfego." OU ATE 100% POR DEPOIS DISSO TODOS SEUS CLIENTES VAI EMBORA KKKKKKKKKKKKK



  3. #3

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    bom amigo imagina quem administra uma empresa e tem que bloquear torrent ou se vc usa adsl e ta com link no gargalo ajuda e muto, tb pode criar um script e desativar a regra de madrugada.

  4. #4

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por elymaiads Ver Post
    "você pode economizar cerca de 25% - a utilização de 50% no tráfego." OU ATE 100% POR DEPOIS DISSO TODOS SEUS CLIENTES VAI EMBORA KKKKKKKKKKKKK
    Se forem usuários de peer to peer que vão todos pros quintos dos infernos !!!!! hauahauahauahaua

    Falando sério:
    1 usuário P2P corresponde a 16 usuários comuns.
    Qual a graça de investir uma fortuna em banda, pro cidadão "acumular de bits" ?
    Duvido que os usuários P2P assitam todos os filmes e músicas piratas que baixam. Por isso eu os chamo de acumuladores de bits.

    Sostenes. Parabéns pelo post, muito bem estruturado e cercando por todos os flancos. Pena que publicou uma das funções "ninja" do meu gerenciador de redes. hehehehe

    ZéAlves
    Última edição por granlabor; 22-06-2010 às 08:12.



  5. #5

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    hehehe e isso ai meu amigo morte ao p2p kkkkkk.

  6. #6

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    bloquear totalmente nao é meio chato?
    nao seria mais interessante apenas fazer um certo controle?
    controle de requisicoes ou de banda....
    tem como fazer?



  7. #7

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    sim basta vc usar o L7 para marcar os pacotes e na queue tree vc controla a banda.(o objetivo do post e o bloqueio ok.)
    Citação Postado originalmente por mascaraapj Ver Post
    bloquear totalmente nao é meio chato?
    nao seria mais interessante apenas fazer um certo controle?
    controle de requisicoes ou de banda....
    tem como fazer?

  8. #8

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Eu usei essas regra no mk 4.10 e o site do baixaki não abria nem a pau.
    Última edição por wala; 24-10-2010 às 09:05.



  9. #9

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Bom mesmo a galera p2p pagam pelo serviço e tem uma garantia de banda certo?

    Ora, deixa o p2p setado no limite de banda dele ( 10% por exemplo) e libera de madruga quando poucos usam, não seria mais pratico?

  10. #10
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por Stronks Ver Post
    Bom mesmo a galera p2p pagam pelo serviço e tem uma garantia de banda certo?

    Ora, deixa o p2p setado no limite de banda dele ( 10% por exemplo) e libera de madruga quando poucos usam, não seria mais pratico?
    Não seria mais prático deixar o cara usufruir do serviço que contratou?



  11. #11

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por osmano807 Ver Post
    Não seria mais prático deixar o cara usufruir do serviço que contratou?
    Então.. ele contratou um serviço que garante uma certa banda, não um link dedicado.

    Qualquer provedor de internet é dessa forma, ate os grande como GVT, virtua e velox...

    Uma coisa é ser pratico, outra coisa é ser viavel, não da pra gantarir 100% de banda pra todos, não pelo preço que eles estão dispostos a pagar.Mas é claro que é errado você vender uma coisa que o cliente nunca poderá usufruir em sua plenitude, esse ponto vai de acordo com os custos do provedor.

  12. #12
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por Stronks Ver Post
    Então.. ele contratou um serviço que garante uma certa banda, não um link dedicado.

    Qualquer provedor de internet é dessa forma, ate os grande como GVT, virtua e velox...

    Uma coisa é ser pratico, outra coisa é ser viavel, não da pra gantarir 100% de banda pra todos, não pelo preço que eles estão dispostos a pagar.Mas é claro que é errado você vender uma coisa que o cliente nunca poderá usufruir em sua plenitude, esse ponto vai de acordo com os custos do provedor.
    Se ele contratou isso, deixe ele usar. O que não pode é o cara baixar a full um arquivo enquanto o torrent tá só no 10%... Ele vai perceber...
    Simples, deixa o cara... Bota sua garantia de 10% para a internet dele e esqueça. Se o cara usa a internet, nada mais justo...



  13. #13

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    O problema e que e uma rede que a velocidade e liberada sem controle de banda e e adsl de 8mb e de 4mb esse e o problema os torrent acabam com o limite de conexão o resto e tudo liberado a full vai desconectando gente vai ficando mais rapido so coloquei o protocolo pcq pra balancear so que que queria pelo menos fazer uma queue tree para botar uma cota no torrent mais ta dificil de controlar isso e ate de bloquear
    Última edição por wala; 29-10-2010 às 17:11.

  14. #14

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por wala Ver Post
    O problema e que e uma rede que a velocidade e liberada sem controle de banda e e adsl esse e o problema os torrent acabam com o limite de conexão o resto e tudo liberado a full vai desconectando gente vai ficando mais rapido so coloquei o protocolo pcq e tem 12 mb um adsl de 8mb e um de 4mb.
    Ha sim, mas um provedor com adsl ate vai, mas ainda por cima sem controle de banda?
    Ai já é amadorismo, não podem nem ser chamado de provedor, como o cara vai vender planos sem controle de banda?
    Esse caso ai, ao meu ver não conta em se tratando de provedor serio.



  15. #15

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Aqui não e provedor de internet não e se fosse eu faria do mesmo jeito questão de amadorismo nada pois eu ja deixaria expecificado a velocidade que e variavel aqui e eu fazia controle de banda antes e o pessoal ta mais contente assim a varios meses.

  16. #16

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por wala Ver Post
    Aqui não e provedor de internet não e se fosse eu faria do mesmo jeito questão de amadorismo nada pois eu ja deixaria expecificado a velocidade que e variavel aqui e eu fazia controle de banda antes e o pessoal ta mais contente assim a varios meses.
    Sim, mas esse metodo ai deixa espaço para interferência de um usuario ao outro, no seu caso um unico p2p ferraria tudo com certeza...



  17. #17

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    o ares pelo menos ta domado o problema e o torrent o bixo e feroz ate com portas trancada ele vai ja consegui bloquear parcialmente ele mais tem uns torrent que ainda vai, e a ideia e liberar os torrent so de madruga por enquanto ta sussa pois so tinha 2 usuarios que usam torrent aqui e um ficou combinado de usar so de madrugada o outro como e ligado a uma rb travei a velocidade dele na placa de rede do mikrotik pois o controle de banda do hotspot não funciona quando ativo o pcq.
    Última edição por wala; 29-10-2010 às 17:34.

  18. #18

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Primeiramente parabéns pela contribuição amigo sostenes.

    Muitos utilizam o Mikrotik apenas para provedores de internet e vejo que agora ele está a cada dia mais ganhando outra fatia de mercado que é o administrativo.

    Eu só utilizo o Mikrotik para estes fins, não tenho provedor mas já montei vários servidores com o mk para empresas que querem fazer os funcionários trabalharem e não ficarem vendo vídeos e baixando porcarias nos P2P.

    Bom agora só uma dúvida amigo, seu código já está funcionando em meu servidor. Mas eu tenho hj várias faixas de IP e gostaria que uma delas apenas tivesse o acesso ao p2p isso seria possível?



  19. #19

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    sim isso e possível,basta vc colocar a rege que vc quer em DST address List e marcar com "!",ou seja negando a regra para essa rege.

  20. #20

    Padrão Re: Usando Mikrotik para bloquear bit torrent

    Citação Postado originalmente por sostenes Ver Post
    bom amigo imagina quem administra uma empresa e tem que bloquear torrent ou se vc usa adsl e ta com link no gargalo ajuda e muto, tb pode criar um script e desativar a regra de madrugada.
    Pois é e eu preciso só que testei as regras aqui com o famoso uTORRENT e de nada adiantou o pau ta quebrando aqui na empresa.
    O que deu errado (mk 3.30)