+ Responder ao Tópico



  1. #1

    Padrão Como resolver este problema no apt-get - RESOLVIDO

    Pessoal, tentei imnstalar um pacote o qual não tive sucesso, e agora fica aparecendo direto a informação que tenho que reinstalar.

    E este problema não deixa eu instalar nada pelo apt-get, e não quero mais instalar este pacote pois já resolvir de outra forma.


    [email protected]:~# apt-get install dosemu
    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências
    Lendo informação de estado... Pronto
    E: O pacote ldap-account-manager precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

    Já tentei com apt-get -f install e nada de fazer desaparecer esta informação.

    alguém tem idéia como resolver?





    [email protected]:~#
    Última edição por gamaj1; 24-06-2010 às 21:04.

  2. #2

    Padrão Re: Como resolver este problema no apt-get

    Tenta
    Código :
    apt-get remove --purge  ldap-account-manager

    depois ( se der certo ou não) limpe o apt-get e atualiza denovo
    Código :
    apt-get clean
    apt-get update



  3. #3

    Padrão Re: Como resolver este problema no apt-get

    Amigo,

    poste o conteúdo do seu arquivo /etc/apt/sources.list

  4. #4

    Padrão Re: Como resolver este problema no apt-get

    Citação Postado originalmente por edsonrsjr Ver Post
    Amigo,

    poste o conteúdo do seu arquivo /etc/apt/sources.list
    Antes eu tei as dicas do amigo e ainda continua com a mesma menssagem.

    Segue abaixoo sources.list

    #
    deb Index of /ubuntu lucid main restricted
    deb-src Index of /ubuntu lucid main restricted
    deb Index of /ubuntu lucid-updates main restricted
    deb-src Index of /ubuntu lucid-updates main restricted
    deb Index of /ubuntu lucid universe
    deb-src Index of /ubuntu lucid universe
    deb Index of /ubuntu lucid-updates universe
    deb-src Index of /ubuntu lucid-updates universe
    deb Index of /ubuntu lucid multiverse
    deb-src Index of /ubuntu lucid multiverse
    deb Index of /ubuntu lucid-updates multiverse
    deb-src Index of /ubuntu lucid-updates multiverse

    deb Index of /ubuntu lucid-security main restricted
    deb-src Index of /ubuntu lucid-security main restricted
    deb Index of /ubuntu lucid-security universe
    deb-src Index of /ubuntu lucid-security universe
    deb Index of /ubuntu lucid-security multiverse
    deb-src Index of /ubuntu lucid-security multiverse


    Algo de errado no sources.list?

    Abraço



  5. #5

    Padrão Re: Como resolver este problema no apt-get

    Não sei porque ficou estranho quando colei o sources.list no topico acima, mas o correto seria este abaixo:


    deb http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid main restricted
    deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
    deb http://br.archive.ubuntu.com/ubuntu/ lucid universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid universe
    deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid-updates universe
    deb http://br.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb http://br.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

    deb http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb http://security.ubuntu.com/ubuntu lucid-security universe
    deb-src http://security.ubuntu.com/ubuntu lucid-security universe
    deb http://security.ubuntu.com/ubuntu lucid-security multiverse
    deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
    Última edição por gamaj1; 24-06-2010 às 15:42.

  6. #6

    Padrão Re: Como resolver este problema no apt-get

    Seu arquivo sources.list está normal

    Tente os seguintes comandos:

    # apt-get update
    # apt-get upgrade

    Tente instalar o pacote dosemu, se persistir o erro do ldap-account-manager tente:

    # apt-get install --reinstall ldap-account-manager ou apt-get -f install

    Tente novamente a instalação do pacote dosemu.

    Poste novamente se aparecer algum problema.



  7. #7

    Padrão Re: Como resolver este problema no apt-get - RESOLVIDO

    Infelizmente amigão não tive sucesso.

    Esta encrenca começou quando tentei instalar estes pacotes abaixo, não lembro qual foi o primeiro.

    ldap-account-manager_3.0.0-2_all.deb
    ldap-account-manager_3.1.0.RC1-1_all.deb
    ldap-account-manager-lamdaemon_3.0.0-2_all.deb

    Como não tive sucesso na configuração então partir pra instalar manual com o pacote:
    ldap-account-manager-3.0.0.tar.gz

    Depois disso o apt-get ferrou.

    Porém encontrei uma solução, segue o link de ouro
    MAD3 Linux: Forçando a Desinstalação de Pacotes deb
    Última edição por gamaj1; 24-06-2010 às 21:03.