+ Responder ao Tópico



  1. #1

    Padrão HOTSPOT filmes limitado por cliente

    olá, pessoal, estou com o seguinte problema... uso estas regras para deixar o hotspot full, ou seja coloco filmes para meu clientes assistirem.. dai deixo isso sem controle de banda... segue as regras.

    /ip firewall mangle
    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=udp comment="hotspot - full"

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64873 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64874 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64875 protocol=tcp

    chain=output action=mark-packet new-packet-mark=hotspot passthrough=no connection-mark=hotspot-out


    /queue tree
    name="hotspot" parent=global-out packet-mark=hotspot limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s

    ----------------------

    o problema que to precisando controlar, limitar esta banda por cliente, ou seja... cada cliente que for assistir os filmes tera uma banda tipo 500k...

    tem como modificar estas regras acima citadas, para este controle?


    Agradeço a ajuda de todos... muito obrigado.

  2. #2

    Padrão Re: HOTSPOT filmes limitado por cliente

    amigo la na sua queues tree vc tem uma regra para liberar full hotspot,ai vc cria uma regra pcq,assim todos os usuários só poderão usar 500k por user.

    Código :
    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
        500000 pcq-total-limit=2000

    agora basta na sua regra queues tree hotspot full->queues type vc seleciona hotspot_controle.
    boa sorte.
    Última edição por sostenes; 13-11-2010 às 13:12.



  3. #3

    Padrão Re: HOTSPOT filmes limitado por cliente

    Citação Postado originalmente por sostenes Ver Post
    amigo la na sua queues tree vc tem uma regra para liberar full hotspot,ai vc cria uma regra pcq,assim todos os usuarios so apoderam usar 500k por user.

    Código :
    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    500000 pcq-total-limit=2000

    agora basta na sua regra queues tree hotspot full->queues type vc seleciona hotspot_controle.
    boa sorte.

    opa... muito obrigado estarei testando... se eu quiser colocar 900k... basta alterar:

    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    900000 pcq-total-limit=2000

    -----
    pcp-total-limit=2000 --> o que quer dizer estes 2000?

    muito obrigado.

  4. #4

    Padrão Re: HOTSPOT filmes limitado por cliente

    Citação Postado originalmente por eletromidia Ver Post
    pcq-total-limit=2000 --> o que quer dizer estes 2000?
    quer dizer que so vai permitir no máximo 2000 conexões.



  5. #5

    Padrão Re: HOTSPOT filmes limitado por cliente

    tentei adicionar as regras em queue->tree

    porem deu a seguinte msg: no such argument (kind)

    acredito que seja por causa da versão que estou usando. 2.9.27

    vc teria esta regra para só que para esta versão?...

    muito obrigado pela sua ajuda.

  6. #6

    Padrão Re: HOTSPOT filmes limitado por cliente

    Citação Postado originalmente por eletromidia Ver Post
    olá, pessoal, estou com o seguinte problema... uso estas regras para deixar o hotspot full, ou seja coloco filmes para meu clientes assistirem.. dai deixo isso sem controle de banda... segue as regras.

    /ip firewall mangle
    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=udp comment="hotspot - full"

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64873 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64874 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64875 protocol=tcp

    chain=output action=mark-packet new-packet-mark=hotspot passthrough=no connection-mark=hotspot-out


    /queue tree
    name="hotspot" parent=global-out packet-mark=hotspot limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s

    ----------------------

    o problema que to precisando controlar, limitar esta banda por cliente, ou seja... cada cliente que for assistir os filmes tera uma banda tipo 500k...

    tem como modificar estas regras acima citadas, para este controle?


    Agradeço a ajuda de todos... muito obrigado.

    Alguem teria estas regras para a versão 3x pois estas so funciona na 2.9x agradeço desde ja



  7. #7

    Padrão Re: HOTSPOT filmes limitado por cliente

    Olá segue as regras para a versão 3.xx

    /ip firewall mangle
    add action=mark-connection chain=output comment="1 - HOTSPOT-FULL " disabled=\
    no new-connection-mark=hotspot-out out-interface=BRIDGE passthrough=yes \
    protocol=udp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=BRIDGE passthrough=yes \
    protocol=tcp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=BRIDGE passthrough=yes \
    protocol=tcp src-port=64873
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=BRIDGE passthrough=yes \
    protocol=tcp src-port=64874
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=BRIDGE passthrough=yes \
    protocol=tcp src-port=64875
    add action=mark-packet chain=output comment="" connection-mark=hotspot-out \
    disabled=no new-packet-mark=hotspot passthrough=no
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=4000000 name="3 - HOTSPOT-FULL" packet-mark=hotspot parent=\
    global-out priority=8 queue=default

  8. #8

    Padrão Re: HOTSPOT filmes limitado por cliente

    /queue type
    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    500000 pcq-total-limit=2000



  9. #9

    Padrão Re: HOTSPOT filmes limitado por cliente

    Citação Postado originalmente por sostenes Ver Post
    /queue type
    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    500000 pcq-total-limit=2000
    oi... agora adicionou tudo certo... porem não esta controlando a bando do hotspot.
    ta passando normal... que to fazendo de errado?

  10. #10

    Padrão Re: HOTSPOT filmes limitado por cliente

    Citação Postado originalmente por sostenes Ver Post
    /queue type
    add kind=pcq name=hotspot_controle pcq-classifier=dst-address pcq-limit=50 pcq-rate=\
    500000 pcq-total-limit=2000
    Rapaz... deu certo sim... selecionei como vc falou, e deu certinho... ficou perfeito... agradeço de coração sua ajuda.



  11. #11

    Padrão Re: HOTSPOT filmes limitado por cliente

    para agradecer clica na estrelinha vlw.