Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Estou tentando instalar o lusca cache no centos 5.5 64 bits mas quando ou o comando:

    ./configure --libexecdir=/usr/lib/squid --localstatedir=/var --prefix=/usr --sysconfdir=/etc/squid --enable-async-io --with-pthreads --enable-heap-replacement --enable-coss-aio-ops --enable-ssl --enable-htcp --enable-arp-acl --enable-removal-policies=lru,heap --disable-hostname-checks --enable-default-err-language=Portuguese --enable-err-languages=Portuguese --enable-linux-netfilter --enable-snmp --disable-ident-lookups --with-maxfd=65536 --enable-storeio=aufs,null,coss --enable-epoll


    no final aparece essa mensagem:

    configure: WARNING: Unrecognized options: --enable-coss-aio-ops, --disable-hostname-checks


    somente essa depois dei o make && make install e apareceu isso abaixo:


    [root@samba LUSCA_HEAD-r14716]# make && make install
    Making all in lib
    make[1]: Entrando no diretório `/home/lusca/LUSCA_HEAD-r14716/lib'
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT Array.o -MD -MP -MF .deps/Array.Tpo -c -o Array.o Array.c
    mv -f .deps/Array.Tpo .deps/Array.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT base64.o -MD -MP -MF .deps/base64.Tpo -c -o base64.o base64.c
    mv -f .deps/base64.Tpo .deps/base64.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT charset.o -MD -MP -MF .deps/charset.Tpo -c -o charset.o charset.c
    mv -f .deps/charset.Tpo .deps/charset.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT getfullhostname.o -MD -MP -MF .deps/getfullhostname.Tpo -c -o getfullhostname.o getfullhostname.c
    mv -f .deps/getfullhostname.Tpo .deps/getfullhostname.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT hash.o -MD -MP -MF .deps/hash.Tpo -c -o hash.o hash.c
    mv -f .deps/hash.Tpo .deps/hash.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT heap.o -MD -MP -MF .deps/heap.Tpo -c -o heap.o heap.c
    mv -f .deps/heap.Tpo .deps/heap.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT hex.o -MD -MP -MF .deps/hex.Tpo -c -o hex.o hex.c
    mv -f .deps/hex.Tpo .deps/hex.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT html_quote.o -MD -MP -MF .deps/html_quote.Tpo -c -o html_quote.o html_quote.c
    mv -f .deps/html_quote.Tpo .deps/html_quote.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT iso3307.o -MD -MP -MF .deps/iso3307.Tpo -c -o iso3307.o iso3307.c
    mv -f .deps/iso3307.Tpo .deps/iso3307.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT md5.o -MD -MP -MF .deps/md5.Tpo -c -o md5.o md5.c
    In file included from md5.c:32:
    ../include/squid_md5.h:27:2: error: #error Cannot find OpenSSL MD5 headers
    make[1]: ** [md5.o] Erro 1
    make[1]: Saindo do diretório `/home/lusca/LUSCA_HEAD-r14716/lib'
    make: ** [all-recursive] Erro 1


    alguém sabe como resolver ou já instalou o lusca no centos?

    OBS.: o openssl está instalado.

  2. Tu tá usando opção velha no Lusca, e habilitou o ssl no lusca sem ter as libs e os headers do openssl.



  3. bom amigo a atenção no configure é que os --enable-coss-aio-ops e --disable-hostname-checks sao opcões desconhecida verifique com o comando ./configure --help se eles mesmo existe

  4. Osmano o problema não é a versão pois a minha é a última de 22 de junho....consegui era só instalar o openssl-devel.


    Agora estou com um pequeno problema..o lusca está funcionando mas o serviço não aparece dentro do /etc/init.d para eu poder parar, restartar e etc..como faço para colocar o serviço lá dentro utilizando o centos ou debian? onde ele fica para eu fazer um link simbólico?



  5. Citação Postado originalmente por lfernandosg Ver Post
    Osmano o problema não é a versão pois a minha é a última de 22 de junho....consegui era só instalar o openssl-devel.


    Agora estou com um pequeno problema..o lusca está funcionando mas o serviço não aparece dentro do /etc/init.d para eu poder parar, restartar e etc..como faço para colocar o serviço lá dentro utilizando o centos ou debian? onde ele fica para eu fazer um link simbólico?
    Não foi isso que eu falei.

    Sobre o script do init, recomendo pegar um do squid para seu sistema, e modificar. O Lusca não vem com um não.
    (na verdade, deve vir, dentro de contrib/squid.rc, mas não garanto que funciona mais)






Tópicos Similares

  1. Erro de compilação Lusca no ubuntu 64 bits
    Por Rmnet no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-12-2010, 17:16
  2. erro compilacao zaptel
    Por laerciok no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-03-2007, 21:15
  3. OpenLDAP - erro compilação
    Por spyderlinux no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-03-2006, 12:11
  4. Erro compilacao openmosixview
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-06-2004, 19:00
  5. Erro compilação Sarg 1.4
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 11-09-2003, 16:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L