+ Responder ao Tópico



  1. #1

    Padrão Erro compilação Lusca cache

    Estou tentando instalar o lusca cache no centos 5.5 64 bits mas quando ou o comando:

    ./configure --libexecdir=/usr/lib/squid --localstatedir=/var --prefix=/usr --sysconfdir=/etc/squid --enable-async-io --with-pthreads --enable-heap-replacement --enable-coss-aio-ops --enable-ssl --enable-htcp --enable-arp-acl --enable-removal-policies=lru,heap --disable-hostname-checks --enable-default-err-language=Portuguese --enable-err-languages=Portuguese --enable-linux-netfilter --enable-snmp --disable-ident-lookups --with-maxfd=65536 --enable-storeio=aufs,null,coss --enable-epoll


    no final aparece essa mensagem:

    configure: WARNING: Unrecognized options: --enable-coss-aio-ops, --disable-hostname-checks


    somente essa depois dei o make && make install e apareceu isso abaixo:


    [[email protected] LUSCA_HEAD-r14716]# make && make install
    Making all in lib
    make[1]: Entrando no diretório `/home/lusca/LUSCA_HEAD-r14716/lib'
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT Array.o -MD -MP -MF .deps/Array.Tpo -c -o Array.o Array.c
    mv -f .deps/Array.Tpo .deps/Array.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT base64.o -MD -MP -MF .deps/base64.Tpo -c -o base64.o base64.c
    mv -f .deps/base64.Tpo .deps/base64.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT charset.o -MD -MP -MF .deps/charset.Tpo -c -o charset.o charset.c
    mv -f .deps/charset.Tpo .deps/charset.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT getfullhostname.o -MD -MP -MF .deps/getfullhostname.Tpo -c -o getfullhostname.o getfullhostname.c
    mv -f .deps/getfullhostname.Tpo .deps/getfullhostname.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT hash.o -MD -MP -MF .deps/hash.Tpo -c -o hash.o hash.c
    mv -f .deps/hash.Tpo .deps/hash.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT heap.o -MD -MP -MF .deps/heap.Tpo -c -o heap.o heap.c
    mv -f .deps/heap.Tpo .deps/heap.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT hex.o -MD -MP -MF .deps/hex.Tpo -c -o hex.o hex.c
    mv -f .deps/hex.Tpo .deps/hex.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT html_quote.o -MD -MP -MF .deps/html_quote.Tpo -c -o html_quote.o html_quote.c
    mv -f .deps/html_quote.Tpo .deps/html_quote.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT iso3307.o -MD -MP -MF .deps/iso3307.Tpo -c -o iso3307.o iso3307.c
    mv -f .deps/iso3307.Tpo .deps/iso3307.Po
    gcc -DHAVE_CONFIG_H -I. -I../include -I../include -I../include -Wall -g -O2 -D_REENTRANT -MT md5.o -MD -MP -MF .deps/md5.Tpo -c -o md5.o md5.c
    In file included from md5.c:32:
    ../include/squid_md5.h:27:2: error: #error Cannot find OpenSSL MD5 headers
    make[1]: ** [md5.o] Erro 1
    make[1]: Saindo do diretório `/home/lusca/LUSCA_HEAD-r14716/lib'
    make: ** [all-recursive] Erro 1


    alguém sabe como resolver ou já instalou o lusca no centos?

    OBS.: o openssl está instalado.

  2. #2
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Erro compilação Lusca cache

    Tu tá usando opção velha no Lusca, e habilitou o ssl no lusca sem ter as libs e os headers do openssl.



  3. #3
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão Re: Erro compilação Lusca cache

    bom amigo a atenção no configure é que os --enable-coss-aio-ops e --disable-hostname-checks sao opcões desconhecida verifique com o comando ./configure --help se eles mesmo existe

  4. #4

    Padrão Re: Erro compilação Lusca cache

    Osmano o problema não é a versão pois a minha é a última de 22 de junho....consegui era só instalar o openssl-devel.


    Agora estou com um pequeno problema..o lusca está funcionando mas o serviço não aparece dentro do /etc/init.d para eu poder parar, restartar e etc..como faço para colocar o serviço lá dentro utilizando o centos ou debian? onde ele fica para eu fazer um link simbólico?



  5. #5
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Erro compilação Lusca cache

    Citação Postado originalmente por lfernandosg Ver Post
    Osmano o problema não é a versão pois a minha é a última de 22 de junho....consegui era só instalar o openssl-devel.


    Agora estou com um pequeno problema..o lusca está funcionando mas o serviço não aparece dentro do /etc/init.d para eu poder parar, restartar e etc..como faço para colocar o serviço lá dentro utilizando o centos ou debian? onde ele fica para eu fazer um link simbólico?
    Não foi isso que eu falei.

    Sobre o script do init, recomendo pegar um do squid para seu sistema, e modificar. O Lusca não vem com um não.
    (na verdade, deve vir, dentro de contrib/squid.rc, mas não garanto que funciona mais)

  6. #6

    Padrão Re: Erro compilação Lusca cache

    blz...peguei o script e está assim:


    #!/bin/sh

    LUSCA_BIN="/usr/local/lusca/sbin/squid"
    LUSCA_COREDIR="/usr/local/lusca/var/logs"
    LUSCA_START_FLAGS="-D"

    ulimit -n 65535

    case $1 in
    'start')
    echo "Starting Lusca.."
    cd ${LUSCA_COREDIR} && ${LUSCA_BIN} ${LUSCA_START_FLAGS}
    exit 0
    ;;
    'stop')
    echo "Stopping Lusca.."
    ${LUSCA_BIN} -k shutdown
    sleep 60
    exit 0
    ;;
    'rotate')
    echo "Rotating Lusca Logfiles.."
    ${LUSCA_BIN} -k rotate
    exit 0
    ;;
    'reconfigure')
    echo "Reconfiguring Lusca.."
    ${LUSCA_BIN} -k reconfigure
    exit 0
    ;;
    *)
    echo "$0: {start|stop|rotate|reconfigure}"
    exit 1
    ;;
    esac
    exit 0
    mas no scrip do ./configure acima não tem esse diretório do lusca_bin onde posso achar?

    os diretórios que preciso saber onde estão:


    LUSCA_BIN="/usr/local/lusca/sbin/squid"
    LUSCA_COREDIR="/usr/local/lusca/var/logs"
    LUSCA_START_FLAGS="-D"


    com o nome lusca não achei nenhum...deve tá com algo sobre squid pois só consigo iniciar ele com o comando:


    squid -d 10 -D -N -F -X -f /etc/squid/squid.conf &



  7. #7

    Padrão Re: Erro compilação Lusca cache

    Consegui!!!

    consegui...adaptei o script que tem dentro do diretório de compilação:


    #!/bin/sh

    LUSCA_BIN="/usr/sbin/squid"
    LUSCA_COREDIR="/var/log/squid/"
    LUSCA_START_FLAGS="-D"

    ulimit -n 65535




    case $1 in
    'start')
    echo "Starting Lusca.."
    cd ${LUSCA_COREDIR} && ${LUSCA_BIN} ${LUSCA_START_FLAGS}
    exit 0
    ;;
    'stop')
    echo "Stopping Lusca.."
    ${LUSCA_BIN} -k shutdown
    sleep 60
    exit 0
    ;;
    'rotate')
    echo "Rotating Lusca Logfiles.."
    ${LUSCA_BIN} -k rotate
    exit 0
    ;;
    'reconfigure')
    echo "Reconfiguring Lusca.."
    ${LUSCA_BIN} -k reconfigure
    exit 0
    ;;
    *)
    echo "$0: {start|stop|rotate|reconfigure}"
    exit 1
    ;;
    esac
    exit 0


    agora funciona para inicar é uma bala mas para parar demora uns 7 minutos é assim mesmo? estou em testes numa bancada com um servidor dell xeon 2.1ghz 1066mhz/2xhds 500GB 16mb cache raid 1/4GB ddr2 e etc...centos 5.4 64 bits.