+ Responder ao Tópico



  1. Galera!

    Alguém daí tem ou sabe de algum lugar que tenha um script que capture quem está no registration table e jogue no access list para que eu possa agendar a execução de tempos em tempos?

    Pergunto porque quero fechar minha rede toda retirando default-athenticate de todos os aps 2.4 mas não posso simplesmente ir de cliente em cliente vendo mac e para onde está apontado nem tão pouco fechar e deixar a galera ir ligando para botar de novo...

  2. Tenho esse script rodando em nossa rede aqui. (utilizo hotspot)

    Daew é so precisa colocar ele no system>scheduler para rodar de tanto em tanto tempo.

    Espero ter ajudado.

    Abraç

    #Inicio do Script
    :log info "Iniciando Script Access-list-auto por: Gustavo Zanatta"

    :global auth "yes";
    :global forw "no";
    :global interface "all";

    :foreach h in=[/ip hotspot active find] do={

    #pegando Usuario e mac
    :global user [/ip hotspot active get $h user];
    :global mac [/ip hotspot active get $h mac-address];
    :global v "0";
    :foreach hh in=[/interface wireless access-list find mac-address=$mac] do={

    :if ([/interface wireless access-list get $hh mac-address] = $mac ) do={
    :global v "1";
    }
    }

    :if (v = "0") do={
    :global macempresa [ick $mac 0 8];

    # Identificando Fabricante
    :global fabricante "";
    :if ($macempresa = "00:0e:2e" or $macempresa = "00:0E:2E") do={:global fabricante "AP Edimax"};
    :if ($macempresa = "00:1F:1F" or $macempresa = "00:1f:1f") do={:global fabricante "USB Edimax"};
    :if ($macempresa = "00:21:8D" or $macempresa = "00:21:8d") do={:global fabricante "AP Router"};
    :if ($macempresa = "00:01:BE" or $macempresa = "00:01:be") do={:global fabricante "GigaCom"};
    :if ($macempresa = "00:05:5D" or $macempresa = "00:05:5d") do={:global fabricante "D-Link"};
    :if ($macempresa = "00:0C:43" or $macempresa = "00:0c:43") do={:global fabricante "Ra-Link"};
    :if ($macempresa = "00:0D:88" or $macempresa = "00:0d:88") do={:global fabricante "D-link"};
    :if ($macempresa = "00:13:46") do={:global fabricante "D-link"};
    :if ($macempresa = "00:15:E9" or $macempresa = "00:15:e9") do={:global fabricante "D-link Placa"};
    :if ($macempresa = "00:19:5B" or $macempresa = "00:19:5b") do={:global fabricante "D-Link"};
    :if ($macempresa = "00:17:9A" or $macempresa = "00:17:9a") do={:global fabricante "D-link"};
    :if ($macempresa = "00:1B:11" or $macempresa = "00:1b:11") do={:global fabricante "D-link Placa"};
    :if ($macempresa = "00:1C:F0" or $macempresa = "00:1c:f0") do={:global fabricante "D-Link"};
    :if ($macempresa = "00:1D:0F" or $macempresa = "00:1f:0f") do={:global fabricante "TP-Link"};
    :if ($macempresa = "00:21:27") do={:global fabricante "Tp-Link"};
    :if ($macempresa = "00:21:91") do={:global fabricante "D-Link"};
    :if ($macempresa = "00:23:CD" or $macempresa = "00:23:cd") do={:global fabricante "TP-link"};
    :if ($macempresa = "00:25:86") do={:global fabricante "TP-link"};
    :if ($macempresa = "00:27:19") do={:global fabricante "TP-link"};
    :if ($macempresa = "00:40:0C" or $macempresa = "00:40:0c") do={:global fabricante "Gi-link"};
    :if ($macempresa = "00:0A:52" or $macempresa = "00:0a:52") do={:global fabricante "AsiaRF - Sansung"};
    :if ($macempresa = "00:15:6D" or $macempresa = "00:15:6d") do={:global fabricante "Ubiquiti Networks"};
    :if ($macempresa = "00:0C:42" or $macempresa = "00:0c:42") do={:global fabricante "Routerboard"};
    :if ($macempresa = "00:02:72") do={:global fabricante "Gi-Link"};
    :if ($macempresa = "00:08:54") do={:global fabricante "Netronix"};
    :if ($macempresa = "00:40:F4" or $macempresa = "00:40:f4") do={:global fabricante "Cameo"};
    :if ($macempresa = "00:12:0E" or $macempresa = "00:12:0E") do={:global fabricante "AP-Router"};
    :if ($macempresa = "00:02:6F" or $macempresa = "00:02:6f") do={:global fabricante "Senao-Engenius"};
    :if ($macempresa = "00:4F:62" or $macempresa = "00:4f:62") do={:global fabricante "Ovislink 5460"};
    :if ($macempresa = "00:02:78") do={:global fabricante "Sansung"};
    :if ($macempresa = "00:18:E7" or $macempresa = "00:18:e7") do={:global fabricante "Cameo"};
    :if ($macempresa = "00:19:E0" or $macempresa = "00:19:e0") do={:global fabricante "TP-Link"};
    :if ($macempresa = "00:05:9E" or $macempresa = "00:05:9e") do={:global fabricante "Zinwell"};
    :if ($macempresa = "00:1A:F0" or $macempresa = "00:1a:f0") do={:global fabricante "Alcatel"};
    :if ($macempresa = "00:C0:CA" or $macempresa = "00:c0:ca") do={:global fabricante "Alfa, Inc."};
    :if ($macempresa = "00:26:08") do={:global fabricante "Apple, Inc"};
    :if ($macempresa = "00:12:BF" or $macempresa = "00:12:bf") do={:global fabricante "Arcadyan Technology Corporation"};
    :if ($macempresa = "00:0E:8B" or $macempresa = "00:0e:8b") do={:global fabricante "Astarte "};
    :if ($macempresa = "00:118" or $macempresa = "00:11:d8") do={:global fabricante "ASUSTek "};
    :if ($macempresa = "00:15:F2" or $macempresa = "00:15:f2") do={:global fabricante "ASUSTek "};
    :if ($macempresa = "00:18:F3" or $macempresa = "00:18:f3") do={:global fabricante "ASUSTek "};
    :if ($macempresa = "00:22:15") do={:global fabricante "ASUSTek COMPUTER INC."};
    :if ($macempresa = "00:24:8C" or $macempresa = "00:24:8c") do={:global fabricante "ASUSTek "};
    :if ($macempresa = "00:11:22") do={:global fabricante "CIMSYS Inc"};
    :if ($macempresa = "00:90:F5" or $macempresa = "00:90:f5") do={:global fabricante "Clevo co."};
    :if ($macempresa = "00:1E:EC" or $macempresa = "00:1e:ec") do={:global fabricante "COMPAL INFORMATION (K "};
    :if ($macempresa = "00:23:5A" or $macempresa = "00:23:5a") do={:global fabricante "COMPAL INFORMATION (KUNSHAN)"};
    :if ($macempresa = "00:26:22") do={:global fabricante "COMPAL INFORMATION (KUNSHAN) CO., LTD."};
    :if ($macempresa = "00:80:4C" or $macempresa = "00:80:4c") do={:global fabricante "Contec Co., Ltd."};
    :if ($macempresa = "00:0E:E2" or $macempresa = "00:0e:e2") do={:global fabricante "Custom Engineering S."};
    :if ($macempresa = "00:01:36") do={:global fabricante "CyberTAN Technolog"};
    :if ($macempresa = "00:14:2A" or $macempresa = "00:14:2a") do={:global fabricante "Elitegroup Computer S"};
    :if ($macempresa = "00:07:95") do={:global fabricante "Elitegroup Computer System (ECS)"};
    :if ($macempresa = "00:14:A5" or $macempresa = "00:14:a5") do={:global fabricante "Gemtek Technology"};
    :if ($macempresa = "00:1A:4D" or $macempresa = "00:1a:4d") do={:global fabricante "Giga-Byte Technology"};
    :if ($macempresa = "00:03:2F" or $macempresa = "00:03:2f") do={:global fabricante "Global Sun Technol "};
    :if ($macempresa = "00:C0:A8" or $macempresa = "00:c0:a8") do={:global fabricante "GVC Corporation"};
    :if ($macempresa = "00:25:B3" or $macempresa = "00:25:b3") do={:global fabricante "Hewlett Packard "};
    :if ($macempresa = "00:0B:CD" or $macempresa = "00:0b:cd") do={:global fabricante "Hewlett Packard "};
    :if ($macempresa = "00:1F:E1" or $macempresa = "00:1f:e1") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:24:2C" or $macempresa = "00:24:2c") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:26:5C" or $macempresa = "00:26:5c") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:26:5E" or $macempresa = "00:26:5e") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:1D9" or $macempresa = "00:1d:d9") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:24:2B" or $macempresa = "00:24:2b") do={:global fabricante "Hon Hai"};
    :if ($macempresa = "00:1E:64" or $macempresa = "00:1e:64") do={:global fabricante "Intel Corporate "};
    :if ($macempresa = "00:21:5C" or $macempresa = "00:21:5c") do={:global fabricante "Intel Corporate "};
    :if ($macempresa = "00:16:6F" or $macempresa = "00:16:6f") do={:global fabricante "Intel Corporation "};
    :if ($macempresa = "00:1A:3F" or $macempresa = "00:1a:3f") do={:global fabricante "Intelbras "};
    :if ($macempresa = "00:E0:4B" or $macempresa = "00:e0:4b") do={:global fabricante "Jump industrielle "};
    :if ($macempresa = "00:0E:62" or $macempresa = "00:0e:62") do={:global fabricante "Nortel Networks "};
    :if ($macempresa = "00:4F:6A" or $macempresa = "00:4f:6a") do={:global fabricante "Ovislink WT-2000PCI"};
    :if ($macempresa = "00:E0:12" or $macempresa = "00:e0:12") do={:global fabricante "pluto technologies "};
    :if ($macempresa = "00:06:4F" or $macempresa = "00:06:4f") do={:global fabricante "PRO-NETS Technology Corporation "};
    :if ($macempresa = "00:1E:68" or $macempresa = "00:1e:68") do={:global fabricante "Quanta Computer Inc "};
    :if ($macempresa = "00:E0:4C" or $macempresa = "00:e0:4c") do={:global fabricante "Realtek Semiconductor corp. "};
    :if ($macempresa = "00:18:37") do={:global fabricante "Universal ABIT Co., Ltd."};
    :if ($macempresa = "00:03:0D" or $macempresa = "00:03:0d") do={:global fabricante "Uniwill Computer C "};
    :if ($macempresa = "00:1A:13" or $macempresa = "00:1a:13") do={:global fabricante "Wanlida Group Co., LTD "};
    :if ($macempresa = "00:1F:16" or $macempresa = "00:1f:16") do={:global fabricante "Wistron Corporation"};
    :if ($macempresa = "00:0E:E8" or $macempresa = "00:0e:e8") do={:global fabricante "zioncom "};
    :if ($macempresa = "08:10:74") do={:global fabricante "Aquario AP"};

    :if ($fabricante = "") do={:global fabricante "FABRICANTE NAO RECONHECIDO"};
    :global NomeAccess "$fabricante - $user";

    #Cadastrando no Access-list
    /interface wireless access-list add mac-address=$mac authentication=$auth \
    forwarding=$forw comment=$NomeAccess interface=$interface;
    }
    }



  3. Boa tarde colega, testei seu script aqui e nao obtive resultado algum.
    Meus aps estao em bridge, quero captura os Macs conectados registration-table e joga-las na access list.

    Grato pela atenção

  4. Citação Postado originalmente por leiterafael Ver Post
    Galera!

    Alguém daí tem ou sabe de algum lugar que tenha um script que capture quem está no registration table e jogue no access list para que eu possa agendar a execução de tempos em tempos?

    Pergunto porque quero fechar minha rede toda retirando default-athenticate de todos os aps 2.4 mas não posso simplesmente ir de cliente em cliente vendo mac e para onde está apontado nem tão pouco fechar e deixar a galera ir ligando para botar de novo...
    Simples de ser feito, preciso so de um acesso pra poder montar de acordo a necessidade pois nao uso cartão .






Tópicos Similares

  1. Quem está logado no SFTP?
    Por thicouto no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-02-2007, 19:21
  2. FireWall - Para quem esta procurando um fire BOM
    Por tianguapontocom no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-06-2006, 14:20
  3. Quem está usando o squid ?
    Por whinston no fórum Servidores de Rede
    Respostas: 15
    Último Post: 14-08-2005, 12:26
  4. Capturar Porta LPT1 em estações Linux para Impressao em Rede
    Por luiz_inf no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 23-07-2005, 09:17
  5. Verificar quem esta usando squid no exato momento
    Por phacam no fórum Servidores de Rede
    Respostas: 4
    Último Post: 04-05-2005, 07:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L