+ Responder ao Tópico



  1. Pessoal, faz tempo que eu to tentando implantar o cache full aqui. Agora tenho rodando um server Mikrotik e proxy squid com zph + thunder3 paralelo, mas to com um problema pra fazer o cache full funcionar.
    Ele funciona se eu desativar o controle de banda individual (simple queues).
    Quando ativo as simple queues, mesmo quando o cliente baixa do cache não sai a full, mas sim na velocidade contratada do cliente. Mas se na queue tree o limite é de 4m, o que sai do cache não tinha q sair a 4m?

    Vou postar minhas regras abaixo, pra ver se alguém me da uma luz, por favor!

    /ip firewall mangle
    ;;; Cache Full_regra 2
    chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes protocol=tcp src-port=5128 dscp=12

    1 ;;; Cache Full_regra 2
    chain=postrouting action=mark-connection new-connection-mark=sem-proxy-hits passthrough=yes protocol=tcp src-port=5128 dscp=!12

    2 chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits

    3 ;;; Cache Full
    chain=postrouting action=mark-connection new-connection-mark=squid-connection-HIT passthrough=yes protocol=tcp src-port=5128 content=X-Cache: HIT from Thunder

    4 ;;; Cache Full
    chain=postrouting action=mark-connection new-connection-mark=squid-connection-HIT passthrough=yes protocol=tcp src-port=5128 content=X-Cache: HIT disable=yes

    5 chain=postrouting action=mark-packet new-packet-mark=squid-packet-HIT passthrough=no connection-mark=squid-connection-HIT

    /queue type
    name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

    /queue tree
    name="squid packets" parent=global-out packet-mark=squid-packet-HIT limit-at=0 queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    7 name="SquidCache_Down" parent=global-out packet-mark=proxy-squid limit-at=0 queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    8 name="SquidCache_Up" parent=global-in packet-mark=proxy-squid limit-at=0 queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    Desde já agradeço.

  2. A marcação que interessa é X-Cache: HIT from Thunder, e o zph do squid. Essa que ta desabilitada quando habilitada marca tb, mas o problema continua o mesmo.
    Me parece ser algum problema de prioridade nas queues.






Tópicos Similares

  1. Ajuda com web proxy e cache full
    Por VALTERTERABYTE no fórum Redes
    Respostas: 4
    Último Post: 11-09-2010, 10:30
  2. Respostas: 11
    Último Post: 07-06-2010, 21:57
  3. Respostas: 3
    Último Post: 23-03-2008, 12:10
  4. Problema Com QUEUES
    Por dumer99 no fórum Redes
    Respostas: 2
    Último Post: 30-03-2007, 07:11
  5. Problemas Com Queues
    Por Aldo.mau no fórum Redes
    Respostas: 5
    Último Post: 04-01-2007, 21:02

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L