+ Responder ao Tópico



  1. #1

    Padrão Raid 1 via hardware

    Bom tenho uma controladora sata pci-x 1x sil3132 e o centos com kernel 2.6.18 reconhece e funciona tudo blz...mas quero instalar outra placa dessa no ubuntu ou debian no debian não vai e no ubuntu 9.10 instala sem erros mas ao tirar um dos HDs o sistema começa a iniciar e para....então fui para o ubuntu server 10.04 e tb reconheceu tudo certinho na hora de testar tirei um HD e na hora de entrar no grub travou na tela da bios....depois testei com o outro HD ai vai normal o que pode ser?

  2. #2

    Padrão Re: Raid 1 via hardware

    Citação Postado originalmente por lfernandosg Ver Post
    Bom tenho uma controladora sata pci-x 1x sil3132 e o centos com kernel 2.6.18 reconhece e funciona tudo blz...mas quero instalar outra placa dessa no ubuntu ou debian no debian não vai e no ubuntu 9.10 instala sem erros mas ao tirar um dos HDs o sistema começa a iniciar e para....então fui para o ubuntu server 10.04 e tb reconheceu tudo certinho na hora de testar tirei um HD e na hora de entrar no grub travou na tela da bios....depois testei com o outro HD ai vai normal o que pode ser?
    Amigo! Pode ser problema de driver. Verifica a matriz de compatibilidade desta placa para o sistema operacional. Se tiver o driver a este sistema instala separado. Não usa o default generico. Ja peguei casos assim e era driver. Não custa tentar.



  3. #3

    Padrão Re: Raid 1 via hardware

    então complicou os drives que tem lá são para redhat/centos, suse e fedora mas nem para eles servem pois são drives para kernel antigo: 2.6.9 e hoje o centos reconhece sem precisar instalar nada e tudo funciona....vou ter que trocar o fake raid pelo raid via software mesmo.

  4. #4

    Padrão Re: Raid 1 via hardware

    Citação Postado originalmente por lfernandosg Ver Post
    então complicou os drives que tem lá são para redhat/centos, suse e fedora mas nem para eles servem pois são drives para kernel antigo: 2.6.9 e hoje o centos reconhece sem precisar instalar nada e tudo funciona....vou ter que trocar o fake raid pelo raid via software mesmo.
    E amigo! complicou a parada!. O problema que Raid via software e perde a performance e se torna um pouco lento. O ideal mesmo se pudesse usar o recurso de hardware para montar o Raid que e bem mais performatico. Boa sorte!



  5. #5

    Padrão Re: Raid 1 via hardware

    pelo o que andei lendo placa que tenho é boa mas é um fake raid pois usa módulo do linux para poder levantar...nessa servidor vou usar o centos mas no outro vou de debian mesmo via software.

    Vi na dell que as placas raid que eles tem são hotswap e não depende do sistema operacional funciona em qualquer um mas ai são muito caras.

  6. #6

    Padrão Re: Raid 1 via hardware

    ja tentou levantar o dodmraid na instalação?



  7. #7

    Padrão Re: Raid 1 via hardware

    dmraid vc fala? no ubuntu ele já reconhece os HDs como um e depois de instalado no lsmod aparece o dmraid45 então ele já instala com o módulo.
    O debian preciso colocar a linha abaixo:

    install dmraid=true xor-true


    ai aparece somente um HD e instala tudo certinho mas quando vou testar desconectando um HD ai que aparece o erro. tem outra forma? porque o centos tem kerne muito mais antigo e funciona perfeitamente nele.

    erro que aparece no debian nos 2 Hds quando tento inciar um de cada vez e no ubuntu 9.10:

    Gave up Wating For root Device(Common Problens):

    -Boot args (cat /proc/cmdline)
    -Check root delay = (did the system wait long enough?)
    -Check root = (did the system wait For the Device?)
    -Missing modules (cat /proc/modules; ls /dev)

    ALERT! /dev/mapper/sil_bgahcdcfejfg1 does not exist.Dropping to a shell.

    Fica nessa tela e abaixo disso fica somente

    ( initramfs)
    Última edição por lfernandosg; 24-07-2010 às 15:54.

  8. #8

    Padrão Re: Raid 1 via hardware

    Quanto ao dodmraid esquece é hábito com gentoo rsrsrsr
    Tem como voce postar seu fstab para darmos uma verificada? Ah e se der posta tambem um ls -lisa do /dev/mapper
    Última edição por rutgerr; 24-07-2010 às 19:03.



  9. #9

    Padrão Re: Raid 1 via hardware

    vamos lá:


    [email protected]:/home/fernando# fdisk -l

    Disco /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Unidades = cilindros de 16065 * 512 = 8225280 bytes
    Identificador do disco: 0x0004be49

    Dispositivo Boot Início Fim Blocos Id Sistema
    /dev/sda1 1 59483 477797166 83 Linux
    /dev/sda2 59484 60801 10586835 5 Estendida
    /dev/sda5 59484 60801 10586803+ 82 Linux swap / Solaris

    Disco /dev/sdb: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Unidades = cilindros de 16065 * 512 = 8225280 bytes
    Identificador do disco: 0x0004be49

    Dispositivo Boot Início Fim Blocos Id Sistema
    /dev/sdb1 1 59483 477797166 83 Linux
    /dev/sdb2 59484 60801 10586835 5 Estendida
    /dev/sdb5 59484 60801 10586803+ 82 Linux swap / Solaris


    [email protected]:/home/fernando# ls -l /dev/mapper/
    total 0
    crw-rw---- 1 root root 10, 60 2010-07-26 10:37 control
    brw-rw---- 1 root disk 252, 0 2010-07-26 10:37 sil_bgahddcfajaf
    brw-rw---- 1 root disk 252, 1 2010-07-26 10:37 sil_bgahddcfajaf1
    brw-rw---- 1 root disk 252, 2 2010-07-26 10:37 sil_bgahddcfajaf5


    estou com o 9.10 de desktop instalado pois o server deixei em casa...nesse caso aqui é o mesmo erro do debian não inicia em nenhum HD dando aquele erro do iniframs.

    abaixo os módulos que ele levanta só na instalação:

    dm_raid45 84228 0

    xor 15620 1 dm_raid45
    Última edição por lfernandosg; 26-07-2010 às 10:48.

  10. #10

    Padrão Re: Raid 1 via hardware

    Então seu fstab tem que apontar para o /dev/mapper vai gerar uma coisa mais ou menos assim

    # nano /etc/fstab
    /dev/mapper/isw_jdeejigjf_RAID11 /boot ext2 defaults,noatime 1 2
    /dev/mapper/isw_jdeejigjf_RAID15 none swap sw 0 0
    /dev/mapper/isw_jdeejigjf_RAID16 / ext3 noatime 0 1
    /dev/mapper/isw_jdeejigjf_RAID12 /var ext3 noatime 1 2
    /dev/mapper/isw_jdeejigjf_RAID13 /usr ext3 noatime 1 2
    /dev/mapper/isw_jdeejigjf_RAID17 /opt ext3 noatime 1 2
    /dev/cdrom /mnt/cdrom auto noauto,user 0 0
    proc /proc proc defaults 0 0
    shm /dev/shm tmpfs nodev,nosuid,noexec 0 0

    e vc vai precisar dar uma ajustada no seu gerenciador de boot
    vai ficar algo assim


    # nano /boot/grub/grub.conf

    default 0

    timeout 5
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz

    title X Linux

    kernel (hd0,0)/boot/kernel-genkernel-x86_64-2.6.32
    root=/dev/ram0 real_root=/dev/mapper/isw_jdeejigjf_RAID16 init=/linuxrc ramdisk=8192 dodmraid udev
    initrd (hd0,0)/boot/initramfs-genkernel-x86_64-2.6.32



    Espero que dessa vez voce consiga levantar o Raid



  11. #11

    Padrão Re: Raid 1 via hardware

    então para ficar mais fácil instalai de volta o server 10.04


    bom meu fstab está assim:


    [email protected]:~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    /dev/mapper/sil_bgahdiccejcc1 / ext4 errors=remount-ro 0 1
    /dev/mapper/sil_bgahdiccejcc2 none swap sw 0 0


    meu grub.cfg está assim:

    menuentry 'Ubuntu, with Linux 2.6.32-21-server' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd2,1)'
    search --no-floppy --fs-uuid --set cd223f81-3eeb-43f9-a70a-d5239e6f1c4e
    linux /boot/vmlinuz-2.6.32-21-server root=UUID=cd223f81-3eeb-43f9-a70a-d5239e6f1c4e ro quiet
    initrd /boot/initrd.img-2.6.32-21-server
    }
    menuentry 'Ubuntu, with Linux 2.6.32-21-server (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd2,1)'
    search --no-floppy --fs-uuid --set cd223f81-3eeb-43f9-a70a-d5239e6f1c4e
    echo 'Loading Linux 2.6.32-21-server ...'
    linux /boot/vmlinuz-2.6.32-21-server root=UUID=cd223f81-3eeb-43f9-a70a-d5239e6f1c4e ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.32-21-server


    meu /dev/mapper está assim:

    [email protected]:/boot/grub$ ls -l /dev/mapper/
    total 0
    crw-rw---- 1 root root 10, 59 2010-07-26 16:01 control
    brw-rw---- 1 root disk 251, 0 2010-07-26 16:01 sil_bgahdiccejcc
    brw-rw---- 1 root disk 251, 1 2010-07-26 16:01 sil_bgahdiccejcc1
    brw-rw---- 1 root disk 251, 2 2010-07-26 16:01 sil_bgahdiccejcc2


    eu preciso alterar algo?lembrando que no grub2 não posso alterar o grub.cfg e sim o arquivo: /etc/default/grub

    que tem dentro:


    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    Última edição por lfernandosg; 26-07-2010 às 16:20.