Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal, estou usando o wpad.dat e proxy.pac, apesar de está funcionando muito bem, mas tem um porém.

    Quando configuro no browser para usar "Detectar Automaticamente as Configurações" de uma estação pertencendo um domino Samba PDC. não consigo acessar o relatório do sarg via web, o qual requer usuário e senha.

    Mas se altero no Browser e informo na Opção LAN o IP do Proxy + porta "192.168.0.1 3128" desta forma eu consigo digitar o usuário e senha que dar acesso ao relatório.


    Alguém saber porque acontece isso?

    Abraço

  2. Código :
    function FindProxyForURL(url, host) {
        if (isInNet(host, "192.168.100.0", "255.255.255.0"))
            return "DIRECT";
        else
            return "PROXY 192.168.100.250:3128";
    }

    Bem, aqui especifica que se o acesso for a algum ip da rede, não acessa pelo proxy.
    Acho que isso é bom para seu sarg, certo?

    Luiz (fl0cker) Blog



  3. Mais já uso desta forma, por exemplo:

    Código :
    function FindProxyForURL(url, host) {
    if(isPlainHostName(host) || isInNet(host, "192.168.0.0", "255.255.255.0") || dnsDomainIs(host, "update.microsoft.com"))
      return "DIRECT";
    else
      return "PROXY 192.168.0.1:3128";
    }
    E o problema continua, não sei porque quando informo o ip do proxy + a porta manualmente no browser, o acesso ao relatório funciona.
    Última edição por osmano807; 24-07-2010 às 14:40.

  4. Bem... então... fez o NAT certinho? Sem proxy acesso algo?



  5. Citação Postado originalmente por osmano807 Ver Post
    Bem... então... fez o NAT certinho? Sem proxy acesso algo?
    Sim,

    Mas na Verdade amigão não está funcionando nada com o wpad.dat configurado para dar acesso via web no browser, irei posta todos os arquivos a respeito do wpad. quem sabe vc ou alguém do forúm com olho clinico encontre o problema.

    Começo com com o Apache2

    Em /etc/apache2/httpd.conf

    <VirtualHost wpad.opcaolinux.net>
    ServerName server-pdc
    ServerAlias proxy.* wpad.*
    DirectoryIndex wpda.dat
    DocumentRoot "/var/www/proxy"
    CustomLog /var/log/apache2/wpad-dat.log combined
    ErrorLog /var/log/apache2/error-wpad-dat.log
    LogLevel warn
    AddType application/x-ns-proxy-autoconfig .dat
    AddType application/x-ns-proxy-autoconfig .pac
    Alias /wpad.dat "/var/www/proxy/wpad.dat"
    Alias /wpad.da "/var/www/proxy/wpad.dat"

    Alias /proxy.pac "/var/www/proxy/wpad.dat"
    <Location "/">
    ForceType application/x-ns-proxy-autoconfig
    </Location>
    <Directory "/var/www/proxy/">
    Order allow,deny
    Allow from 192.168. 127.
    AllowOverride FileInfo AuthConfig Limit
    ForceType application/x-ns-proxy-autoconfig
    </Directory>
    </VirtualHost>

    Em /var/www/proxy tem os arquivos wpad.dat e proxy.pac

    No /etc/dhcp3/dhcpd.conf tem as linhas
    option wpad code 252 = text;
    option wpad "http://192.168.0.1/wpad.dat\n";

    Na Zona no bind9 eu dexei a linha:

    wpad A 192.168.0.1


    Fazendo um teste de ping para resolver o nome:

    valdir@server-pdc:~$ ping wpad
    PING wpad.opcaolinux.net (192.168.0.1) 56(84) bytes of data.
    64 bytes from server-pdc.opcaolinux.net (192.168.0.1): icmp_seq=1 ttl=64 time=0.033 ms
    64 bytes from server-pdc.opcaolinux.net (192.168.0.1): icmp_seq=2 ttl=64 time=0.020 ms
    64 bytes from server-pdc.opcaolinux.net (192.168.0.1): icmp_seq=3 ttl=64 time=0.017 ms

    valdir@server-pdc:~$ dig wpad.opcaolinux.net

    ; <<>> DiG 9.4.2-P2.1 <<>> wpad.opcaolinux.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23133
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;wpad.opcaolinux.net. IN A

    ;; ANSWER SECTION:
    wpad.opcaolinux.net. 302400 IN A 192.168.0.1

    ;; AUTHORITY SECTION:
    opcaolinux.net. 38400 IN NS server-pdc.opcaolinux.net.

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jul 27 21:17:06 2010
    ;; MSG SIZE rcvd: 78


    E mesmo assim quando configuro o browser para "Detectar Automaticamente Configurações"
    Não da acesso a internet.

    Alguém sabe o que falta para funcionar?

    Abraço
    Última edição por gamaj1; 27-07-2010 às 20:26.






Tópicos Similares

  1. Respostas: 1
    Último Post: 23-01-2013, 23:20
  2. Respostas: 2
    Último Post: 02-09-2008, 22:58
  3. Quero barrar o acesso a net e deixar apenas 1 site liberado
    Por overkill13 no fórum Servidores de Rede
    Respostas: 7
    Último Post: 24-11-2004, 07:46
  4. Acesso a Net com IP Fixo ....
    Por pssgyn no fórum Servidores de Rede
    Respostas: 3
    Último Post: 05-03-2004, 08:25
  5. Usando apt-get para baixar e instalar pacotes é ?...
    Por APT-GET?... no fórum Servidores de Rede
    Respostas: 5
    Último Post: 27-02-2004, 19:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L