+ Responder ao Tópico



  1. #1

    Padrão Fazendo Backup Automatico com Mikrotik

    Fazendo Backup Automatico com Mikrotik


    set [email protected] password=senha23 server=servidordeemail username=bkp
    #
    # Backups automáticos via e-mail
    #
    /system script
    remove bkp
    remove envia
    add name=envia_backup source={
    #
    # Configuracao
    :gl email "[email protected]"
    :gl servidor "ip do servidor"
    # Variaveis
    :gl dia ([:ick [/system clock get date] 4 6])
    :gl mes ([ick [/system clock get date] 0 3])
    :gl ano ([ick [/system clock get date] 7 11])
    :gl hora [/sys cl get time]
    :gl rb [/sys id get name]
    #:gl arquivo ($rb . "_" . $dia.$mes.$ano)
    :gl arquivo ($rb . "_" . $mes)
    #
    :log info "Gerando backup..."
    /system backup save name=$arquivo
    #
    # Aguarda um tempo para o Backup
    :delay 30s
    :log info "Enviando backup por e-mail..."
    /tool e-mail send to="$email" subject=($rb . " \
    ".$dia.$mes.$ano . "-".$hora) from=$email file=$arquivo server=$servidor
    /tool e-mail send to="[email protected]" subject=($rb . " \
    ".$dia.$mes.$ano . "-".$hora) from=$email file=$arquivo server=$servidor
    # Comentar a proxima linha SE for RouterOS < 4
    #tls=yes
    #
    :log info "Backup terminado."
    }
    #
    # Configurando o agendador de tarefas para envio a cada 5 dias, 5h
    /sys scheduler
    add name="envia_backup" on-event="backup" start-date=jan/01/1970 \
    start-time=05:00:00 interval=5d disabled=no
    #
    Última edição por fabriciodantas; 26-07-2010 às 22:00.

  2. #2

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    poxa o que seria eses circulos amarelos, ??? não deu pra entender bem..



  3. #3

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    set [email protected] password=senha23 server=servidordeemail username=bkp
    #
    # Backups automáticos via e-mail
    #
    /system script
    Última edição por fabriciodantas; 26-07-2010 às 22:12.

  4. #4

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    Boa noite,

    por favor da uma olhada no meu blog.

    Mikrotik
    Última edição por fabriciodantas; 26-07-2010 às 22:09.



  5. #5

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    vc ta com depressao rapaz
    pra que isso tudo pra fazer um backup
    da uma pesquisada ai no forum que tem coisa
    bem mais simples



    Citação Postado originalmente por fabriciodantas Ver Post
    Boa noite,

    por favor da uma olhada no meu blog.

    Mikrotik

  6. #6

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    Amigo (cobrabatita) apesar das regras do amigo "fabricio dantas" serem um pouco grande, a eficacia é bem mais pois impõe o mk a obedecelas com precisão, as regras são otimas e devem ser usadas por todos q desegem usar-las.



  7. #7

    Thumbs up Re: Fazendo Backup Automatico com Mikrotik

    Concordo,!!!

  8. #8

    Padrão Re: Fazendo Backup Automatico com Mikrotik

    Citação Postado originalmente por fabriciodantas Ver Post
    Fazendo Backup Automatico com Mikrotik


    set [email protected] password=senha23 server=servidordeemail username=bkp
    #
    # Backups automáticos via e-mail
    #
    /system script
    remove bkp
    remove envia
    add name=envia_backup source={
    #
    # Configuracao
    :gl email "[email protected]"
    :gl servidor "ip do servidor"
    # Variaveis
    :gl dia ([:ick [/system clock get date] 4 6])
    :gl mes ([ick [/system clock get date] 0 3])
    :gl ano ([ick [/system clock get date] 7 11])
    :gl hora [/sys cl get time]
    :gl rb [/sys id get name]
    #:gl arquivo ($rb . "_" . $dia.$mes.$ano)
    :gl arquivo ($rb . "_" . $mes)
    #
    :log info "Gerando backup..."
    /system backup save name=$arquivo
    #
    # Aguarda um tempo para o Backup
    :delay 30s
    :log info "Enviando backup por e-mail..."
    /tool e-mail send to="$email" subject=($rb . " \
    ".$dia.$mes.$ano . "-".$hora) from=$email file=$arquivo server=$servidor
    /tool e-mail send to="[email protected]" subject=($rb . " \
    ".$dia.$mes.$ano . "-".$hora) from=$email file=$arquivo server=$servidor
    # Comentar a proxima linha SE for RouterOS < 4
    #tls=yes
    #
    :log info "Backup terminado."
    }
    #
    # Configurando o agendador de tarefas para envio a cada 5 dias, 5h
    /sys scheduler
    add name="envia_backup" on-event="backup" start-date=jan/01/1970 \
    start-time=05:00:00 interval=5d disabled=no
    #
    Amigo ele ta completo ou tem que mudar alguma coixa?