+ Responder ao Tópico



  1. #1

    Padrão Mikrotik 3.22 como fazer cache full ?

    galera estou utilizando a versão 3.22, tentei por varias vezes implantar o cahe full, nas nos tutoriais que encontro é da versão 2.9, como meu conhecimento é muito pequeno em mikrotik, creio que estou fazendo bobagem, por isso busco ajuda dos meus Professores aqui do forum para me ajudarem a implantarem aqui o tão famoso "Cache Full", se possivel um passo-a-passo pois como disse meu conhecimento é bem pequeno, desde já grato pela ajuda e um forte abraço a todos.

  2. #2

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    no link abaixo tem tudo sobre cache full usando somente o proxy do mikrotik.

    http://forum.mikrotik.com/viewtopic.php?f=13&t=36565
    Última edição por pedrovigia; 02-08-2010 às 00:17. Razão: ortografia



  3. #3

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    amigo fico imensamente grato pela boa vontade, mas como disse no tópico sou muito leigo em MK em ingles ai piorou mais ainda, eu vi nesse link um monte de códigos mas não faço a minima ideia de onde coloca-los ou o que mudar para que o mesmo funcione na minha rede, meu MK tem o seguinte IP 192.168.0.50/24 meus clientes estão na faixa de IP 192.168.0.100 - 192.168.0.150, grato pela ajuda e peço desculpas pela minha falta de conhecimento, um forte abraço

  4. #4

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    adiciona as regras abaixo no mikrotik que é certo ele irar marcar pelo tos do proxy local ....

    no seu firewall nat:
    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="NAT - Proxy" disabled=no
    no seu proxy:
    /ip proxy
    set cache-hit-dscp=4
    na tabela mangle:
    / ip firewall mangle
    add chain=postrouting protocol=tcp src-port=3128 dscp=4 action=mark-connection new-connection-mark=n-cache passthrough=yes comment="Marca o com e sem TOS" disabled=no


    add chain=postrouting protocol=tcp src-port=3128 dscp=!4 action=mark-connection new-connection-mark=s-cache passthrough=yes comment="" disabled=no


    add chain=postrouting connection-mark=n-cache action=mark-packet new-packet-mark=Cache-Packet passthrough=no comment="Libera cache full" disabled=no
    no seu queue type:

    / queue type
    add name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    no seu queues tree:
    / queue tree
    add name="CACHE-FULL" parent=global-out packet-mark=Cache-Packet limit-at=0 queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    e já estara funcionando com tudo do cache saindo não a full mais a 4.8MB para cada cliente e vc altera essa velocidade no queues type.

    Citação Postado originalmente por wanderley85 Ver Post
    amigo fico imensamente grato pela boa vontade, mas como disse no tópico sou muito leigo em MK em ingles ai piorou mais ainda, eu vi nesse link um monte de códigos mas não faço a minima ideia de onde coloca-los ou o que mudar para que o mesmo funcione na minha rede, meu MK tem o seguinte IP 192.168.0.50/24 meus clientes estão na faixa de IP 192.168.0.100 - 192.168.0.150, grato pela ajuda e peço desculpas pela minha falta de conhecimento, um forte abraço
    Última edição por pedrovigia; 04-08-2010 às 09:40. Razão: ortografia



  5. #5
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    pedrovigia

    Muito bom mesmo amigo, parabéns por sua boa vontade em ajudar o amigo e acabou me ajudando também, ótimo mesmo, estarei fazendo alguns teste no servidor de teste antes de está adicionando essas regras de cache-full no servidor dos clientes!

    Abração!

  6. #6
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Observando o script
    / queue tree
    add name="CACHE-FULL" parent=global-out packet-mark=Cache-Packet limit-at=0 queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    Onde está em negrito, em priority=8, não seria melhor deixar mais baixa em casa de entrar em fileira ele nao está na frente?
    Andei pesqueisando aque mesmo no forum onde outros membros informam o mesmo, desculpa se estiver errado, mais fica essa minha dúvida!



  7. #7

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Exatamente, se deixar em 8 o cache é o ultimo da fila!!!

  8. #8
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Citação Postado originalmente por int21 Ver Post
    Exatamente, se deixar em 8 o cache é o ultimo da fila!!!
    Certo amigo, obrigado!



  9. #9

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    amigo sou muito "Noob" em Mikrotik, sou novato mesmo, quando vcs mandam eu colocar esses comando por exemplo:

    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="NAT - Proxy" disabled=no

    ou

    /ip proxy
    set cache-hit-dscp=4

    onde eu devo colocar esse comandos ? como devo inserir esses comandos no Mikrotik ? Peço um pouco de paciencia comigo pois como disse tenho uma idea lega de compreensão do sistema, mas as vezes me perco como nesse ponto, grato pela ajuda e compreensão de todos

  10. #10
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Citação Postado originalmente por wanderley85 Ver Post
    amigo sou muito "Noob" em Mikrotik, sou novato mesmo, quando vcs mandam eu colocar esses comando por exemplo:

    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="NAT - Proxy" disabled=no

    ou

    /ip proxy
    set cache-hit-dscp=4

    onde eu devo colocar esse comandos ? como devo inserir esses comandos no Mikrotik ? Peço um pouco de paciencia comigo pois como disse tenho uma idea lega de compreensão do sistema, mas as vezes me perco como nesse ponto, grato pela ajuda e compreensão de todos
    Simples mano, vai no Terminal e coloca lá copia e cola, qualquer coisa tamos aque!



  11. #11

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Poxa amigo é facil assim ? Só mais uma Duvida utilizando o codigo abaixo apenas como um exemplo:
    / ip firewall nat
    add chain=dstnat src-address=Faixa de ip dos seus clientes protocol=tcp dst-port=80 action=redirect to-ports=8080 comment="NAT - Proxy" disabled=no
    eu Clico em "New Terminal" copio esse código todo colo no "New Terminal" e Aperto "Enter" ou eu preciso copiar e colar uma linha de cada vez ? sei que pra vocês parece ate uma pergunta besta, outras partes mais difíceis eu ate consegui mas esses pedacinhos simples me quebra, ah só por curiosidade eu fiz o cache aqui acho que ta funcionando, eu acho eu perguntei a respeito de onde colocar esses códigos pq eu segui esse tutorial pra fazer funcionar:

    Mikrotik - UnderLinux Wiki

    e tem uma parte que o autor diz que não se pode fazer cache de paginas dinamicas e ele manda aplicar o seguinte:
    add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages" disabled=no
    add url="https://" action=deny comment="no cache dynamic https pages" disabled=no
    ai só faltou isso... grato pela ajuda

  12. #12
    Deus acima de tudo!
    Ingresso
    Jul 2009
    Localização
    Paulista - Pernambuco
    Posts
    414

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Citação Postado originalmente por wanderley85 Ver Post
    Poxa amigo é facil assim ? Só mais uma Duvida utilizando o codigo abaixo apenas como um exemplo:


    eu Clico em "New Terminal" copio esse código todo colo no "New Terminal" e Aperto "Enter" ou eu preciso copiar e colar uma linha de cada vez ? sei que pra vocês parece ate uma pergunta besta, outras partes mais difíceis eu ate consegui mas esses pedacinhos simples me quebra, ah só por curiosidade eu fiz o cache aqui acho que ta funcionando, eu acho eu perguntei a respeito de onde colocar esses códigos pq eu segui esse tutorial pra fazer funcionar:

    Mikrotik - UnderLinux Wiki

    e tem uma parte que o autor diz que não se pode fazer cache de paginas dinamicas e ele manda aplicar o seguinte:


    ai só faltou isso... grato pela ajuda
    Exemplo se você tem várias regras relacionada ao Firewall pode copiar todas de uma vez e colar e ENTER.
    se a regra estiver miste separe copie todas por exemplo relacionada ao Firewall e cole, depois vá fazendo isso com as demais, não tive tempo de olhar o Wiki que você postou estarei olhando mais tarde e em sequencia respondendo. Abraço!



  13. #13

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Se allguem estiver usando radios tipo kodama etc, (generic 4 ports) é bom ter cuidado com o valor de saida,

    a regra:
    / queue type
    add name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    esta setada acima do que o radio pode suportar, nunca usem uma saida no queue-tree solta, designem um valor tipo 2m ou algo parecido mas nunca acima disso, se um determinado arquivo estiver la cheio (4megas que é o maximo que o 3.x deixa no storage) descer a full com um cliente so pendurado o radio geralmente abre as pernas (rtl80xx).

    So esta dica, outra coisa, se o cliente paga pra ter 256k eu devolvo 256k pois com isso eu estou economizando a minha banda, pois, se ele baixa de vez ja pula pra outro e ai não houve nenhuma economia na razão principal que é tempo de acesso no link por parte do cliente, cache-full é muito legal mas so devolva a full se a rede for robusta, e se tiver link sobrando pois vc não esta tendo nada em troca, eu so uso aqui o full pára arquivos especificos como jpg, swf, gif, css, mas nada de arquivos executaveis e etc.

    Um forte abraço a todos e muito boa a materia.

  14. #14

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Amigo,como eu fasso para limitar o p2p em 50k de upload e 300k de download para que toda a rede divida essa velocidade? meu mk é 3.22.....



  15. #15

    Padrão Re: Mikrotik 3.22 como fazer cache full ?

    Bom entao seria eu usar assim:

    / queue type
    add name="cache" kind=pcq pcq-rate=1048576 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

    e no queue tree tbm defino 1M ?

    pra nao congestionar os radios

    Citação Postado originalmente por int21 Ver Post
    Se allguem estiver usando radios tipo kodama etc, (generic 4 ports) é bom ter cuidado com o valor de saida,

    a regra:
    / queue type
    add name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    esta setada acima do que o radio pode suportar, nunca usem uma saida no queue-tree solta, designem um valor tipo 2m ou algo parecido mas nunca acima disso, se um determinado arquivo estiver la cheio (4megas que é o maximo que o 3.x deixa no storage) descer a full com um cliente so pendurado o radio geralmente abre as pernas (rtl80xx).

    So esta dica, outra coisa, se o cliente paga pra ter 256k eu devolvo 256k pois com isso eu estou economizando a minha banda, pois, se ele baixa de vez ja pula pra outro e ai não houve nenhuma economia na razão principal que é tempo de acesso no link por parte do cliente, cache-full é muito legal mas so devolva a full se a rede for robusta, e se tiver link sobrando pois vc não esta tendo nada em troca, eu so uso aqui o full pára arquivos especificos como jpg, swf, gif, css, mas nada de arquivos executaveis e etc.

    Um forte abraço a todos e muito boa a materia.