Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola pessoal, ja tem 4 dias que estou tentando compilar um kernel e sempre mostra o mesmo erro, não to conseguindo ver e resolver este erro seque abaixo

    This is kernel package version 11.015.
    echo "The UTS Release version in include/linux/version.h"; echo " \"\" "; echo "does not match current version:"; echo " \"2.6.34.1\" "; echo "Please correct this."; exit 2
    The UTS Release version in include/linux/version.h
    ""
    does not match current version:
    "2.6.34.1"
    Please correct this.
    make[1]: ** [debian/stamp/install/linux-image-2.6.34.1] Erro 2
    make[1]: Saindo do diretório `/usr/src/linux-2.6.34.1'
    make: ** [kernel_image] Erro 2


    pq esta acontecendo isso???

    Obrigado

  2. Da uma olhada no seguinte post, que encontrei com uma pesquisa simples no google.

    Ubuntu Forums - View Single Post - Master Kernel Thread

    O foco é alterar dentro do arquivo version_vars.mk . as linhas:

    Código :
    UTS_RELEASE_HEADER=$(call doit,if [ -f include/generated/utsrelease.h ]; then  \
    	                       echo include/generated/utsrelease.h;            \
    	                   else                                            \
                                   echo include/generated/utsrelease.h ;              \
    	                   fi)


    Se funcionar informe, para ficar registrado.

    Att
    Tiago Iahn
    Última edição por Lynx; 03-08-2010 às 07:38.



  3. Citação Postado originalmente por Lynx Ver Post
    Da uma olhada no seguinte post, que encontrei com uma pesquisa simples no google.

    Ubuntu Forums - View Single Post - Master Kernel Thread

    O foco é alterar dentro do arquivo version_vars.mk . as linhas:

    Código :
    UTS_RELEASE_HEADER=$(call doit,if [ -f include/generated/utsrelease.h ]; then  \
    	                       echo include/generated/utsrelease.h;            \
    	                   else                                            \
                                   echo include/generated/utsrelease.h ;              \
    	                   fi)


    Se funcionar informe, para ficar registrado.

    Att
    Tiago Iahn
    Boa noite, eu tinha achado um semelhante mais tava dando erro, mudei como esta no exemplo que vc me mandou, e deu este erro segue a abaixo:

    make[2]: Entrando no diretório `/usr/src/linux-2.6.35'
    cp: impossível fazer stat em `/usr/src/linux-2.6.35/modules.order': Arquivo ou diretório não encontrado
    make[2]: ** [_modinst_] Erro 1
    make[2]: Saindo do diretório `/usr/src/linux-2.6.35'
    make[1]: ** [debian/stamp/install/linux-image-2.6.35] Erro 2
    make[1]: Saindo do diretório `/usr/src/linux-2.6.35'
    make: ** [kernel_image] Erro 2


    pelo que entendi deu erro em algum modulo, ja viu este erro antes???

    ja segui varios jeito de compilar e todos dão erro, é dificil assim compilar um kernel?

    Obrigado!

  4. O erro fala sobre "arquivo não encontrado", descubra onde ele está e copie ou crie um link para ele no local designado.

    Att
    Tiago Iahn



  5. desisto, só ta dando erro, colocquei o arquivo modules.order na pasta linux-2.6.35 ai deu outro erro do arquivo modules.builtin coloquei ele tb na pasta linux-2.6.35 ai deu outro erro, é normal este erros? pois os tutorial que to vendo ai ninguem teve tanta dificuldade igual eu to tentado risos

    eu não apliquei o patch tem haver alguma coisa com isso??


    Obrigado!






Tópicos Similares

  1. Erro ao compilar Kernel FreeBSD 6.2
    Por CEP no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 27-07-2007, 10:53
  2. Erro ao compilar kernel 2.6
    Por nikolas no fórum Servidores de Rede
    Respostas: 2
    Último Post: 02-06-2006, 08:21
  3. Erro ao compilar zaptel em debian sarge 3.1 r1
    Por LinuxKids no fórum Servidores de Rede
    Respostas: 8
    Último Post: 11-01-2006, 00:51
  4. Erro ao compilar kernel 2.6.10 (Inconsistent Kallsyms data)
    Por gregorioenrico no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-01-2005, 00:38
  5. Erro ao instalar programa no Debian com apt-get
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-02-2004, 07:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L