Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá Pessoal!

    Alguém sabe me dizer se há alguma coisa que devo implementar para fazer o CACHE FULL na versão 3.30, sendo que uso autenticação por PPPoE.

    Apliquei as regras direto da WIKI do Mikrotik: Queue with Masquerading and Internal Web-Proxy

    Minhas regras estão iguais ao da WIKI (mudando apenas a classe de IPs)

    Código PHP:
    ip firewall nat print 

    Flagsdisabledinvaliddynamic 
     0   
    ;;; Firewall NAT
         chain
    =srcnat action=masquerade src-address=192.168.4.0/24 out-interface=public 

     
    1   chain=dstnat action=redirect to-ports=3128 protocol=tcp src-address=192.168.4.0/24 in-interface=local dst-port=80 
    Código PHP:
    ip firewall mangle print 

    Flagsdisabledinvaliddynamic 
     0   
    ;;; HIT TRAFFIC FROM PROXY
         chain
    =output action=mark-packet new-packet-mark=proxy-hit passthrough=no out-interface=local dscp=

     1   
    ;;; UP TRAFFIC
         chain
    =prerouting action=mark-packet new-packet-mark=test-up passthrough=no src-address=192.168.4.0/24 in-interface=local 

     2   
    ;;; CONN-MARK
         chain
    =forward action=mark-connection new-connection-mark=test-conn passthrough=yes src-address=192.168.4.0/24 

     3   
    ;;; DOWN-DIRECT CONNECTION
         chain
    =forward action=mark-packet new-packet-mark=test-down passthrough=no in-interface=public connection-mark=test-conn 

     4   
    ;;; DOWN-VIA PROXY
         chain
    =output action=mark-packet new-packet-mark=test-down passthrough=no dst-address=192.168.4.0/24 out-interface=local 
    Código PHP:
    queue tree print 
    Flagsdisabledinvalid 
     0   name
    ="downstream" parent=local packet-mark=test-down limit-at=100M queue=default priority=8 max-limit=100M burst-limit=
         burst
    -threshold=0 burst-time=0s 

     1   name
    ="upstream" parent=global-in packet-mark=test-up limit-at=100M queue=default priority=8 max-limit=100M burst-limit=
         burst
    -threshold=0 burst-time=0s 
    Código PHP:
    ip proxy print 
                     
    enabledyes
                 src
    -address0.0.0.0
                        port
    3128
                parent
    -proxy0.0.0.0
           parent
    -proxy-port0
         cache
    -administrator"webmaster"
              
    max-cache-sizenone
               cache
    -on-diskyes
      max
    -client-connections600
      max
    -server-connections600
              max
    -fresh-time3d
       serialize
    -connectionsno
           always
    -from-cacheno
              cache
    -hit-dscp4
                 cache
    -drivesata1 
    Clique na imagem para uma versão maior

Nome:	         proxy.PNG
Visualizações:	564
Tamanho: 	21,0 KB
ID:      	13477
    Alguém pode me dizer o que poderia ser?

  2. ninguém ?
    pessoal, quem conseguiu, basta postar as regras do firewall nat, mangle, web-proxy e queue que eu já me viro só!

    pois as regras que eu encontrei aqui no forum não estão funcionando!
    Lembrando que para a versão 2.9.x eu consegui legal! Funcionou perfeito, só não estou conseguindo na versão 3.x.

    obrigado!



  3. Estava usando estas regras aqui com cache no próprio MK, não é em paralelo:
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=5128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    Ivan Galves

  4. Consegui pessoal!!

    /ip firewall nat
    add action=masquerade chain=srcnat comment=nat disabled=no \
    out-interface=public src-address=192.168.4.0/24
    add action=redirect chain=dstnat comment="redirect port 80 to 3128" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.4.0/24 \
    to-ports=3128


    /ip firewall mangle
    add action=mark-connection chain=output comment=\
    "mark connection *conn_squid-up*" content="X-Cache: HIT" disabled=\
    no new-connection-mark=conn_squid-up passthrough=yes protocol=tcp \
    src-port=3128
    add action=mark-packet chain=output comment=\
    "mark packet *pacotes_squid-up*" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment=\
    "mark connection *conn_squid-down*" disabled=no dst-port=3128 \
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment=\
    "mark packet *pacotes_squid-down*" connection-mark=conn_squid-down \
    disabled=no new-packet-mark=pacotes_squid-down passthrough=yes


    /ip firewall filter
    add action=drop chain=input comment="block external proxy" disabled=no \
    dst-port=3128 in-interface=public protocol=tcp
    add action=accept chain=input comment="accept connections from proxy" \
    disabled=no dst-port=3128 protocol=tcp


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=downstream packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=150M name=upstream packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default


    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=408555000KiB \
    max-client-connections=600 max-fresh-time=3d \
    max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 \
    port=3128 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=\
    no dst-port=23-25
    add action=allow comment=web-proxy disabled=no src-address=\
    192.168.4.0/24
    add action=deny comment=web-proxy disabled=no



  5. Citação Postado originalmente por JorgeAldo Ver Post
    Não existe cache full. Isso é lenda. O nome é "misleading".

    Não entendi, pode até existir diferentes nomes, mas todos sabendo o que é.






Tópicos Similares

  1. Respostas: 9
    Último Post: 05-11-2010, 18:45
  2. Cache Full em Mikrotik v3.30
    Por brparra no fórum Redes
    Respostas: 7
    Último Post: 20-10-2010, 19:13
  3. Cache Full na Versão 3.15
    Por mircmouse no fórum Redes
    Respostas: 13
    Último Post: 28-12-2008, 01:01
  4. Respostas: 19
    Último Post: 17-12-2008, 02:19
  5. Cache full mikrotik versão 3.4
    Por wescleybueno1 no fórum Redes
    Respostas: 12
    Último Post: 11-06-2008, 15:57

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L