+ Responder ao Tópico



  1. #1

    Padrão Tem Como atualizar o samba de 3.0.28a para 3.3 ou 3.4 pelo apt-get?

    Pessoal, estou com o Ubuntu-Server 8.04, e preciso atualizar o Samba para a versão 3.3 ou 3.4 através do apt-get.

    Infelizmente neste exato momento não posso trocar de distro para uma mais recente do Ubuntu-Server, pelo menos por um tempo, mas preciso usar o Samba com uma versão mais recente.

    Estou com uma máquina com Windows 7 Prof. e pelo que andei lendo só o samba 3.3 ou 3.4 irá ter exito em colocar o windows 7 no dominio.

    Alguém sabe alguma mirror que instale esta versão do samba no Ubuntu-server 8.04?

  2. #2

    Padrão Re: Tem Como atualizar o samba de 3.0.28a para 3.3 ou 3.4 pelo apt-get?

    Amigo,

    Eu também trabalho com servidores com Samba mais antigos e realmente a unica solução que achei foi atualizar os linux aos poucos.
    Tentei instalar o Samba na mão (recompilando pelo tar.gz) mas não deu muito certo e preferi não insistir.
    Pelo Apt-get não tem o 3.3 ou 3.4 para a versão do teu ubuntu.

    Tem um comando do ubuntu - apt-get distro-upgrade (alguma coisa assim) que ele baixa os pacotes da nova distro (10.04) e atualiza tudo.
    Se for fazer isto, sugiro fazer um Ghost do teu sistema original e depois fazer isto para caso de um erro, pelo menos tu tem o sistema ok

    Caso não consiga agora, a unica forma que encontrei de os Win7 acessarem a rede com dominio pelo samba mais antigo foi criando um usuario e senha no win7 (usuario local) com o mesmo usuario e senha do dominio.
    Eh ruim fazer isto mas eh um quebra-galho



  3. #3
    Fmotta
    Visitante

    Padrão Re: Tem Como atualizar o samba de 3.0.28a para 3.3 ou 3.4 pelo apt-get?

    Para instalar a partir dele basta verifica se o mesmo está no seu sources.list, deve haver uma linha desta forma:


    deb Index of /debian lenny-backports main contrib non-free


    Para instalar a versão do samba desse repositório você pode fazer da seguinte forma:


    apt-get -t lenny-backports install samba


    Você pode também utilizar a opção -s para simular a instalação primeiramente:


    apt-get -s -t lenny-backports install samba

    Old Nabble - Re: Debian Lenny + Samba 3.5.3

    Faça um Backup do Sistema antes só pra garantir, mas fiz aqui e funcionou BLZ.

  4. #4

    Padrão Re: Tem Como atualizar o samba de 3.0.28a para 3.3 ou 3.4 pelo apt-get?

    Valeu amigo, já estou usando o Samba 3.4.7 pois instei o Ubuntu-server 10.4, infelizmente eu só agora vi sua resposta, e sofri para reconfigurar todos os serviços que rodam neste server.

    Mas estou com o Samba 3.0.28a no HD antigo, e irei fazer o teste.

    Obrigado