Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Laod balance 2 links adsl com modens roteados

    Olá caros amigos do under-linux aqui estou eu com mais uma duvida que está fazendo meus neurônios ferverem... eu quero fazer um loadbanle com 2 links ADSL em os Modens estão em modo roteado. São dois modens Dlink ADSL 500b 2+ (Black), meu cenário e o seguinte!
    Modem 1 link 8mb ligado ether1
    Gateway 192.168.1.1
    Modem 2 link 1mb ligado ether2
    Gateway 192.168.1.254
    Saída ether3
    10.1.1.1
    minha RB é uma 433 AH MK v.4.11
    Já fiz todos os tutorias que ensinam no fórum e não funciona de forma alguma por ultimo fiz este que vou posta logo abaixo... gostaria de contar com ajuda de vcs para mais esse feito e desde já agradeço a colaboração de todos
    minha configuração:
    / ip address
    add address=10.1.1.1/24 network=10.1.1.0 broadcast=10.1.1.255 interface=Local
    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
    add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.1 interface=ether2
    / ip firewall mangle
    add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn
    add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
    add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    add chain=prerouting dst-address=192.168.1.1/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.1.254/24 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/0 \
    action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/1 \
    action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    add chain=prerouting connection-mark=ether1_conn in-interface=Local action=mark-routing new-routing-mark=to_ether1
    add chain=prerouting connection-mark=ether2_conn in-interface=Local action=mark-routing new-routing-mark=to_ether2

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 distance=2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade
    add chain=srcnat out-interface=ether2 action=masquerade

    IP Addresses
    / ip address
    add address=10.1.1.1/24 network=10.1.1.0 broadcast=10.1.1.255 interface=Local
    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
    add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether2

    / ip firewall mangle
    add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn
    add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
    add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    add chain=prerouting dst-address=192.168.1.1/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.1.254/24 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/0 \
    action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/1 \
    action=mark-connection new-connection-mark=wlan2_conn passthrough=yes
    add chain=prerouting connection-mark=ether1_conn in-interface=Local action=mark-routing new-routing-mark=to_ether1
    add chain=prerouting connection-mark=ether2_conn in-interface=Local action=mark-routing new-routing-mark=to_ether2

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 distance=2 check-gateway=ping


    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade
    add chain=srcnat out-interface=ether2 action=masquerade
    esta desta forma e não conecta de geito nem um pela porta de saida ether3 com o ip 10.1.1.1/24 e nem uma outra classe de ips...

  2. #2

    Padrão Re: Laod balance 2 links adsl com modens roteados

    ola amigo,seus modens estao na mesma rage de ips,o correto seria link 1 192.168.1.1,link 2 192.168.2.1.



  3. #3

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Bom dia amigo..mude a range de ip..por ex:

    192.168.0.254 (Modem 1 )
    192.168.1.254 (Modem 2 )

    Na RB coloque desta forma..ex:

    eth1 - 192.168.0.253 (comunicar com modem 1)
    eth2 - 192.168.1.253 (comunicar com modem 2)
    eth3 - 192.168.254.1 (interface dos clientes)

    depois bloquei o acesso ao modem na rede interna...
    va em Firewall:
    chain: forward; src. Adress: 192.168.254.0/24; dst. Adress: 192.168.0.254; Protocol: 6(tcp); Action: drop
    criei esta mesma regra para o outro modem.. 192.168.1.254
    abraço!
    Última edição por felilogo; 25-08-2010 às 07:00.

  4. #4

    Padrão Re: Laod balance 2 links adsl com modens roteados

    vc esqueceu dos DNS amigo:
    Código :
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


    Teste ai e reporta senao funcionar.



  5. #5

    Padrão Re: Laod balance 2 links adsl com modens roteados

    ok! vou fazer as devidas alterações é posto o resultado...

  6. #6

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por sostenes Ver Post
    ola amigo,seus modens estao na mesma rage de ips,o correto seria link 1 192.168.1.1,link 2 192.168.2.1.
    Fiz desta forma
    link 1:192.168.1.1 8mb
    link 2:192.168.2.1 1mb
    Local:10.1.1.1

    Citação Postado originalmente por Geeek Ver Post
    vc esqueceu dos DNS amigo:
    Código :
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
    Coloquei este DNS ele e do google né o meu aki é 201.10.128.3/201.10.120.3 da Brt mais esse funciona tbm eu creio que quase todo mundo usa ele...
    e nem assim ainda funcionou meu scrip fico assim agora:

    / ip address
    add address=10.1.1.254/24 network=10.1.1.0 broadcast=10.1.1.255 interface=Local
    add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
    add address=192.168.2.254/24 network=192.168.2.0 broadcast=192.168.2.255 interface=ether2
    / ip firewall mangle
    add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn
    add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
    add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    add chain=prerouting dst-address=192.168.1.1/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.2.1/24 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/0 \
    action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/1 \
    action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    add chain=prerouting connection-mark=ether1_conn in-interface=Local action=mark-routing new-routing-mark=to_ether1
    add chain=prerouting connection-mark=ether2_conn in-interface=Local action=mark-routing new-routing-mark=to_ether2

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade
    add chain=srcnat out-interface=ether2 action=masquerade


    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
    fico grato pela ajuda de vez e gostaria que vcs me auxiliacem neste problema... sou novo com MK!
    e agradeço os feras nessa área...
    dede já muito grato..
    Última edição por claudinhohw; 25-08-2010 às 10:45.



  7. #7

    Padrão Re: Laod balance 2 links adsl com modens roteados

    seta os modens com range de ip diferente o mude sua netmask.
    vc colocou num no 192.168.1.1 o broadcast .254...... e no 192.168.1.254 vc colocou o broadcast .1.1 .... muda isso...
    192.168.1.0/30 netmask 255.255.255.252 gateway 192.168.1.1 eth 192.168.1.2
    192.168.1.252/30 netmask 255.255.255.252 gateway 192.168.1.254 eth 192.168.1.253

    ou se quizer deixar a netmask /24
    192.168.1.1
    192.168.2.1

    nao esqueça dos DNS

  8. #8

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por gbovelar Ver Post
    seta os modens com range de ip diferente o mude sua netmask.
    vc colocou num no 192.168.1.1 o broadcast .254...... e no 192.168.1.254 vc colocou o broadcast .1.1 .... muda isso...
    192.168.1.0/30 netmask 255.255.255.252 gateway 192.168.1.1 eth 192.168.1.2
    192.168.1.252/30 netmask 255.255.255.252 gateway 192.168.1.254 eth 192.168.1.253

    ou se quizer deixar a netmask /24
    192.168.1.1
    192.168.2.1

    nao esqueça dos DNS
    amigo segui suas dicas tbm não tive êxito nem um ainda, mesmo assim obrigado pra mim serviria o load balance Failover, pois tenho 2 links link1 8mb link2 1mb quando o de 8mb cair o de 1mb entra só pra nao ficar sem msm... segue a configuração de como fico agora...

    / ip address
    add address=10.1.1.254/24 network=10.1.1.0 broadcast=10.1.1.1 interface=Local
    add address=192.168.1.254/30 network=192.168.1.0 broadcast=192.168.1.1 interface=ether1
    add address=192.168.2.254/30 network=192.168.2.0 broadcast=192.168.2.1 interface=ether2
    / ip firewall mangle
    add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn
    add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
    add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    add chain=prerouting dst-address=192.168.1.1/30 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.2.1/30 action=accept in-interface=Local
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/0 \
    action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/1 \
    action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    add chain=prerouting connection-mark=ether1_conn in-interface=Local action=mark-routing new-routing-mark=to_ether1
    add chain=prerouting connection-mark=ether2_conn in-interface=Local action=mark-routing new-routing-mark=to_ether2

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade
    add chain=srcnat out-interface=ether2 action=masquerade


    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=201.10.128.3,201.10.120.3



  9. #9

    Padrão Re: Laod balance 2 links adsl com modens roteados

    bom amigo,essas conf que vc esta usando estao erradas,primeiro te aconselho a usar modens em bridge vc tera um desempenho melhor em seu lb,segundo as marcações de peso no mangle estao erradas pois se vc tem um link de 8M e um de 1M tem que a ver 8 marcações pro link de 8M ,e 1 pro link de 1M.

    tenho um tutorial meu que funciona perfeita mente e so vc adaptar as suas necessidades,te aconselho a resetar seu lb e começar do zero, crie os discadores pppoe e desmarque as opções de add default router e use peer DNS, crie nat para as interfaces pppoe, e nao confunda com nat para interface eth, depois siga o típico:

    https://under-linux.org/f227/load-ba...ilover-139132/

    Eliminando as configurações para o Link3 e em pcc possibilidades use essas marcações:

    Código :
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/1
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/2
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/3
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/4
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/5
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/6
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/7
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link2" disabled=no dst-address-type=!local in-interface= new-connection-mark=link2adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/8

    boa sorte.

  10. #10

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por sostenes Ver Post
    bom amigo,essas conf que vc esta usando estao erradas,primeiro te aconselho a usar modens em bridge vc tera um desempenho melhor em seu lb,segundo as marcações de peso no mangle estao erradas pois se vc tem um link de 8M e um de 1M tem que a ver 8 marcações pro link de 8M ,e 1 pro link de 1M.

    tenho um tutorial meu que funciona perfeita mente e so vc adaptar as suas necessidades,te aconselho a resetar seu lb e começar do zero, crie os discadores pppoe e desmarque as opções de add default router e use peer DNS, crie nat para as interfaces pppoe, e nao confunda com nat para interface eth, depois siga o típico:

    https://under-linux.org/f227/load-ba...ilover-139132/

    Eliminando as configurações para o Link3 e em pcc possibilidades use essas marcações:

    Código :
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/1
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/2
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/3
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/4
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/5
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/6
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/7
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link2" disabled=no dst-address-type=!local in-interface= new-connection-mark=link2adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/8

    boa sorte.
    muito obrigado amigo pelas dica mais não intendi muito bem sou novo com mk só a 4meses que estou estudando esse software... mais vou ver se consigo fazer e que não sei enterpretar muito bem esses scripts como o seu que vc me sugeril no link vou continuar tentando... vou fazer o reset e começar do zero... depois posto o resultado...



  11. #11

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Amigo vou postar pra vc uma configuração pronta de um servidor q eu fiz pra um cliente!
    Modens em bridge!
    Essas configs sao de uma 433AH tbm divirta-se

    system resource print
    uptime: 1d17h55m46s
    version: "4.11"
    free-memory: 106260kB
    total-memory: 127408kB
    cpu: "MIPS 24K V7.4"
    cpu-count: 1
    cpu-frequency: 680MHz
    cpu-load: 9
    free-hdd-space: 30480kB
    total-hdd-space: 61440kB
    write-sect-since-reboot: 17277
    write-sect-total: 161912
    bad-blocks: 0.1%
    architecture-name: "mipsbe"
    board-name: "RB433AH"
    platform: "MikroTik"
    *****************************************

    Código :
    /interface ethernet
     
    set 0 arp=enabled auto-negotiation=yes comment="Interfaces  F\EDsicas de Rede" disabled=no full-duplex=yes l2mtu=1526 mac-address=00:0C:42:38:D7:CF mtu=\
        1500 name="Modem A" speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1522 mac-address=00:0C:42:38:D7:D0 \
        master-port=none mtu=1500 name="Modem B" speed=100Mbps
    set 2 arp=reply-only auto-negotiation=yes bandwidth=unlimited/unlimited comment="Interface de Saida da Rede" disabled=no full-duplex=yes l2mtu=1522 \
        mac-address=00:0C:42:38:D7:D1 master-port=none mtu=1500 name=EthClientes speed=100Mbps
    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="PPPOE do Modem A, \"\"8Mbps" dial-on-demand=no disabled=no interface="Modem A" \
        max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkA password=neca1 profile=default service-name="" use-peer-dns=no [email protected]
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="PPPOE do Modem B, \"\"8Mbps" dial-on-demand=no disabled=no interface="Modem B" \
        max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkB password=2138374572 profile=default service-name="" use-peer-dns=no user=\
        [email protected]
     
    /ip dns
     
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
     
    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="hotspot network" disabled=no interface=EthClientes network=192.168.0.0
     
     
    /ip firewall address-list
     
    add address=200.155.0.0/16 comment="" disabled=no list=BRADESCO
    add address=200.201.0.0/16 comment="" disabled=no list=CEF
    add address=170.66.0.0/24 comment="" disabled=no list=BB
    add address=200.220.0.0/16 comment="" disabled=no list=SANTANDER
    add address=200.196.0.0/16 comment="" disabled=no list=ITAU
    add address=189.56.0.0/16 comment="" disabled=no list=NOSSACAIXA
    add address=161.113.0.0/24 comment="" disabled=no list=HSBC
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO1
    add address=201.7.180.0/24 comment="" disabled=no list=GLOBO2
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO3
    add address=200.154.56.0/24 comment="" disabled=no list=TERRA
    add address=208.84.247.0/24 comment="" disabled=no list=TERRA
    add address=62.140.0.0/16 comment="" disabled=no list=RAPIDSHARE
    add address=80.152.62.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.24.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.41.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.56.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.128.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.137.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.151.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.152.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.159.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.226.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.236.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.239.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.33.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.35.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.36.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.39.0/24 comment="" disabled=no list=RAPIDSHARE
     
    /ip firewall mangle
     
    add action=accept chain=prerouting comment="SEM BALANCE/////////////////////////////////////////////////////////////////////////////////////////////////////\
        /////////////////////////////////////////////////////////////////////////////////////////////////" disabled=no dst-address-list=sem_balance \
        in-interface=EthClientes
    add action=accept chain=prerouting comment="LIBERAR SITES HTTPS" disabled=no dst-address-list=BB in-interface=EthClientes
    add action=accept chain=prerouting comment=Bradesco disabled=no dst-address-list=BRADESCO in-interface=EthClientes
    add action=accept chain=prerouting comment=CEF disabled=no dst-address-list=CEF in-interface=EthClientes
    add action=accept chain=prerouting comment=HSBC disabled=no dst-address-list=HSBC in-interface=EthClientes
    add action=accept chain=prerouting comment=Itau disabled=no dst-address-list=ITAU in-interface=EthClientes
    add action=accept chain=prerouting comment=NossaCaixa disabled=no dst-address-list=NOSSACAIXA in-interface=EthClientes
    add action=accept chain=prerouting comment=Santander disabled=no dst-address-list=SANTANDER in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo1 disabled=no dst-address-list=GLOBO1 in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo2 disabled=no dst-address-list=GLOBO2 in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo3 disabled=no dst-address-list=GLOBO3 in-interface=EthClientes
    add action=accept chain=prerouting comment=Terra disabled=no dst-address-list=TERRA in-interface=EthClientes
    add action=accept chain=prerouting comment=Rapidshare disabled=no dst-address-list=RAPIDSHARE in-interface=EthClientes
    add action=mark-connection chain=input comment="Load Balance////////////////////////////////////////////////////////////////////////////////////////////////\
        //////////////////////////////////////////////////////////////////////////////////////////////////////" connection-state=new disabled=no in-interface=\
        EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=EthLinkB new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment="Marcando Rotas" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment=Balanceando disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 \
        passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marca Rotas de Saida" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=\
        to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no
    add action=change-mss chain=forward comment="Ajuste de Quadros para o MSN///////////////////////////////////////////////////////////////////////////////////\
        ///////////////////////////////////////////////////////////////////////////////////////////////////////////////////" disabled=no new-mss=1380 protocol=\
        tcp tcp-flags=syn
     
    /ip firewall nat
     
    add action=masquerade chain=srcnat comment="Macaramento dos Links" disabled=no out-interface=EthLinkA src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=EthLinkB src-address=192.168.0.0/24
     
    /ip route
     
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA routing-mark=to_nra scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB routing-mark=to_nrb scope=30 target-scope=10
    add check-gateway=ping comment="PPPOE do Link A, 8Mbps" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA scope=30 target-scope=10
    add check-gateway=ping comment="PPPOE do Link B, 8Mbps" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkB scope=30 target-scope=10

  12. #12

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por Geeek Ver Post
    Amigo vou postar pra vc uma configuração pronta de um servidor q eu fiz pra um cliente!
    Modens em bridge!
    Essas configs sao de uma 433AH tbm divirta-se

    system resource print
    uptime: 1d17h55m46s
    version: "4.11"
    free-memory: 106260kB
    total-memory: 127408kB
    cpu: "MIPS 24K V7.4"
    cpu-count: 1
    cpu-frequency: 680MHz
    cpu-load: 9
    free-hdd-space: 30480kB
    total-hdd-space: 61440kB
    write-sect-since-reboot: 17277
    write-sect-total: 161912
    bad-blocks: 0.1%
    architecture-name: "mipsbe"
    board-name: "RB433AH"
    platform: "MikroTik"
    *****************************************

    Código :
    /interface ethernet
     
    set 0 arp=enabled auto-negotiation=yes comment="Interfaces F\EDsicas de Rede" disabled=no full-duplex=yes l2mtu=1526 mac-address=00:0C:42:38:D7:CF mtu=\
    1500 name="Modem A" speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1522 mac-address=00:0C:42:38:D7:D0 \
    master-port=none mtu=1500 name="Modem B" speed=100Mbps
    set 2 arp=reply-only auto-negotiation=yes bandwidth=unlimited/unlimited comment="Interface de Saida da Rede" disabled=no full-duplex=yes l2mtu=1522 \
    mac-address=00:0C:42:38:D7:D1 master-port=none mtu=1500 name=EthClientes speed=100Mbps
    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="PPPOE do Modem A, \"\"8Mbps" dial-on-demand=no disabled=no interface="Modem A" \
    max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkA password=neca1 profile=default service-name="" use-peer-dns=no [email protected]
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="PPPOE do Modem B, \"\"8Mbps" dial-on-demand=no disabled=no interface="Modem B" \
    max-mru=1492 max-mtu=1492 mrru=disabled name=EthLinkB password=2138374572 profile=default service-name="" use-peer-dns=no user=\
    [email protected]
     
    /ip dns
     
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
     
    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="hotspot network" disabled=no interface=EthClientes network=192.168.0.0
     
     
    /ip firewall address-list
     
    add address=200.155.0.0/16 comment="" disabled=no list=BRADESCO
    add address=200.201.0.0/16 comment="" disabled=no list=CEF
    add address=170.66.0.0/24 comment="" disabled=no list=BB
    add address=200.220.0.0/16 comment="" disabled=no list=SANTANDER
    add address=200.196.0.0/16 comment="" disabled=no list=ITAU
    add address=189.56.0.0/16 comment="" disabled=no list=NOSSACAIXA
    add address=161.113.0.0/24 comment="" disabled=no list=HSBC
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO1
    add address=201.7.180.0/24 comment="" disabled=no list=GLOBO2
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO3
    add address=200.154.56.0/24 comment="" disabled=no list=TERRA
    add address=208.84.247.0/24 comment="" disabled=no list=TERRA
    add address=62.140.0.0/16 comment="" disabled=no list=RAPIDSHARE
    add address=80.152.62.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.24.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.41.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.56.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.231.128.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.137.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.151.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.152.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.159.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.226.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.236.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=80.239.239.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.33.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.35.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.36.0/24 comment="" disabled=no list=RAPIDSHARE
    add address=82.129.39.0/24 comment="" disabled=no list=RAPIDSHARE
     
    /ip firewall mangle
     
    add action=accept chain=prerouting comment="SEM BALANCE/////////////////////////////////////////////////////////////////////////////////////////////////////\
    /////////////////////////////////////////////////////////////////////////////////////////////////" disabled=no dst-address-list=sem_balance \
    in-interface=EthClientes
    add action=accept chain=prerouting comment="LIBERAR SITES HTTPS" disabled=no dst-address-list=BB in-interface=EthClientes
    add action=accept chain=prerouting comment=Bradesco disabled=no dst-address-list=BRADESCO in-interface=EthClientes
    add action=accept chain=prerouting comment=CEF disabled=no dst-address-list=CEF in-interface=EthClientes
    add action=accept chain=prerouting comment=HSBC disabled=no dst-address-list=HSBC in-interface=EthClientes
    add action=accept chain=prerouting comment=Itau disabled=no dst-address-list=ITAU in-interface=EthClientes
    add action=accept chain=prerouting comment=NossaCaixa disabled=no dst-address-list=NOSSACAIXA in-interface=EthClientes
    add action=accept chain=prerouting comment=Santander disabled=no dst-address-list=SANTANDER in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo1 disabled=no dst-address-list=GLOBO1 in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo2 disabled=no dst-address-list=GLOBO2 in-interface=EthClientes
    add action=accept chain=prerouting comment=Globo3 disabled=no dst-address-list=GLOBO3 in-interface=EthClientes
    add action=accept chain=prerouting comment=Terra disabled=no dst-address-list=TERRA in-interface=EthClientes
    add action=accept chain=prerouting comment=Rapidshare disabled=no dst-address-list=RAPIDSHARE in-interface=EthClientes
    add action=mark-connection chain=input comment="Load Balance////////////////////////////////////////////////////////////////////////////////////////////////\
    //////////////////////////////////////////////////////////////////////////////////////////////////////" connection-state=new disabled=no in-interface=\
    EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=EthLinkB new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment="Marcando Rotas" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment=Balanceando disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marca Rotas de Saida" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=\
    to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no
    add action=change-mss chain=forward comment="Ajuste de Quadros para o MSN///////////////////////////////////////////////////////////////////////////////////\
    ///////////////////////////////////////////////////////////////////////////////////////////////////////////////////" disabled=no new-mss=1380 protocol=\
    tcp tcp-flags=syn
     
    /ip firewall nat
     
    add action=masquerade chain=srcnat comment="Macaramento dos Links" disabled=no out-interface=EthLinkA src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=EthLinkB src-address=192.168.0.0/24
     
    /ip route
     
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA routing-mark=to_nra scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB routing-mark=to_nrb scope=30 target-scope=10
    add check-gateway=ping comment="PPPOE do Link A, 8Mbps" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA scope=30 target-scope=10
    add check-gateway=ping comment="PPPOE do Link B, 8Mbps" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkB scope=30 target-scope=10
    muito obrigado caro Geeek mais tenho mais uma pergunta e desde já pesso descupas por ser tão leigo em materia de configuração de mk o meu e essa mesma versão eu o atualizei!

    1º como devera ficar a configuração das minhas ethers 1,2 e 3
    2º meus modens são roteados 1 dlink 500b 2+ e speedthuch
    3º só com esse escript que vc mando eu posso fazer esse load balance?
    4º se não como deverei proceder com a configuração gostaria que se possivel vcs me deem algumas dicas gostaria de intender o porque desse escript ser assim não apenas CTRL+C CTRL+V todas configuraçãos que fiz até agora foram em vão... não tive exito em nem uma

    Moro em goiás estou de planos fazer um curso da mk mais não tem nem um proximo daqui o mais proximo e em salvador...
    desde já muito grato pela colaboração...

    parece brincadeira mais só hoje já resetei minha RB umas 11x
    Última edição por claudinhohw; 26-08-2010 às 16:19.



  13. #13

    Padrão Re: Laod balance 2 links adsl com modens roteados

    1º como devera ficar a configuração das minhas ethers 1,2 e 3
    2º meus modens são roteados 1 dlink 500b 2+ e speedthuch
    3º só com esse escript que vc mando eu posso fazer esse load balance?
    4º se não como deverei proceder com a configuração gostaria que se possivel vcs me deem algumas dicas gostaria de intender o porque desse escript ser assim não apenas CTRL+C CTRL+V todas configuraçãos que fiz até agora foram em vão... não tive exito em nem uma
    reseta sua RB, depois de resetar ela copia o codigo e cola no terminal e deixa rolar, que tudo vai se fazer...

    R1: a ether1 e 2 vai ser entradar de link, "sao para os modem".

    R2: reseta os modem e deixa ele em bridge, quem vai discar o velox vai ser o mikrotik, trabalhar com modem roteado é furada pois o hardware dele é muito fraco e sua contrack "coração do roteador" é limitada e por isso ele fica travando quando nao tem mais memoria.

    R3:pode sim qualquer duvida vc entra no router que fiz e peguei as conf e postei e veja ele funcionando em tempo real: Address: superlink.freeddns.com user: print senha: print

    R4: Não sou bom professor mas posso te indicar um tópico que fala sobre o loadbalance PCC by Luciano Rampaneli , ele traduziu de forma simples o que esta na wiki do mikrotik

    Boa Sorte!
    Última edição por Geeek; 26-08-2010 às 17:26.

  14. #14

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por Geeek Ver Post
    Boa Sorte!
    vlw amigo vou tentar aki posto o resultado hj ainda so que tenho mais um problemas meus modens não pedem ficar em bridge pois tenho uma rede utp ligadas neles



  15. #15

    Padrão Re: Laod balance 2 links adsl com modens roteados

    olá amigos ainda estou na peleja fiz igual ao amigo Geeek posto vi como é entendi mais ou menos agora e o seguinte fiz os modens estão em bridge já configurei o mk como pppoe cliente sege o imagem abaixo de como esta agora o que vem depois para ser configura? fico grato se alguem puder me informar

    Clique na imagem para uma versão maior

Nome:	         screen.jpg
Visualizações:	78
Tamanho: 	62,4 KB
ID:      	13817

  16. #16

    Padrão Re: Laod balance 2 links adsl com modens roteados

    pelo que esta mostrando na imagem seu modem com link de 1Mb esta desconectado na RJ45, quando vc tirar outra Screen tire com os logs aparecendo.



  17. #17

    Padrão Re: Laod balance 2 links adsl com modens roteados

    como eu disse antes,seus links nao sao simétricos,entao a marcação de pesos esta errada.
    tem que ser 8 pro link de 8M e 1 pro link de 1M,daforma que esta acima esta mandando 1pro link 8M e 1 pro link de 1M, ocasionando o estouro de banda do link de 1M.

  18. #18

    Padrão Re: Laod balance 2 links adsl com modens roteados

    Citação Postado originalmente por sostenes Ver Post
    como eu disse antes,seus links nao sao simétricos,entao a marcação de pesos esta errada.
    tem que ser 8 pro link de 8M e 1 pro link de 1M,daforma que esta acima esta mandando 1pro link 8M e 1 pro link de 1M, ocasionando o estouro de banda do link de 1M.
    o sostenes tem razao quanto ao peso, mas a imagem dele fala tudo o link de 1 que entra na interface LINK 1MB nao esta conectado.
    Clique na imagem para uma versão maior

Nome:	         screen.jpg
Visualizações:	61
Tamanho: 	113,9 KB
ID:      	13818

    aos pesos vc deve por da seguinte forma:

    Código :
    add action=mark-connection chain=input comment="Load Balance////////////////////////////////////////////////////////////////////////////////////////////////\
        //////////////////////////////////////////////////////////////////////////////////////////////////////" connection-state=new disabled=no in-interface=\
        EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=EthLinkB new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment="Marcando Rotas" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    [COLOR="red"]#(Se baseando que a conn_ma0 é o link de 1Mb)[/COLOR]
    add action=mark-connection chain=prerouting comment=Balanceando disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 \
        passthrough=yes per-connection-classifier=both-addresses:8/0
    [COLOR="red"]#(E o link de 8Mb é a conn_mb1)[/COLOR]
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/2
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/3
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/4
    add action=mark-connection chain=prerouting comment="" dis8bled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/5
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/6
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/7
    add action=mark-routing chain=prerouting comment="Marca Rotas de Saida" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=\
        to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no

    é so fazer as alterações no script anterior ^^.



  19. #19

    Padrão Re: Laod balance 2 links adsl com modens roteados

    para se balancear corretamente soma-se os links 8M+1M=9M ai se divide pelo valor menor que é 1M=9 marcações de rota,

    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/1
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/2
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/3
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/4
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/5
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/6
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/7
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link2" disabled=no dst-address-type=!local in-interface= new-connection-mark=link2adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/8

  20. #20

    Padrão Re: Laod balance 2 links adsl com modens roteados

    eu sei que tua lógica esta certo mas fazendo assim, por experiência própria ele quase nao vai usar o link de 1 Mb a não ser q ele seja a rota de distancia 1