Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Partindo do Mk-Auth Apenas Instalado e Mikrotik zerado.

    Dessa forma é pra resolver o problema de IP mostrado no Mk-Auth e problemas com relatórios do squid.

    Umas das vantagens de ter IP Real no MK-Auth é que você pode ter um website e nele colocar um link para que o cliente de qualquer lugar que esteja possa acessar sua central do cliente e aconpanhar o que esta contecendo ou até mesmo imprimir seu boleto de mensalidade... Tipo no seu website colocaria um link tipo "Central do assinante" e nele o link...

    http://200.1.1.3/central/login.php

    Clique na imagem para uma versão maior

Nome:	         Esquema IP Real.png
Visualizações:	880
Tamanho: 	10,0 KB
ID:      	14411

    No MK-Auth:

    nano /etc/network/interfaces
    -----------------------------------------------------------------------------------------------------------------------------
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 200.1.1.3
    netmask 255.255.255.0
    network 200.1.1.0
    broadcast 200.1.1.255
    gateway 200.1.1.1
    dns-nameservers 8.8.8.8
    -----------------------------------------------------------------------------------------------------------------------------
    no rc.local fica as regras de firewall:
    -----------------------------------------------------------------------------------------------------------------------------
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    route add -net 10.10.10.0/24 gw 200.1.1.2

    ########################################################################

    No Mikrotik:
    -----------------------------------------------------------------------------------------------------------------------------
    Internet: 200.1.1.2
    RedeLocal: 10.10.10.0/24
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de IP's
    ip address add address=200.1.1.2/24 interface=Internet
    ip address add address=10.10.10.1/24 interface=RedeLocal
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de DNS
    # ip dns static add address=[gateway da sua rede] name=10.10.10.1
    ip dns static add address=10.10.10.1 name=10.10.10.1

    # Estou usando Mikrotik v4.11, para setar dns em versões antigas é diferente os comandos.
    # ip dns set allow-remote-requests=yes servers=[gateway da sua rede],8.8.8.8,8.8.4.4
    ip dns set allow-remote-requests=yes servers=10.10.10.1,8.8.8.8,8.8.4.4
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Gateway
    ip route add gateway=200.1.1.1
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Pool de Endereços
    ip pool add name=RedeLocal ranges=10.10.10.2-10.10.10.254
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Hotspot
    ip hotspot profile set default login-by=http-chap name=default nas-port-type=cable radius-accounting=yes radius-interim-update=3m radius-mac-format=XX:XX:XX:XX:XX:XX use-radius=yes

    ip hotspot user add name=admin password=123 profile=default

    add dns-name=10.10.10.1 hotspot-address=10.10.10.1 login-by=http-chap name=hsprof1 nas-port-type=cable radius-accounting=yes radius-interim-update=3m radius-mac-format=XX:XX:XX:XX:XX:XX use-radius=yes

    ip hotspot add idle-timeout=5m interface=Clientes name=hotspot1 profile=hsprof1

    ip hotspot user profile set default address-pool=RedeLocal idle-timeout=none keepalive-timeout=5m name=default shared-users=1 status-autorefresh=1m transparent-proxy=no
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Radius
    radius add address=200.1.1.3 service=hotspot secret=123456
    -----------------------------------------------------------------------------------------------------------------------------
    no mikrotik regras de nat:
    -----------------------------------------------------------------------------------------------------------------------------
    /ip firewall nat

    add action=dst-nat chain=dstnat comment="Redireciona a porta 80 para o proxy" disabled=no dst-address=!200.1.1.0/29 \
    dst-port=80 in-interface=Clientes protocol=tcp to-addresses=200.1.1.3
    add action=masquerade chain=srcnat comment="Faz Mascaramento de tudo que nao e porta 80" disabled=no dst-port=!80 \
    protocol=tcp
    add action=masquerade chain=srcnat comment="Faz Mascaramento de Ping" disabled=no protocol=icmp

    ########################################################################

    No Debian Proxy:

    nano /etc/network/interfaces
    -----------------------------------------------------------------------------------------------------------------------------
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 200.1.1.4
    netmask 255.255.255.0
    network 200.1.1.0
    broadcast 200.1.1.255
    gateway 200.1.1.1
    dns-nameservers 8.8.8.8
    -----------------------------------------------------------------------------------------------------------------------------
    no rc.local fica as regras de firewall:
    -----------------------------------------------------------------------------------------------------------------------------
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 3128

    route add -net 10.10.10.0/24 gw 200.1.1.2

    ########################################################################
    Última edição por wilkerpaz; 20-09-2010 às 23:59.

  2. wilkerpaz Muito bacana a forma que vc distribuiu seus servidores, mas poderia detalhar melhor cada configuração que vc fez, ajudaria muito nos leigos rss, desde já obrigado.



  3. Olha eu detalhei o maximo todo o procedimento, o que pra vc esta faltando???

  4. qto vc cobra para montar um sistema desse?



  5. Me manda seu msn...
    Última edição por wilkerpaz; 22-09-2010 às 12:20.






Tópicos Similares

  1. Fazendo maquina sair com ip real
    Por LeoJfa no fórum Redes
    Respostas: 0
    Último Post: 11-03-2010, 10:12
  2. Problemas com ip Real!! muito sério!
    Por DirectNet no fórum Redes
    Respostas: 6
    Último Post: 21-11-2008, 20:13
  3. Respostas: 3
    Último Post: 17-03-2008, 08:36
  4. Myauth com ip real pro cliente sem mexer no roteador
    Por pinkfloydlsd no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-07-2007, 13:16
  5. Link E1 com IP real
    Por Dom751 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-07-2005, 10:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L