+ Responder ao Tópico



  1. #1

    Padrão WEB-PROXY MIKROTIK V. 4.10

    Salve Salve pessoal !!!

    Estou passando por uma dificuldade, com o web-proxy do mk versão 4.10,
    Configurei tudo, redirecionei.

    E quando ativo ele funciona perfeitamente, fazendo o cache full, mas passa uns 10 a 15 min o mk para de comunicar com a internet. Tento fazer um ping externo nao pinga.

    Ai reinicio o mesmo, e tudo volta funcionar perfeitamente por mais 15 min. rsrsrs

    Se desativo o WP tudo funciona normal.

    Trabalho com Pppoe, autenticação via Radius com 60 clientes cadastrados, pico de 50 online. Maquina core duo com 2 gigas de ram e 200 e poucos de hd.

    Será que alguem pode me dar a solução?

    Estou pensando em trocar as placa de rede por 3com 100/1000 pois as que uso são realtek 10/100, mas acredito que não seja pois os trafego com WP ativado nao passa de 5 megas.

    Abraços a todos e espero uma Luz...

  2. #2

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    Primeiro atualize seu mk para 4.11 depois observe o uso de processador e mensagens de log quando você fica sem acesso ao link.



  3. #3

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    É muito importante você acompanhar o log, cpu e memória e postar aqui, tente acompanhar as conexões no porta 80, filtre a porta 3128.

  4. #4

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    Cara, desinstale qualquer pacote do mikrotik que vc nao esteja usando, tipo se vc nao usa PPPoE, desinstale o pacote PPP. Faça isso, verifique os logs no momento que tudo para, tente pinga de dentro do mikrotik para fora, usando o NEW TERMINAL.

    Se nada funcionar, pode ser problema físico, principalmente o HD, pois ele começa a trava na hora da escritura de dados.

    um abraço



  5. #5

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    vc bloqueou as requisiçoes que vem da internet na porta do seu proxy?

  6. #6

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    eu ja atualizei a versão do mk para 4.11
    e o uso do cpu está no maximo 6% com o w-proxy ativado.

    e continua travando a navegação, o mk nao pinga pra fora.
    descarto a hipotese de ser hd pois os clientes continuam conectados, pois acho que se fosse ele, iria travar o software.

    e nos logs nao esta mostrando nada na hora que a o link cai com o mk.

    bom, estou no aguardo, se alguem ja passou por algum problema desses, me ajude por favor.

    abraços



  7. #7

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    bloquiei o acesso externo sim.

  8. #8

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    Passa suas regras de web-proxy e firewall filter, pra agente dar uma analizada =)



  9. #9

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    ip proxy print
    enabled: no
    src-address: 0.0.0.0
    port: 5128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 1000
    max-server-connections: 1000
    max-fresh-time: 3d
    serialize-connections: yes
    always-from-cache: no
    cache-hit-dscp: 10


    ip firewall filter print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; aceitando 50 pings a cada 5 segundos
    chain=input action=accept protocol=icmp limit=50,5

    1 ;;; bloqueando o excesso
    chain=input action=drop protocol=icmp

    2 ;;; bloqueio de VIRUS conhecidos
    chain=virus action=drop protocol=tcp dst-port=445

    3 chain=virus action=drop protocol=udp dst-port=445

    4 chain=virus action=drop protocol=tcp dst-port=593

    5 chain=virus action=drop protocol=tcp dst-port=1080

    6 chain=virus action=drop protocol=tcp dst-port=1363

    7 chain=virus action=drop protocol=tcp dst-port=1364

    8 chain=virus action=drop protocol=tcp dst-port=1373



    ip firewall nat print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Mascaramento dos clientes
    chain=srcnat action=masquerade src-address=10.1.1.0/24

    1 X ;;; Redirecionamento do Proxy
    chain=dstnat action=redirect to-ports=5128 protocol=tcp
    src-address=10.1.1.0/24 dst-port=80


    ip firewall nat print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Mascaramento dos clientes
    chain=srcnat action=masquerade src-address=10.1.1.0/24

    0 ;;; MARCA O P2P
    chain=prerouting action=mark-connection new-connection-mark=p2p_conn
    passthrough=yes p2p=all-p2p

    1 chain=prerouting action=mark-packet new-packet-mark=p2p passthrough=yes
    connection-mark=p2p_conn

    2 X ;;; Web Proxy
    chain=output action=mark-packet new-packet-mark=proxy-hit
    passthrough=no dscp=10
    Última edição por suportemikrotik; 30-09-2010 às 18:18.

  10. #10

    Padrão Re: WEB-PROXY MIKROTIK V. 4.10

    vamos por partes, hehe
    qual o tamanho do seu hd? e quando você quer liberar par o cache?
    veja como está funcionando o meu.. essa sua mesma versão

    enabled: yes
    src-address: 0.0.0.0
    port: 5128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "webmaster"
    max-cache-size: 15000000KiB (ajuste para o tamanho do seu hd)
    cache-on-disk: yes
    max-client-connections: 5000 (dependendo de quantos clientes você tenha ajuste à sua necessidade, aqui tenho 90 com media de 40 simultâneo)
    max-server-connections: 5000
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4 (ajuste para cache full)
    cache-drive: primary-master

    faça o bloqueio externo do proxy e pra complementar adiciona essas regras..

    /ip proxy access
    add action=allow comment="" disabled=no src-address=192.169.0.0/16 (Rede geral de clientes)
    add action=deny comment="" disabled=no src-address=0.0.0.0/0
    /ip proxy cache
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\\\?"
    add action=deny comment="" disabled=no dst-host=caixa.gov.br
    add action=deny comment="" disabled=no dst-host=bb.gov.br
    add action=deny comment="" disabled=no dst-host=https://
    add action=deny comment="" disabled=no dst-host=globo.com

    pelo que eu vi com tão poucas conexões liberadas, usando todo o disco e ainda com cache full pode ser o motivo do travamento. Testa e posta pra ver se deu certo