Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Red face ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Pessoal, muita gente estava procurando testar o ThunderCache 5 então compilei uma distro para testar antes mesmo de instalar, se trata de um sistema LiveCD baseado em Ubuntu Linux e que possui a capacidade de relatório e gráficos de performance, além de recentemente ter recebido suporte a RAID0, agora você pode ter mais desempenho utilizando vários HDs em RAID.

    Atende redes com ate 30 pc's

    Processador 1.2Ghz
    512 MB RAM
    1 HD 80GB

    Atende redes com até 100 pc's

    Processador 1.8Ghz ou superior
    2 GB RAM
    1 HD 500GB ou maior

    Atende redes com até 400 pc's

    Processador Quad Core 2.8Ghz ou superior
    8 GB RAM
    4 HDs 500GB

    Tela de boot:
    http://img409.imageshack.us/img409/3...0913213540.png

    Instruções:

    1 - Dê boot no PC pelo cdrom
    Digite no console 'sudo su'
    Digite 'menu'
    Selecione a opção 'f' para formatar o disco onde será gravado o cache
    Responda 's' para as perguntas confirmando a formatação

    Siga este video mostrando o que precisa ser feito



    Relatório rodando do ConLiNUXCD
    http://img508.imageshack.us/img508/4...helanhouse.jpg

    Recursos da Versão 1.95

    Menu de configuração em modo texto facilitado


    Configura thunder.conf pelo menu

    Retém as configuração do ThunderCache

    Configura rede pelo menu

    Retém as configurações de rede

    Salva Gráficos de ganho e monitoramento

    Monitora Tempo de retorno (ping)
    Monitora Trheads e Processos
    Monitora Requisições MISS/HIT
    Monitora Tráfego MISS/HIT
    Monitora Consumo de CPU
    Monitora Interface LAN

    Aceleracao e cache DNS

    TTL minimo setado para 1 hora (maior desempenho)

    Suporte a RAID0

    Testado e aprovado de 2 a 12 HDs SATA
    Perfeito para quem quer máximo desempenho

    Suporte a TPROXY

    Com atualização via menu

    Script de inicialização

    Configure o que mais quiser e o sistema inicia automático

    Arquivo ISO versão 1.95 em 2 partes compactado com WinRAR


    Atualizado com novo tutorial e versão 1.97

    Agradeço ao amigo que ajudou no upload dos arquivos.


    Após o download descompacte e grave o CD, envie por e-mail para
    [email protected] e receberá sua licença demonstração que irá permitir rodar o sistema apartir do CD com threads suficientes.

    FORMULÁRIO DE LICENÇA DEMONSTRAÇÃO PARA THUNDERCACHE PRO 5 LIVECD E ADS:
    Razão Social:
    CNPJ:
    Nome Fantasia:
    ---------------------------ACIMA PARA PESSOA JURIDICA-----------------------
    Responsável Legal:
    CPF:
    E-mail de contato:
    Cargo na empresa:
    Endereço:
    Cidade:
    Bairro:
    Estado:
    CEP:
    Telefone:
    Celular:
    Número total de usuários/clientes na rede:
    Processador:
    Memoria:
    HD:

    Cadastro incompleto ou com dados incorretos serão ignorados, tenha certeza que os dados enviados sejam os seus.


    Para acessar a o painel de configuração do ThunderCache, digite em seu navegador:
    http://www.bmsoftware.org/new/index.php?pg=suporte

    As configurações estão todas no painel que conta com icones "?" de ajuda para cada item onde as principais configurações estão em:

    CONFIG. THUNDER

    Thunder

    TAM. MÍNIMO DE ARQ. EM CACHE: 4096
    THREADS INICIAIS: 200
    MARCAÇÃO TOS (DECIMAL) DE HIT: 4

    Extensões:

    IPSW TORRENT IPA DMG NPK LZH CAB ARJ ACE 7ZIP
    7Z DEB RPM GZ2 GZ TBZ TGZ TAR BIN MKV NRG ISO
    PPTX PPT DOCX DOC PPSX PPS DIVX MOV MPEG MPG
    AVI RMVB WMA WMV PNG GIF PDF MSP MSI BZ2 BZ
    MP3 MP4 JPEG JPGE JPG EXE RAR ZIP SWF FLV
    Blacklist:
    HOLTS.COM
    VAPORNINE.COM
    EMERSONSCIGARS.COM
    LAMGMT.BEAUTYCHOICE.COM
    GOOGLE-ANALYTICS.COM
    CHUDETSTVO.RU
    Sem Tproxy:
    172.16.
    192.168.
    10.
    Conf. Disco:
    /conlinux/thunder/cache
    Plugins:
    ativar todos

    Abaixo as regras para redirecionar o trafego do MikroTik para o Thunder em paralelo utilizando 1 placa de rede apenas como o CD foi concebido para ser utilizado:
    (para utilização com TPROXY e IPs públicos nos clientes se faz necessária atualização e configuração da bridge pelo rc.fw)

    IPs utilizados como exemplo para configuração padrão:
    Range dos Clientes: 10.0.0.0/24

    Mikrotik Interface Cache: 192.168.10.253

    ThunderCache eth0: 192.168.10.250
    Netmask: 255.255.255.0
    Network: 192.168.10.0
    Broadcast: 192.168.10.255
    Gateway: 192.168.10.253
    DNS: 127.0.0.1

    Crie o mascaramento no MikroTik para range de ips que será utilizada pelo servidor de cache:

    /ip firewall nat
    add action=masquerade chain=srcnat comment="PC.MASCARAMENTO" disabled=no src-address=RANGE.DO.SERVER.THUNDE R

    Onde RANGE.DO.SERVER.THUNDER=192.16 8.10.0/24, isso mascara todos os ips da rede 192.168.10.XXX

    Desvio de trafego do MikroTik para o servidor ThunderCache e porta configurada no painel de suporte:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="PC.PPPOE" content=!https disabled=no dst-address-list=!sem_cache_dst dst-port=80 protocol=tcp src-address=RANGE.DOS.CLIENTES/MSK src-address-list=!sem_cache_src to-addresses=IP.DO.SERVER.THUNDER to-ports=PORTA.DO.SERVER.THUNDER

    Acima para uso com redirecionamento de clientes estáticos via IP/MAC/QUEUE ou PPPOE

    /ip firewall nat
    add action=dst-nat chain=pre-hotspot comment="PC.HOTSPOT" content=!https disabled=no dst-address-list=!sem_cache_dst dst-port=80 hotspot=auth protocol=tcp src-address=RANGE.DOS.CLIENTES/MSK to-addresses=IP.DO.THUNDER to-ports=PORTA.DO.SERVER.THUNDER

    Acima para uso com redirecionamento de clientes do HOTSPOT

    O suporte é feito aqui mesmo pelo fórum.

    Número de clientes e threads:
    THREADS: São instâncias simultâneas paralelas de processos do thunder. Quando não houver threads suficientes para atender a carga, demais requisições ficam em espera até a liberação dos children. No modo gratuito são liberadas 500 threads.

    Quantos clientes consigo atender com no plano gratuito ?

    - A resposta é simples, tantos quanto as requisições aguentarem, podem ser 10, 100 ou 10000 vai depender do que estiverem fazendo na web, nos testes que fizemos 500 threads atendem aproximamente 100 clientes simultâneos.

    A única coisa que vou pedir é que se gostarem deste post, clique na estrelinha ao final, agradecer não custa dinheiro e mostra que foram capazes de implantar seus próprios sistemas de cache de forma EFICIENTE/GRATUITA com a AJUDA deste fórum que é a proposta deste post.

    DICA FINAL:
    Antes de perguntar no fórum, faça uma busca, comece pela pesquisa pois sua dúvida já pode ter sido respondida várias vezes, isso reduz o tempo de espera por uma resposta e mantém o fórum organizado.


    Agradecimento especial ao portal underlinux e seus usuários.

    Abraço a todos
    Última edição por m4d3; 30-12-2010 às 14:23. Razão: link que não funciona

  2. #2

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Grande Mestre Luciano, parabéns!



  3. #3

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Para esta versão sera necessario IP público também?

  4. #4

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    arauadbr,

    Funciona em ambos os modos.



  5. #5

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Tutorial atualizado...

  6. #6

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Amigo, boa noite
    Segui o tutorial exatamento como dito assima, mas quando direciono a porta 80 para a porta do thunder, as paginas solicitadas nao abrem aparecem a seguinte mensagem de erro:

    Url:
    Erro: ERROR REQUEST: Invalid request



  7. #7

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por evecimar Ver Post
    Amigo, boa noite
    Segui o tutorial exatamento como dito assima, mas quando direciono a porta 80 para a porta do thunder, as paginas solicitadas nao abrem aparecem a seguinte mensagem de erro:

    Url:
    Erro: ERROR REQUEST: Invalid request
    Forneça maiores informações sobre a configuração ex:
    O sistema rodando do cd consegue pingar pra internet ?
    Esta resolvendo nomes ?
    Quais ips utilizou na configuração ?
    Seu servidor esta em paralelo com o mikrotik utilizando uma placa de rede apenas ?
    Quais ips seus clientes utilizam ?
    Cole aqui a sua regra de redirecionamento:

  8. #8

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por m4d3 Ver Post
    Tutorial atualizado...
    Luciano..
    Não abusando da sua boa vontade..
    Mais é possível ao invés de rodar em Live-CD , ter alguma opção para que possamos instalar o mesmo no disco.?



  9. #9

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    doublenet,

    Não tenho nem previsão, tendo em vista que pelo tamanho reduzido eu teria de fazer um instalador na unha e não estou tendo o tempo necessário, mas se alguém se habilitar quem sabe na próxima release.

  10. #10

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por m4d3 Ver Post
    Forneça maiores informações sobre a configuração ex:
    O sistema rodando do cd consegue pingar pra internet ?
    Esta resolvendo nomes ?
    Quais ips utilizou na configuração ?
    Seu servidor esta em paralelo com o mikrotik utilizando uma placa de rede apenas ?
    Quais ips seus clientes utilizam ?
    Cole aqui a sua regra de redirecionamento:
    Amigo, segue abaixo mais dados

    a topologia de minha rede e a seguinte:

    Utilizo o sistema em paralelo com o MK, onde meu MK possui 3 placas de redes, 1 ligada internet, 1 ligada ao thunder e 1 ligada aos clientes.

    O Mk esta pingando e resolvendo momes sem problemas.

    Configuracões de IP
    MK= 3 Interfaces
    MK wan 200.xx.xx.xx/27
    MK Thunder 172.31.255.1/30
    Mk Clientes 169.254.3.1/24

    Thunder = 1 Interface
    Thunder Eth0 = 172.31.255.2/30 Gw 172.31.255.1/30

    Clientes Ip Faixa 169.254.3.0/24

    Direcionamento Nat

    add action=dst-nat chain=dstnat comment=PC.PPPOE content=!https disabled=no \
    dst-address-list=!sem_cache_dst dst-port=80 protocol=tcp src-address=\
    169.254.3.48 src-address-list=!sem_cache_src to-addresses=172.31.255.2 \
    to-ports=8081

    Obs.1: Ip 169.254.3.48 e um maquina de teste e porta 8081 e a porta que configurei o thunder, ja tentei na 8080 e da o mesmo erro.

    Obs.2: quando desativo o direcionamento Nat e ativo as configuracoes do proxy manualmente no firefox (Feramentas, Opcoes, Avancado, rede) Funciona normalmente.

    MAis algumas perguntas:

    Qual seria a topologia mais indicada para instalacao deste thunder



  11. #11

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Mude a configuração do thunder para transparent true no painel de suporte e/ou no arquivo de configuração e tente novamente, ao fazer isso não vai mais navegar setando pelo seu navegador e vai passar a funcionar pelo redirecionamento, me parece que o restante esta OK, a topologia é a que esta usando mesmo em paralelo.

  12. #12

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Amigo, Ficou perfeito, auterei toda a configuracao na parte CONFIGURAÇÕES DE MODO DE EXECUÇÃO no painel da BMsoftware para sim, agora ficou perfeito.

    Modo transparente = sim
    PROXY 100% TRANSPARENTE (TPROXY)= sim
    REPASSAR IP POR HEADER= sim
    REPASSAR IP POR HEADER(TPROXY)= sim

    Valew Galera, estarei criando um post colocando como resolver este problema para os proximos que os tiverem



  13. #13

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por evecimar Ver Post
    Amigo, Ficou perfeito, auterei toda a configuracao na parte CONFIGURAÇÕES DE MODO DE EXECUÇÃO no painel da BMsoftware para sim, agora ficou perfeito.

    Modo transparente = sim
    PROXY 100% TRANSPARENTE (TPROXY)= sim
    REPASSAR IP POR HEADER= sim
    REPASSAR IP POR HEADER(TPROXY)= sim

    Valew Galera, estarei criando um post colocando como resolver este problema para os proximos que os tiverem
    Conto com isso pra identificar as dificuldades dos usuários, com certeza com base no que você escrever teremos adendos ao tutorial. Obrigado por descrever o seu retorno.

  14. #14

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Versao atualizada
    Corrigido bug na configuracao do ip estatico.



  15. #15

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Tenho uma duvida thunder no cd ja vem com ip configurado ou tem que configurar manualmente?se tiver de configurar como? uso modem em brigde mk/pc que autentica, o thunder esta em paralelo com o mk.

  16. #16

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    juliocf

    O LiveCD vem como dhcp client e permite a configuração de ip estatico, no video tem a demonstração de como configurar o ip.

    Abraço



  17. #17

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por m4d3 Ver Post
    juliocf

    O LiveCD vem como dhcp client e permite a configuração de ip estatico, no video tem a demonstração de como configurar o ip.

    Abraço
    Ola Luciano

    É possivel usar 2 placas de rede, exemplo - links - tc5 - clientes

  18. #18

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Ola Luciano!!!

    Abusando uma vez mais do seu tempo.. minha pegunta e...

    is possivel para fazer un reinicio do thunder (liveCD) fazerlo pelo putty?, o sempre eu tenho que acudir a meu PC-TC5liveCD, pra mediante o menu fazer o restart?, devido a que eu fiz cambios no panel do BMsoftware.

    Obrigado pela sua Ajuda!!



  19. #19

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por sidneiadriano Ver Post
    Ola Luciano

    É possivel usar 2 placas de rede, exemplo - links - tc5 - clientes
    Entao amigao, so com 1 placa de rede ok, vou tentar postar uma imagem com a indicacao de como fazer as ligacoes.

  20. #20

    Padrão Re: ConLiNUXCD by M4D3 - ThunderCache 5 +RAID0 +TPROXY +DNS Cache em LiveCD

    Citação Postado originalmente por yohanvil Ver Post
    Ola Luciano!!!

    Abusando uma vez mais do seu tempo.. minha pegunta e...

    is possivel para fazer un reinicio do thunder (liveCD) fazerlo pelo putty?, o sempre eu tenho que acudir a meu PC-TC5liveCD, pra mediante o menu fazer o restart?, devido a que eu fiz cambios no panel do BMsoftware.

    Obrigado pela sua Ajuda!!
    Olha so, por rodar no LiveCD nao tem nenhuma senha definida (nao permitindo o login remoto), voce deve portanto definir uma senha no console para o usuario padrao, fazer o acesso remoto por telnet, tornar-se root com o sudo e depois pode fazer o restart do thunder via menu ou executar os comandos que desejar.