+ Responder ao Tópico



  1. #1

    Lightbulb Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Ola pessoal do Uder-Linux..
    A questão é a seguinte, a algum tempo instalei o Mk 3.30 com intuíto de fazer um web proxy+Cache Full para usar aqui na minha Lan House.
    Só que eu ja procurei aqui no forum mas não achei nenhum passo a passao de como fazer web proxy nessas versões.
    Então se tiver algum especialista no assunto que possa ajudar com um passo a passo e nao com script ficarei muito grato.
    Atualmente o link internet entra na placa de rede e os clientes se conectão via wireless tudo funcionando perfeitamente menos o web proxy.
    Qualquer ajuda é bem vinda.

  2. #2

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Mikrotik - Under-Linux.Org Wiki
    Passo-a-passo bem explicadinho. Mamão-com-açucar



  3. #3

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Amigo obrigado pela boa intensão de querer ajudar as pessoas, só que esse passo a passo eu ja fiz, só que não deu em nada, deve ser porque esse tutorial e a da versao 2.9.27 e a que eu estou usando é 3.30 acho que muda alguma coisas nas regras.
    Alguem ai ja fez web proxy para me passar um passo a passo. scrips não servem.

  4. #4

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Ninguem????



  5. #5

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Consegui fazer com que paginas e download fiquem armazenadas no cache, só que na hora de entregar o conteudo apenas os download são baixados na velocidade full que eu determinei as paginas não, o que pode esta errado?

  6. #6

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Só pra adiantar ai vão as regras.

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=50M name=CACHE-FULL-Download packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=50M name=CACHE-FULL-Upload packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default
    /ip firewall filter
    add action=accept chain=input comment="CHACHE FULL - ACEITAR CONEXOES PROXY" \
    disabled=no dst-port=3128 in-interface=Entrada protocol=tcp
    /ip firewall mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up passthrough=\
    yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="CACHE FULL" connection-mark=\
    conn_squid-up disabled=no new-packet-mark=pacotes_squid-up passthrough=\
    yes
    add action=mark-connection chain=prerouting comment="CACHE FULL" disabled=no \
    dst-port=3128 new-connection-mark=conn_squid-down passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="CACHE FULL" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    Entrada src-address=192.168.10.0/24
    add action=redirect chain=dstnat comment=\
    "MPSnet WEB PROXY redirecionamento porta 80 para webproxy 3128" disabled=\
    no dst-port=80 protocol=tcp src-address=192.168.10.0/24 to-ports=3128
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=10 \
    cache-on-disk=yes enabled=yes max-cache-size=5342651KiB \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment=\
    "MPSnet WEB PROXY block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25
    add action=allow comment="MPSnet WEB PROXY " disabled=no src-address=\
    192.168.10.0/24
    add action=deny comment="MPSnet WEB PROXY " disabled=no



  7. #7

    Padrão Re: Ajuda Sobre Web Proxy+ Cache Full MK 3.2x a 3.30.

    Acompanhando. Aqui uso o MK 3.30 e também não funciona.