+ Responder ao Tópico



  1. #1

    Padrão Tutorial cache full no MikroTik 3.30

    Salve meus queridos eu penei, procurei muito até que consegui fazer funcionar perfeitamente o cache no MikroTik versão 3.30, existem vários tutoriais porém a maioria ou quase todos para a versão 2.x, como vi que existem varias pessoas com essa mesma dificuldade segue abaixo um tutorial passo-a-passo de como fazer, se você já tentou de varias formas e jeitos peço que você delete as regras criadas no Firewall, na Queue,etc delete todas as regras criadas por você na tentativa de criar o cache... delete tudo, no caso de você ter feito muita bagunça, recomendo reinstalar o MikroTik do zero, para que o mesmo fique 100%, segue o tutorial:

    Acesse seu Mikrotik 3.30 pelo Winbox, clique em "New Terminal" copie o seguinte código e cole na janela do "New Terminal",
    Observações importantes antes de copiar e colar:

    1-) A substitua a parte 192.168.1.0/24 pela sua máscara de rede

    2-) Na parte "in-interface=public" substitua public pelo nome da sua interface wan (interface onde entra a internet no MikroTik)

    3-) A parte onde consta "max-limit=4M" esse 4M é o valor que o MikroTik vai entregar os objetos que estão em cache, você pode alterar conforme a necessidade da sua rede, para redes com muito tráfego recomendo colocar 2M para não saturar a rede

    4-) Na parte "max-cache-size=10485760KiB" esses 10485760 são equivalentes a 10GB de cache (1024x1024=1048576 isso seria 1GB, 1048576x10=10485760 equivalente a 10GB) , que na minha opinião está ótimo esse tamanho, varias pessoas usam mais do que esse valor, eu recomendo esses 10GB para não causar lentidão nas conexões, simplificando: com um cache muito grande o tempo de busca no HD para encontrar determinado objeto pode demorar muito, e causar uma lentidão, o mikrotik sabe que tem aquele objeto no cache e ele vai busca-lo porem demora muito com um cache muito grande, creio que esses 10GB vão atender muito bem, caso seu Hardware seja fraco recomendo usar um valor menor, depois dessas observações copie e cole todo o código abaixo na Janela do "New Terminal"

    /ip firewall nat
    add action=redirect chain=dstnat comment="redirect port 80 to 8080" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.1.0/24 \
    to-ports=8080
    /ip firewall mangle
    add action=mark-connection chain=output comment=\
    "mark connection *conn_squid-up*" content="X-Cache: HIT" disabled=\
    no new-connection-mark=conn_squid-up passthrough=yes protocol=tcp \
    src-port=8080
    add action=mark-packet chain=output comment=\
    "mark packet *pacotes_squid-up*" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment=\
    "mark connection *conn_squid-down*" disabled=no dst-port=8080 \
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment=\
    "mark packet *pacotes_squid-down*" connection-mark=conn_squid-down \
    disabled=no new-packet-mark=pacotes_squid-down passthrough=yes
    /ip firewall filter
    add action=drop chain=input comment="Bloqueio de Proxy Externo" disabled=no \
    dst-port=8080 in-interface=public protocol=tcp
    add action=accept chain=input comment="Aceita Conexao Proxy" \
    disabled=no dst-port=8080 protocol=tcp
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=4M name=downstream packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=\
    0 max-limit=4M name=upstream packet-mark=pacotes_squid-up parent=\
    global-out priority=1 queue=default
    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=10485760KiB \
    max-client-connections=600 max-fresh-time=3d \
    max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 \
    port=8080 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=\
    no dst-port=23-25



    * Quero deixar bem claro que meu conhecimento em MikroTik é bem pequeno, e minha intenção foi 100% em ajudar aqueles que como eu enfrentarão grande dificuldade em criar o tão famoso "CACHE" no MikroTik, um forte abraço a todos e que DEUS nos abençoe Grandemente *
    Última edição por wanderley85; 12-11-2010 às 02:31.

  2. #2

    Padrão Re: Tutorial Cache Full no MikroTik 3.30

    Printa suas telas funcionando ai.



  3. #3

    Padrão Re: Tutorial Cache Full no MikroTik 3.30

    eu ja vi essas regras em algum lugar mais nao testei

  4. #4

    Padrão Re: Tutorial Cache Full no MikroTik 3.30

    Se funcionar mesmo te dou uma *.



  5. #5

    Padrão Re: Tutorial cache full no MikroTik 3.30

    Citação Postado originalmente por sombra Ver Post
    ip firewall filter
    add action=drop chain=input comment="Bloqueio de Proxy Externo" disabled=no \
    dst-port=8080 in-interface=public protocol=tcp
    add action=accept chain=input comment="Aceita Conexao Proxy" \
    disabled=no dst-port=8080 protocol=tcp
    Esqueceu de falar tb que tem que mudar o nome da interface.

  6. #6

    Padrão Re: Tutorial cache full no MikroTik 3.30

    aqui no meu cache, os arquivos que estao em cache ele vai na velocidade certa puxando do MK, mas tem site ex. videos do uol, ele puxa direto do link e nao passar pelo quees, ta passando direto



  7. #7

    Padrão Re: Tutorial cache full no MikroTik 3.30

    Para quem está com dificuldades em configurar o cache-full nas versões acima de 3.X, segue os scripts:
    Obs: porta do webproxy: 3128 e colocar o ip da rede. No meu caso 192.168.0.0/24

    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirecionamento do Proxy" disabled=\
    no dst-port=80 protocol=tcp src-address=ip_da_rede to-ports=3128

    /ip firewall filter
    add chain=input action=accept dst-port=3128 protocol=tcp comment="ACEITAR \
    CONEXOES PROXY" disabled=no

    ip firewall mangle
    add action=mark-connection chain=output comment="2-PROXY FULL" disabled=no \
    dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=\
    3128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull \
    disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=5M \
    max-limit=5M name="2 - CACHE-FULL" packet-mark=proxyfull parent=\
    global-out priority=1 queue=default

    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=no \
    src-address=0.0.0.0

    Acessa o site abaixo para ter acesso ao script todo, mas as regras acima funciona...
    Abraços
    Agradecimentos ao Gerônimo.
    Fonte: VIDEO COMPLETO PARA CONFIGURAÇÃO DO CACHE FULL E REGRAS PRONTAS

  8. #8

    Padrão Re: Tutorial cache full no MikroTik 3.30

    Olá sou novo no forun tanto e q não tive tempo ainda pra colocar meu avatar.
    Olha essa regrinha deu certo, apesar de não saber quase nada de linux eu coloquei e o cache funcionou mais ele sempre desabilita o controlde de banda dos clientes ou seja os clientes navegam e full.
    faço controle de banda pelo hotspot, estou com muita dor de cabeça por isso, por favor dar uma frcinha ai galera ficarei muito grato!



  9. #9

    Padrão Re: Tutorial cache full no MikroTik 3.30

    Geralmente acontece isso na versao 3.30 pq o full esta ativado no Queue Tree.
    Desative o full e faça o teste.