+ Responder ao Tópico



  1. Boa tarde a todos...
    é o seguinte minha rede está crescendo e com isso muitos virus e tudo mais.. pesquisando na net achei varios script para ap em modo brigde.. gostaria da opnião de vcs sobre esse script se ele vai ser funcional ou não no bloqueio de virus e spams e worms..

    Código :
    /ip firewall filter 
    add chain=forward connection-state=established comment="allow established connections" 
    add chain=forward connection-state=related comment="allow related connections" 
    add chain=forward connection-state=invalid action=drop comment="drop invalid connections" 
    add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm" 
    add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=tcp dst-port=593 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom" 
    add chain=virus protocol=tcp dst-port=1214 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester" 
    add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server" 
    add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast" 
    add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx" 
    add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid" 
    add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm" 
    add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus" 
    add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y" 
    add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle" 
    add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K" 
    add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom" 
    add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro" 
    add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm" 
    add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm" 
    add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser" 
    add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B" 
    add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B" 
    add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y" 
    add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B" 
    add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus" 
    add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2" 
    add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven" 
    add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot" 
    add chain=input protocol=tcp psd=21,3s,3,1 action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="Port scanners to list " disabled=no 
    add chain=input protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="NMAP FIN Stealth scan" 
    add chain=input protocol=tcp tcp-flags=fin,syn action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="SYN/FIN scan" 
    add chain=input protocol=tcp tcp-flags=syn,rst action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="SYN/RST scan" 
    add chain=input protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="FIN/PSH/URG scan" 
    add chain=input protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="ALL/ALL scan" 
    add chain=input protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="NMAP NULL scan"

    quem manja bem em MK dá uma luz ai para min para ver se esta certo isso..

    desde já agradeço a atenção de todos..

  2. Citação Postado originalmente por danillona Ver Post
    Boa tarde a todos...
    é o seguinte minha rede está crescendo e com isso muitos virus e tudo mais.. pesquisando na net achei varios script para ap em modo brigde.. gostaria da opnião de vcs sobre esse script se ele vai ser funcional ou não no bloqueio de virus e spams e worms..

    Código :
    /ip firewall filter 
    add chain=forward connection-state=established comment="allow established connections" 
    add chain=forward connection-state=related comment="allow related connections" 
    add chain=forward connection-state=invalid action=drop comment="drop invalid connections" 
    add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm" 
    add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm" 
    add chain=virus protocol=tcp dst-port=593 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom" 
    add chain=virus protocol=tcp dst-port=1214 action=drop comment="________" 
    add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester" 
    add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server" 
    add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast" 
    add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx" 
    add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid" 
    add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm" 
    add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus" 
    add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y" 
    add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle" 
    add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K" 
    add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom" 
    add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro" 
    add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm" 
    add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm" 
    add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser" 
    add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B" 
    add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B" 
    add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y" 
    add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B" 
    add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus" 
    add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2" 
    add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven" 
    add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot" 
    add chain=input protocol=tcp psd=21,3s,3,1 action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="Port scanners to list " disabled=no 
    add chain=input protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="NMAP FIN Stealth scan" 
    add chain=input protocol=tcp tcp-flags=fin,syn action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="SYN/FIN scan" 
    add chain=input protocol=tcp tcp-flags=syn,rst action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="SYN/RST scan" 
    add chain=input protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="FIN/PSH/URG scan" 
    add chain=input protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="ALL/ALL scan" 
    add chain=input protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w comment="NMAP NULL scan"

    quem manja bem em MK dá uma luz ai para min para ver se esta certo isso..

    desde já agradeço a atenção de todos..
    Amigo sugiro você entender o que cada coisa faz, pois esse negócio de copiar regras e colar não fica bom não, cada caso é um caso, procure tutoriais mikrotik ou faça um curso.



  3. Citação Postado originalmente por Geeek Ver Post
    Amigo sugiro você entender o que cada coisa faz, pois esse negócio de copiar regras e colar não fica bom não, cada caso é um caso, procure tutoriais mikrotik ou faça um curso.
    Geek voce tem total razão.
    Mas ao procurar tutoriais, normalmente estes são muito suscintos, sem muitos comentários sobre os motivos da regra ou as possíveis repercussões em outras. Sobre quem deve vir primeiro, etc etc.
    Alguma coisa se pega nos posts dos companheiros.
    Isto foi uma coisa que eu faz tempo comentei com o Catv. Não sei se no livro que ele está lançando haverá um conteúdo mais aprofundado do que um simples tutorial. Estes tutoriais é que na verdade estimulam a copiar e colar.
    Precisamos ir mais a fundo nos conceitos que cada regra imprime ao sistema como um todo.

    Por ex, na citação do danillona, as 3 primeiras regras, eu tenho aqui, por sugestão de outro companheiro, mas não sei exatamente o real beneficio do uso delas, apesar de ter um ideia do que elas representam. Pois depois que as adicionei, não notei diferença de desempenho.

    Outra coisa: ao adicionar as regras anti virus, poderá ocorrer do mikrotik ficar mais lento em vista de tantas regras de controle, apesar de mais seguro?

  4. Tem coisa errada nestas regras, se simplesmente colocar a rodar assim não vão funcionar.
    O canal VIRUS precisa de um jump:
    add action=jump chain=forward comment=";;; jump para o canal virus" disabled=no jump-target=virus
    coloque este jump logo abaixo desta regra que esta no seu script:
    add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot"

    Outra coisa, se você colocar a funcionar este script em uma AP com bridge, também não ira funcionar:
    Habilite isso:
    interface bridge settings set use-ip-firewall=yes

    E lembrando, cada situação requer regras adequadas para a situação.






Tópicos Similares

  1. Respostas: 22
    Último Post: 20-08-2017, 17:19
  2. Respostas: 3
    Último Post: 01-08-2017, 21:08
  3. Script para desativar regra do thunder em caso de down !
    Por lednet no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-11-2016, 11:37
  4. Respostas: 12
    Último Post: 16-09-2012, 19:39
  5. Respostas: 0
    Último Post: 21-07-2010, 10:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L