+ Responder ao Tópico



  1. Pessoal,

    tenho 2 sambas com centos 5.4 integrados ao AD de um servidor de dominio windows 2003.Esse servidor windows também é servidor de arquivos então depois que deixei somente o samba como servidor de arquivos os usuários começaram a reclamar muito de lentidão na rede para acessar os arquivos.

    Hoje fui fazer um teste:

    Peguei o instalador do antivírus avast e coloquei no server windows 2003 numa pasta compartilhada.Fiz o mesmo no samba.

    Pasmem: no windows a máquina cliente abriu o arquivo para começar a instalar em 3.07 segundos já no samba 2:54(quase 3 minutos)

    o que pode está acontecendo? meus servidores samba tem as seguintes configurações:
    1-Sevidor dell Poweredge 840 processador xeon 2.4ghz/2xHds satas 500GB raid 1/4GB de memória/placa de rede 1Gb/s
    2-Dell T105 opteron 2.1ghz/2GB/250GB sata II/placa de rede 1Gb/s

    o servidor windows 2003 é:
    Xeon 2.4/3xHds scsi 146GB/8GB de memória

    sei que o servidor windows é mais parrudo mas isso não justifica pois nos linux só roda o samba puro e no windows roda banco de dados oracle, dns, dhcp, IIS, 5 aplicativos da empresa pois ele tb é servidor de aplicativos.


    Segue abaixo meu smb.conf:

    workgroup = NOVAF


    realm = NOVAF.LOCAL
    server string = Servidor Linux
    security = ads
    ;security = share
    netbios name = backup

    idmap uid = 10000-20000
    winbind enum users = yes
    winbind gid = 10000-20000
    os level = 20
    winbind enum groups = yes

    password server = application.novaf.local
    domain master = no
    local master = no
    domain logons = no
    preferred master = no
    winbind separator = +
    ;winbind use default domain = yes
    max log size = 50
    template homedir = /home/%D/%U
    log file = /var/log/samba/log.%m
    encrypt passwords = yes
    dns proxy = no
    wins server = 10.0.1.2
    wins proxy = no


    #Performace

    log level = 1
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    read raw = yes
    write raw = yes
    oplocks = yes
    max xmit = 65535
    dead time = 15
    getwd cache = yes



    #Lixeira samba
    vfs object = recycle
    #a linha abaixo cria uma pasta com o nome do usuário que deletou o arquivo e salva la
    recycle:repository = /var/samba/trash/%U
    recycle:keeptree = yes
    recycle:versions = yes





    [dados]
    comment = pastas do servidor linux
    path = /home/samba/dados
    browseable = yes
    writable = true
    #read only = No
    valid users = @"NOVAF+domain users"
    create mask = 0660
    directory mask = 2770


    [dvdrom]
    comment = CDRom Server Linux
    path = /media/cdrom
    public = yes
    read only = yes
    browseable = yes
    root preexec = /bin/mount /media/cdrom
    root postexec = /bin/umount /media/cdrom

  2. Amigao, bom dia! tive um problema parecido.. depois que li os logs do samba, percebi que ele estava tentando carregar o CUPS, porém o CUPS nao estava instalado no meu servidor em questao, apenas instalei o CUPS e tudo ficou lindo! já ouvi comentarios de lentidao causada por placa de rede.


    um grande abraço



  3. bom instalei o cups nos 2 servidores mesmo sem usá-lo sobre a placa de rede são broadcom 1Gb/s da dell e são compatíveis com Redhat logo são compatíveis com o centos só se tiver algum drive específico vou pesquisar tb.
    Última edição por lfernandosg; 11-11-2010 às 08:26.

  4. é, estranho... ( rs quem nunca começa o post assim rsrs )
    mas nessas horas é bom desconfiar de tudo, hehe,
    eu desconfiei quando vc falow q no windows abriu em menos de 5 segundos.
    pensei: deve ser por causa da indexação de arquivos, já que seus terminais devem estar com o primeiro DNS apontado para o WinServer.
    veja se adicionando o compartilhamento ao indice do windows melhora..
    mas o esquema é dar uma lida nos logs do samba pra ve se o Sr acha algo...
    boa sorte.






Tópicos Similares

  1. Lentidão abrindo MDB no samba
    Por kondor no fórum Servidores de Rede
    Respostas: 4
    Último Post: 21-03-2007, 21:42
  2. Lentidao no samba com Winbind e ACL
    Por andrefs no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-05-2005, 16:45
  3. lentidao no samba
    Por bouncer no fórum Redes
    Respostas: 0
    Último Post: 22-03-2005, 20:00
  4. Executavéis no Samba
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 21-10-2002, 17:19
  5. User Pam no Samba
    Por anjo-negro no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-04-2002, 08:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L