+ Responder ao Tópico



  1. #1

    Padrão HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    galera, to com um problema, talvez pra voces seja facil, pois ainda estou gatinhando no mikrotik. Vamos ao problema !! Eu fiz o balanceamento de carga PCC (Mikrotik 3.3) e a tela de login do hotspot nao entra a nao ser que se coloque o ip do servidor, por outro lado se eu desativar a segunda regra em route (abaixo em vermelho) a tela de login aparece, o que pode ser galera ???

    Desde Ja, agradeço a todos !!!

    As regras >>>------->

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=Lan new-connection-mark=Sites0 passthrough=yes

    add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=Lan new-routing-mark=Rota0 passthrough=no

    add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no dst-port=443 in-interface=Lan protocol=tcp
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 protocol=icmp

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=Net new-connection-mark=Net_conn passthrough=yes

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=adsl_Spd new-connection-mark=adsl_Spd_conn passthrough=yes

    add action=mark-routing chain=output comment="" connection-mark=Net_conn disabled=no new-routing-mark=to_Net passthrough=yes

    add action=mark-routing chain=output comment="" connection-mark=adsl_Spd_conn disabled=no new-routing-mark=to_adsl_Spd passthrough=yes

    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    200.***.***.0/24 in-interface=Lan

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=Net_conn passthrough=yes per-connection-classifier=both-addresses:3/0

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=Net_conn passthrough=yes per-connection-classifier=both-addresses:3/1

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=adsl_Spd_conn passthrough=yes per-connection-classifier=\
    both-addresses:3/2

    add action=mark-routing chain=prerouting comment="" connection-mark=Net_conn disabled=no in-interface=Lan new-routing-mark=to_Net passthrough=yes add action=mark-routing chain=prerouting comment="" connection-mark=adsl_Spd_conn disabled=no in-interface=Lan new-routing-mark=to_adsl_Spd passthrough=yes

    / ip route

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    200.***.***.1 routing-mark=Rota0 scope=30 target-scope=10

    add comment=Link1 disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
    adsl_Spd routing-mark=to_adsl_Spd

    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.189.206.1 scope=30 target-scope=10

    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.***.***.1 routing-mark=to_Net scope=30 \
    target-scope=10

    add comment=Link1 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    adsl_Spd

  2. #2

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    amigo não sou muito bom com scripts mais faz o seguinte vc tem que setar o hotspot do ip que vai sair para os clientes assim ele vai ficar blz!



  3. #3
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Citação Postado originalmente por sonishi Ver Post
    galera, to com um problema, talvez pra voces seja facil, pois ainda estou gatinhando no mikrotik. Vamos ao problema !! Eu fiz o balanceamento de carga PCC (Mikrotik 3.3) e a tela de login do hotspot nao entra a nao ser que se coloque o ip do servidor, por outro lado se eu desativar a segunda regra em route (abaixo em vermelho) a tela de login aparece, o que pode ser galera ???

    Desde Ja, agradeço a todos !!!

    As regras >>>------->

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=Lan new-connection-mark=Sites0 passthrough=yes

    add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=Lan new-routing-mark=Rota0 passthrough=no

    add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no dst-port=443 in-interface=Lan protocol=tcp
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 protocol=icmp

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=Net new-connection-mark=Net_conn passthrough=yes

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=adsl_Spd new-connection-mark=adsl_Spd_conn passthrough=yes

    add action=mark-routing chain=output comment="" connection-mark=Net_conn disabled=no new-routing-mark=to_Net passthrough=yes

    add action=mark-routing chain=output comment="" connection-mark=adsl_Spd_conn disabled=no new-routing-mark=to_adsl_Spd passthrough=yes

    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    200.***.***.0/24 in-interface=Lan

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=Net_conn passthrough=yes per-connection-classifier=both-addresses:3/0

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=Net_conn passthrough=yes per-connection-classifier=both-addresses:3/1

    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local in-interface=Lan new-connection-mark=adsl_Spd_conn passthrough=yes per-connection-classifier=\
    both-addresses:3/2

    add action=mark-routing chain=prerouting comment="" connection-mark=Net_conn disabled=no in-interface=Lan new-routing-mark=to_Net passthrough=yes add action=mark-routing chain=prerouting comment="" connection-mark=adsl_Spd_conn disabled=no in-interface=Lan new-routing-mark=to_adsl_Spd passthrough=yes

    / ip route

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    200.***.***.1 routing-mark=Rota0 scope=30 target-scope=10

    add comment=Link1 disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
    adsl_Spd routing-mark=to_adsl_Spd

    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.189.206.1 scope=30 target-scope=10

    add check-gateway=ping comment=Link0 disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=200.***.***.1 routing-mark=to_Net scope=30 \
    target-scope=10

    add comment=Link1 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    adsl_Spd
    é melhor separar o seu PCC, coloca um RB 450G ou 750G para fazer LB saindo para o seu servidor, ja vai resolver em muito o seu caso.

  4. #4

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Também estou com o mesmo problema. Tenho mikrotik v3.30 com load balance por pcc de dois links adsl de 1MB da oi. Está funcionando direito, porém o hotspot não está funcionando... Alguém poderia postar como configurar por exemplo: Uma Rb 450g para fazer o pcc e um pc para fazer as autenticações por hotspot? Desde já agradeço!!!!



  5. #5

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Galera, depois de muita pesquisa (Sem resultado), comecei a fazer uns testes constatei que no:
    /ip firewall address-list tem que ter o ip da pagina inicial do navegador, exemplo: se for br.msn.com tem que colocar o ip 65.55.17.37, mas como nem todos utilizam a mesma pagina inicial, eu coloquei o ip 0.0.0.0/0 e funcionou direitinho !!!

    agora gostaria que os profissionais existentes nesse forum deem uma analizada para ver se isso gera alguma brecha. !!!

    Obrigado por enquanto !!!!

  6. #6

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Amigo quer dizer que vc conseguiu colocar o sever + hotspot + load balance na mesma maquina ? comprei uma rb 750 pois diziam que isto não dava certo



  7. #7

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Pois é, as vezes é bom insistir, fazer todos os testes possiveis antes de partir para o DESISTO, e o pior que esse servidor MK esta rodando em uma maquina virtual dentro de um server 2003 !!

  8. #8

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Parabéns pelo feito, consultei muito bam bam bam por ai dizendo que não dava certo de jeito nenhum.
    Outra coisa, vc usa o webproxy do próprio MK ou em paralelo ?



  9. #9

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    Ola hotspot com pcc funciona no mesmo Pc , estou com ele funcionano faz meses , eu no consegui fazer funcionar o pcc + hotspot + proxy paralelo.

  10. #10

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    ola sonishi, fiquei intereçado em seu pos "exemplo: se for br.msn.com tem que colocar o ip 65.55.17.37, mas como nem todos utilizam a mesma pagina inicial, eu coloquei o ip 0.0.0.0/0 e funcionou direitinho !!!" mais nao entendi direito, onde devo colocar isso, minha situaçao é a seguinte, hotspot funciona mais o balanceamento pcc nao funciona coretamente quando uma linha cai a outra asume mais ele nao balancea a carga, postarei minha rtegras abaixo se puder me ajudar ficarei grato....

    /ip route
    add check-gateway=arp comment="WAN 2 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan2
    add check-gateway=arp comment="WAN 1 - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=wan1
    add check-gateway=arp comment="WAN 1 - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=wan1
    add check-gateway=arp comment="Default Route - Distance 1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    add check-gateway=arp comment="Default Route - Distance 2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=arp comment="Rota estática - WAN1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=static-wan1
    add check-gateway=arp comment="Rota estática - WAN2" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=static-wan2
    ############################## #############################
    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=201.7.176.0/20 comment="Vdeos - Globo" disabled=no list=loopback
    add address=208.84.247.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.154.56.0/24 comment="Vdeos - terratv" disabled=no list=loopback
    add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    add address=200.201.166.0/24 comment="" disabled=no list=loopback
    add address=200.201.173.0/24 comment="" disabled=no list=loopback
    add address=200.201.174.0/24 comment="" disabled=no list=loopback
    add address=200.141.207.3 comment=Detran disabled=no list=loopback
    add address=85.17.216.46 comment=www.easy-share.com disabled=no list=loopback
    add address=200.222.8.9 comment=Detran disabled=no list=loopback
    ############################## #############################
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOAD BALACED" disabled=no dst-address-list=loopback in-interface=lan
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan1" connection-state=new disabled=no in-interface=wan1-pppoe new-connection-mark=wan1 \
    passthrough=yes
    add action=mark-connection chain=input comment="Marca nova conexão de entrada wan2" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2 \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan1" connection-state=established disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada estabelecidas wan2" connection-state=established disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan1" connection-state=related disabled=no in-interface=wan1-pppoe \
    new-connection-mark=wan1 passthrough=yes
    add action=mark-connection chain=prerouting comment="Marca conexão de entrada relacionadas wan2" connection-state=related disabled=no in-interface=wan2-pppoe \
    new-connection-mark=wan2 passthrough=yes
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan1" connection-mark=wan1 disabled=no new-routing-mark=static-wan1 passthrough=no
    add action=mark-routing chain=output comment="Marca nova rota de entrada wan2" connection-mark=wan2 disabled=no new-routing-mark=static-wan2 passthrough=no
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=new disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego estabelecido que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/1
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (2 possibilidades) - opção 1" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="Marca tráfego relacionado que não é local com rand marca PCC (2 possibilidades) - opção 2" connection-state=related \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_pcc_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 1" connection-mark=wan1_pcc_conn disabled=no new-routing-mark=wan1 passthrough=\
    yes
    add action=mark-routing chain=prerouting comment="Marca encaminhamento para marcar PCC - opção 2" connection-mark=wan2_pcc_conn disabled=no new-routing-mark=wan2 passthrough=\
    yes



  11. #11

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    o grande problema e esse vc consultou o bam bam bam , não os profissionais, la no post sobre lb do luciano (PCRAM) possui o esquema pra quem quer usar hotspot junto com pcc, agora se vc quer facilitar sua vida em vez de complicar, e mais fácil vc separar os serviços e evitar esquemas mais complexos,visando manutenção e problemas futuros.
    Citação Postado originalmente por jardelalmeida Ver Post
    Parabéns pelo feito, consultei muito bam bam bam por ai dizendo que não dava certo de jeito nenhum.
    Outra coisa, vc usa o webproxy do próprio MK ou em paralelo ?

  12. #12

    Padrão Re: HOTSPOT NAO FUNCIONA COM BALANCEAMENTO PCC

    para quem quer dar uma olhada, esse lb fiz para um amigo meu.
    3 Links assimétricos 4MB/2MB/1MB
    IP:201.29.22.118
    Login:Teste
    Senha:teste