+ Responder ao Tópico



  1. Sou novato em mk (nunca tinha contato antes), estou ontanto um 3.30 e através deste forum montei um frankstein, um pedacinho de cada amigo.

    Minha configuração é a seguinte: servidor 2 placas ether, a primeira recebe o link recebendo o ip por DHCP(modem/roteador) e a segunda envia liberando ip por DHCP(Server). Aparentemente esta funcionando, más como não sou expert como os amigos peço sua apreciação.

    Segue a configuração:

    Configuração Básica
    /interface set ether1 name=Link comment="conexão com a internet"
    /interface set ether2 name=Clientes comment="conexão com os clientes"


    /ip dhcp-client add interface=Link client-id="xx:xx:xx:xx:xx:xx(MAC DO MODEM/ROUTER)" add-default-route=yes use-peer-dns=yes use-peer-ntp=yes comment="" disabled=no
    /ip address add address=192.168.1.1/24 interface=Clientes

    /ip route add gateway=192.168.0.1


    /ip dns set primary-dns=192.168.0.1
    /ip dns static add name=192.168.1.1 address=192.168.1.1

    /ip firewall nat add chain=srcnat action=masquerade src-address=192.168.1.0/24 comment="masquerade hotspot network"

    /ip pool add name=”dhcp-pooll” ranges=192.168.1.2-192.168.1.254 next-pool=none
    /ip dhcp-server add name=”DHCP-SERVER” interface=Clientes address-pool=dhcp-pooll lease-time=3d add-arp=yes disabled=no
    /ip dhcp-server network add address=192.168.1.0/24 comment="" dns-server=192.168.1.1 gateway=192.168.1.1

    Configuração do Web-Proxy Full

    /ip firewall filter
    add chain=input action=drop protocol=tcp in-interface=Link dst-port=3128 comment="block external proxy"
    add chain=input action=accept protocol=tcp dst-port=3128 comment="accept connections from proxy"

    /ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=3128 content=”X-Cache: HIT” comment="mark connection *conn_squid-up*"
    add chain=output action=mark-packet new-packet-mark=pacotes_squid-up passthrough=yes connection-mark=conn_squid-up comment="mark packet *pacotes_squid-up*"
    add chain=prerouting action=mark-connection new-connection-mark=conn_squid-down passthrough=yes protocol=tcp dst-port=3128 comment="mark connection *conn_squid-down*"

    add chain=prerouting action=mark-packet new-packet-mark=pacotes_squid-down passthrough=yes connection-mark=conn_squid-down comment="mark packet *pacotes_squid-down*"

    /ip firewall nat
    add chain=srcnat action=masquerade src-address=192.168.1.0/24 out-interface=Clientes comment="nat"
    add chain=dstnat action=redirect to-ports=3128 protocol=tcp src-address=192.168.1.0/24 dst-port=80 comment="redirect port 80 to 3128"

    /queue tree
    add name="downstream" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
    add name="upstream" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    /ip proxy
    set port=3128 cache-on-disk=yes src-address=0.0.0.0 parent-proxy=0.0.0.0 parent-proxy-port=0 cache-administrator="webmaster" max-cache-size= unlimited max-client-connections=200 max-server-connections=200 max-fresh-time=3d serialize-connections=no always-from-cache=no cache-hit-dscp=4
    set enabled=yes


    Configuração do HotSpot

    /ip hotspot profile add name="profile-hotspot" hotspot-address=192.168.1.1 dns-name="192.168.1.1" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,http-chap,cookie split-user-domain=no use-radius=no

    /ip hotspot add name=servidor-hotspot profile=profile-hotspot interface=Clientes disabled=no address-pool=dhcp-pooll

    /ip hotspot user profile add name=Liberado address-pool=dhcp-pool shared-users=1 idle-timeout=5m status-autorefresh=1m transparent-proxy=yes open-status-page=always advertise=no
    /ip hotspot user profile add name="Atraso" address-pool=none idle-timeout=10m keepalive-timeout=10m status-autorefresh=5m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=atraso.htm advertise-interval=10m advertise-timeout=never
    /ip hotspot user profile add name="Bloqueio" address-pool=none idle-timeout=none session-timeout=10s keepalive-timeout=20m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=bloqueio.htm advertise-interval=0s advertise-timeout= immediately

    /ip hotspot user add name=Usuario1 profile="Aviso" server=servidor-hotspot password=1234

    FIM

    Gostaria de saber se isto esta certo e se a sequencia em que coloquei os comandos influencia em alguma coisa.

    Agradeço desde já a todos que puderem dar uma pitada de sua sabedoria

    Marcos Sá

  2. Olá, bem vindo ao under-linux e ao MikroTik que parece também o seu caso, vou deixar um passo a passo inicial.

    Indicar de onde vem a internet pro seu ros.

    1 - Defina o IP da interface de entrada, pode ser via DHCP Client (neste caso já vai adicionar rota default/dns/ip automaticamente), ou então se manual acesse:
    /ip address - aqui você coloca um ip na mesma classe da lan do roteador
    /ip dns - indica o dns que vai utilizar, pode ser o ip da lan do roteador se este suportar ou do google/opendns
    /ip route - aqui você adiciona a rota default, algo como 0.0.0.0/0 ou seja para todos os destinos, o gateway 1.2.3.4 que deve ser o ip do seu roteador/modem.

    Neste ponto se abrir o terminal do Mk deve ser possível sair pra internet:
    ping uol.com.br

    O passo seguinte é definir um ip (noutra classe preferencialmente) na interface que vai atender os clientes, pode ser algo como 10.10.10.254, este que será o gateway/dns dos seus clientes e criar um mascaramento para a interface de entrada do link.
    /ip address - define o ip na interface dos clientes
    /ip firewall nat - adiciona o mascaramento para out-interface=link e src-address a range dos clientes (10.10.10.0/24).

    Nos clientes vc vai utilizar ips dentro desta classe, ex:
    cliente 1> 10.10.10.1 mask 255.255.255.0 gat>10.10.10.254
    cliente 2> 10.10.10.2 mask 255.255.255.0 gat>10.10.10.254
    cliente n> 10.10.10.n mask 255.255.255.0 gat>10.10.10.254

    Isso para uma rede nateada sendo a mais simples de configurar.

    Na sequencia você pode criar controles de banda especificos para cada IP, acesse:
    /queue simple
    Name=qualquer, pode ser o nome do cliente
    Target Address=10.10.10.n - ip do cliente
    Max Limit: velocidades de limite para upload e download, ex: 256k 128k

    Feito isso, você já sabe configurar o mikrotik básico sem copiar e colar regras, quisera eu que todos soubessem os passos básicos, talvez você até já saiba mas tem muita gente que utiliza mikrotik a anos e não sabe.

    Quanto a sua pergunta se a 'ordem dos fatores altera o produto', no caso do mikrotik sim, se tentar configurar o dhcp server sem definir um ip na interface que irá servir terá problema, se tentar criar um profile sem uma pool também, acaba tendo de seguir uma certa ordem como tudo na vida. Um exemplo clássico é tentar navegar na internet sem configurar o DNS, não vai por ns mas vai por ip, logo seguindo a ordem tudo funciona.

    Grande abraço.






Tópicos Similares

  1. Respostas: 31
    Último Post: 15-05-2015, 06:36
  2. Respostas: 33
    Último Post: 14-11-2011, 21:50
  3. Respostas: 29
    Último Post: 25-07-2007, 17:58
  4. Gostaria da opnião dos colegas
    Por netosdr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 23-10-2004, 08:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L