+ Responder ao Tópico



  1. Olá amigos.
    Hoje peguei o seguinte caso.
    Servidor: Linux rodando samba aonda somente serve (Sistema de Gerenciamento da empresa) para apenas 1 terminal e a ele mesmo, pois o cliente usa também esse servidor para jogar dados no SG.
    Terminal: windows xp sp3.

    O clinte me chamou porque quando ele criava o backup do SG, ao copiar para o terminal ele aparece uns escritos na tela no servidor.

    Algo como: overflow line 10, overflow line 9 e assim por diante.

    Entrei em contato com a empresa repsonsável pelo SG, eles fizeram uns testes e não acharam nada anormal no sistema, falaram que é problema no samba.

    Vou explicar exatamento o precesso do backup. Pelo terminal é acionado o backup, é gerado um backup dentro do servidor, depois é feito uma cópia do arquivo de backup para o terminal. Quando manda copiar, ou manda substituir, ou algumas vezes até quando está fazendo o backup as mensagens de overflow aparecem. Eu consigo gravar no servidor, deletar, mas se eu copiar algo novo, tirar dele para o terminal da essas mensagens. Não me parece configuração do samba, o HD está com uso de 47%. Dei uma lida em alguns foruns e vi sobre o AVIRA causar overflow e talz, nesse terminal tem o PANDA, o que vocês acham que pode ser?


    OBS: Infelizmente não tenho muitas informações sobre versão do samba e do linux.
    Última edição por maninhx; 25-11-2010 às 19:38.

  2. 1) como é feito a cópia do servidor para o terminal ?
    Via FTP, via drive mapeado no Samba ?

    2) A partição do Windows (para onde estão sendo copiados os arquivos) está com NTFS ou FAT3?

    3) Vc já desabilitou os antivirus no cliente e refez o teste ?



  3. É feito via drive mapeado do samba. Partição windows NTFS. o Anti-Vírus ainda não desativei.Vou fazer esse teste.

  4. Peguei mais detalhes do servidor.

    Conectiva linux Server 7
    Samba: 2.2.0
    segue o smb.conf.

    mensagens de erro. ERROR string overflow by 2 in safe_strcat
    smbd/posix_acls.c:create_canon_ace_lists
    unable to map SID S-1-5-18 to uid or gid.



    [global]

    workgroup = lorenci

    netbios name = servidor

    server string = Servidor de Dados

    hosts allow = 192.168.0. 127.

    printcap name = /etc/printcap

    load printers = yes
    p
    rinting = lprng

    log file = /var/log/samba/log.%m

    max log size = 50

    security = share

    encrypt passwords = yes

    unix password sync = Yes

    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

    local master = no

    os level = 33

    domain master = yes

    preferred master = yes

    null passwords = no

    dead time = 0

    #============================ Compartilhamento ==============================

    [printers]

    comment = All Printers

    path = /var/spool/samba

    browseable = no

    public = yes

    writable = no

    printable = yes

    available = no

    [c]

    path = /usr

    public = yes

    writable = yes

    printable = no

    create mask = 0777

    directory mask = 0777

    force user = root

    force group = root
    Última edição por maninhx; 26-11-2010 às 10:20.



  5. Pessoal. É o anti-vírus que causa esse oveflow. Como resolver? não gostaria de trocar o anti-vírus, o cliente usa o Panda Pro 2010.






Tópicos Similares

  1. Grupos linux no samba
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-12-2002, 09:56
  2. smb_get_length(mgs erros no Samba)?????
    Por PedroNasc no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-11-2002, 12:42
  3. Lixeira no Samba
    Por marcosmamorim no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-10-2002, 14:36
  4. Executavéis no Samba
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 21-10-2002, 17:19
  5. User Pam no Samba
    Por anjo-negro no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-04-2002, 08:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L