Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Tenho hoje dois links com balanceamento por rotas e algumas regras que fazem a redundância deles.
    Se o link 1 cai o 2 assume e vice-versa.
    Em /Tools Netwatch é verificado um ip externo através dos dois links
    Se um dos links não consegue resposta um script é ativado fazendo o outro link assumir

    Ex: No caso do link 1 cair, em mangle tem uma rota que joga tudo para o link 1.
    Daí um script, ao cair, desativa a regra de divisão por rotas, e ativa a regra jogando tuda rede no 2.

    Só que de alguns dias pra cá, se o link 1 cai, quando ele volta as rotas não são refeitas ao padrão. Ou seja, todos ficam no link 1, gerando gargalo.

    Se jogar o script no terminal ele executa as regras normal, mas se eu dar um run script simplesmente ele desativa em mangle as rotas padrão.
    Falo do script Link1on, ou seja, o script que volta as coisas ao normal quando o link 1 estiver on.

    O conteúdo do script tá assim:
    :log info "LINK 1 VOLTOU"
    /ip firewall mangle enable 32
    /ip firewall mangle disable 33

    As regras do mangle fazem o seguinte:
    32 ;;; ROTAS PARA LINK 2
    chain=prerouting action=mark-routing new-routing-mark=LINK2
    passthrough=yes src-address=192.168.1.100-192.168.1.150

    33 ;;; REDUDANCIA
    chain=prerouting action=mark-routing new-routing-mark=LINK2
    passthrough=yes src-address=192.168.1.2-192.168.1.150

    Se eu copio e colo no terminal faz certinho

    Mas executando o script ele dá como se fosse disable 32 não enable.

    Estão marcadas as opções:

    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive

  2. Se esta se tratando de rota, use em IP ROUTE direto.
    Crie as 2 rotas, pela distancia faça a prioridade. O raciocinio esta certinho. Desabilitando e habilitando a principal automaticamente a secundaria entrara. O comentário dado a cada rota é muito importante pois usara ele como marcação.



  3. Mas o estranho é o seguinte
    São duas regras em mangle
    Uma sempre desativada que é a 33
    Que redireciona toda a rede para um link só
    É a outra 31 que Redireciona metade da rede para o Link 2
    Fica sempre ativada

    Quando o link 1 cai é ativado um script
    Toda a rede vai para o link 2
    Beleza, funciona..
    Mass....
    Quando o link 1 volta

    Tem um script chamado LINK1ON
    Que reverte tudo, ou seja, dá um enable na regra 32 e um disable na regra 33
    Se vc pegar o conteúdo do script, copiar e colar no terminal funciona filé
    A regra 32 que é a de de rotas de metade da rede para o link 2 é ativada com esse script
    Se vc copia e cola no terminal funciona massa
    Mas se manda dar um run no script...
    Simplesmente ao invés de ativar a regra 32
    Ele desativa
    Faz o contrário

    Olha que simples o script
    :log info "LINK1 VOLTOU"
    /ip firewall mangle enable 32
    /ip firewall mangle disable 33

    O o script quando roda faz o efeito contrário. É isso que não entendo porquê

  4. Vou explicar mais detalhado:

    O gateway da rede é 192.168.1.1
    Clientes estão em uma bridge chamada PONTE
    Clientes ip 192.168.1.2-192.168.1.99 usam o link 1
    Clientes ip 192.168.1.100-192.168.1.150 usam o link 2

    Modem 1 em bridge
    Modem 2 roteado com ip 1.1.1.1

    As regras são:

    /ip firewall nat

    1 ;;; NAT LINK 1
    chain=srcnat action=masquerade src-address=192.168.1.2-192.168.1.99

    2 ;;; NAT LINK 2
    chain=srcnat action=masquerade src-address=192.168.1.100-192.168.1.150


    /ip firewall mangle

    32 ;;; ROTAS PARA Link 2
    chain=prerouting action=mark-routing new-routing-mark=LINK2
    passthrough=yes src-address=192.168.1.100-192.168.1.150

    33 X ;;; REDUDANCIA
    chain=prerouting action=mark-routing new-routing-mark=LINK2

    Rotas:

    #...........DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 A S......0.0.0.0/0.......................................1.1.1.1...............1
    1 A S......0.0.0.0/0.......................................200.x.x.x............1
    2....S......0.0.0.0/0.......................................1.1.1.1...............1
    3 ADC....1.1.1.0/24.............1.1.1.2..............Link2.................0
    4 ADC....192.168.1.0/24.....192.168.1.1......PONTE...............0
    5 ADC....200.xx.xx.xx/32.....201.xx.xx.xx.....Link1.................0
    6 A S......208.xx.xx.xx/32.............................200.x.x.x...........1
    7 A S......208.xx.xx.xx/32.............................1.1.1.1..............1

    São 4 scripts

    Link1OFF:
    :log info "LINK 1 CAIU"
    /ip firewall mangle disable 32
    /ip firewall mangle enable 33

    Link1On
    :log info "LINK 1VOLTOU"
    /ip firewall mangle enable 32
    /ip firewall mangle disable 33

    Link2Off
    :log info "LINK 2 CAIU"
    /ip route disable 0

    Link2On:
    :log info "LINK 2 VOLTOU"
    /ip route enable 0

    Em Netwatch são duas regras onde os links mandam requisição para um ip.

    Caso o link 1 não caia:
    É ativado o script Link1OFF

    Caso o link 1 volte:
    É ativado o script Link1ON

    Caso o Link 2 caia:
    É ativado o script link 2OFF

    Caso o link 2 volte:
    É ativado o script Link2ON



  5. Aos mais avançados em Router OS.. Deem uma moral aí pra mim por favor..






Tópicos Similares

  1. Redundancia de Links e redirecionamento de serviços
    Por Dedao no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-08-2008, 19:40
  2. Redundancia de Link
    Por Thiagocpv no fórum Servidores de Rede
    Respostas: 14
    Último Post: 29-01-2008, 17:41
  3. Redundancia De Links
    Por jorgepatrinicola no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-10-2007, 08:13
  4. Redundância de link
    Por andunno no fórum Servidores de Rede
    Respostas: 1
    Último Post: 08-01-2007, 20:00
  5. Redundância de Link
    Por lucianogf no fórum Servidores de Rede
    Respostas: 7
    Último Post: 20-09-2005, 15:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L