Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico




  1. Boa Tarde amigo, vc. pode me falar quais são essas regras.?



  2. No Debian Proxy:

    nano /etc/network/interfaces
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 172.31.255.3
    netmask 255.255.255.248
    network 172.31.255.0
    broadcast 172.31.255.7
    gateway 172.31.255.1
    dns-nameservers 8.8.8.8
    -----------------------------------------------------------------------------------------------------------------------------
    no rc.local fica as regras de firewall:
    nano /etc/rc.local

    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 3128

    # route add -net [rede dos clientes] gw [ip do mikrotik que conversa com o cache]
    route add -net 192.168.0/24 gw 172.31.255.1
    ------------------------------------------------------------------------------------------------

    No Mikrotik:

    Internet: 200.200.200.200/24
    Proxy: 172.31.255.1/29
    RedeLocal: 192.168.0.1/24
    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração das placas e dos IP's
    interface set ether1 name=Internet
    interface set ether2 name=Proxy
    interface set ether3 name=Clientes

    ip address add address=200.200.200.200/24 interface=Internet
    ip address add address=172.31.255.1/29 interface=Proxy
    ip address add address=192.168.0.1/24 interface=Clientes

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de DNS
    # ip dns static add address=[gateway da rede dos clientes] name=192.168.0.1
    ip dns static add address=192.168.0.1 name=192.168.0.1

    ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Gateway
    ip route add gateway=200.200.200.1

    -----------------------------------------------------------------------------------------------------------------------------
    # Configuração de Radius
    # radius add address=[IP do MK-Auth] service=hotspot secret=123456
    radius add address=172.31.255.2 service=hotspot secret=123456

    obs: Estou usando Mikrotik v4.11 para setar dns em versões antigas é diferente.

    -----------------------------------------------------------------------------------------------------------------------------
    no mikrotik regras de nat:

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=172.31.255.0/29
    add action=masquerade chain=srcnat comment="Conectividade Social" disabled=no dst-address=200.201.160.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.166.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.173.0/24
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=200.201.174.0/24
    add action=dst-nat chain=dstnat comment="Redireciona a porta 80 para o proxy" disabled=no dst-port=80 in-interface=Clientes protocol=tcp src-address=!172.31.255.0/29 to-addresses=172.31.255.3
    add action=masquerade chain=srcnat comment="" disabled=no dst-port=!80 protocol=tcp
    add action=masquerade chain=srcnat comment="" disabled=no dst-port=!80 protocol=udp
    add action=masquerade chain=srcnat comment="" disabled=no protocol=icmp
    add action=masquerade chain=srcnat comment="Mascaramento Geral" disabled=yes

    -----------------------------------------------------------------------------------------------------------------------------
    Para acesso Externo ao Servidor:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=1880 protocol=tcp to-addresses=172.31.255.2 to-ports=80

    Tenha como base essas regras... Qualquer duvida é so falar... Olha fiz as regras de nat aqui agora de acordo com o que eu penso que vai te servir, qualquer duvida posta ai...
    Última edição por wilkerpaz; 03-01-2011 às 20:11.

  3. Bom dia amigo, fico mto grato por sua ajuda. fiz todos os procedimentos citados e o cache e o proxy estão funcionando perfeitamente, no entanto no sarg ainda não aparece os ip's dos clientes da rede mas somente o ip do mikrotik. ficarei mto grato se conseguir me passar quais regras devo adicionar para que isso ocorra.



  4. Amigo as regras estão ai olha direirinho no tutorial não esquece de clicar na estrelinha pra agradecer rss:

    # route add -net [rede dos clientes] gw [ip do mikrotik que conversa com o cache]
    route add -net 192.168.0/24 gw 172.31.255.1






Tópicos Similares

  1. Speedr em paralelo com Mikrotik 5.23
    Por indioklebson no fórum Servidores de Rede
    Respostas: 12
    Último Post: 29-11-2013, 17:45
  2. Regra para speedr em paralelo com mikrotik
    Por rodolfostayne no fórum Servidores de Rede
    Respostas: 27
    Último Post: 15-11-2012, 11:13
  3. Ajuda Squid em paralelo com Mikrotik
    Por pu3rzr no fórum Redes
    Respostas: 2
    Último Post: 01-11-2011, 06:52
  4. SQUID EM PARALELO COM MIKROTIK "DUVIDA"
    Por cordeirog3 no fórum Redes
    Respostas: 10
    Último Post: 30-12-2009, 21:21
  5. Proxy em paralelo com Mikrotik
    Por juderlan no fórum Redes
    Respostas: 13
    Último Post: 13-07-2008, 11:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L