+ Responder ao Tópico



  1. #1

    Padrão *ERRO AO INSTALAR SQUID NO CONECTIVA 10

    Olá pessoal, sou novato no forum e iniciante no linux!
    Bom meu objetivo nessas ferias de inicio de ano é aprender sobre squid (proxy) do linux, optei por usar o conectiva 10 por ser uma distribuiçao nacional.
    Fiz a instalaçao do linux (conetiva10) em modo padrao e fiz o download do squid em formato rpm, executei o seguinte comando e recebi esta msg:


    [[email protected] squid]# apt-get -f install squid-2.6-s13_2.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando squid para 'squid-2.6-s13_2.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.

    Já que você solicitou uma única operação é extremamente provável que
    o pacote esteja simplesmente não instalável e um relato de erro sobre
    esse pacote deve ser enviado.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:
    squid: Depende: libcrypto.so.4 mas este não é instalável
    Depende: liblber-2.2.so.7 mas este não é instalável
    Depende: libldap-2.2.so.7 mas este não é instalável
    Depende: libssl.so.4 mas este não é instalável
    Depende: perl(File::Basename) mas este não é instalável
    Depende: perl(Getopt::Std) mas este não é instalável
    Depende: perl(URI::URL) mas este não é instalável
    Depende: perl(getopts.pl) mas este não é instalável
    Depende: perl(strict) mas este não é instalável
    Depende: perl(vars) mas este não é instalável
    E: Pacotes quebrados

    O QUE ESTOU FAZENDO DE ERRADO?

  2. #2

    Padrão Re: *ERRO AO INSTALAR SQUID NO CONECTIVA 10

    Está trabalhando em uma distro muito antiga.
    Se quer continuar a usar "conectiva", recomendo usar o mandriva, que foi a fusao da conectiva com a mandrake.
    Recomento também utilizar um debian-based.
    Saudações,



  3. #3

    Padrão Re: *ERRO AO INSTALAR SQUID NO CONECTIVA 10

    Pessoal instalei o pacote de ferramentas de (desenvolvimento) os compiladores... copiei o squid-3.1.9 para pasta temp no formato tar.gz e descompactei em seguida abri o console e executei o seguinte comando:
    1- localizei o arquivo na pasta 'tmp'
    2-./configure

    em seguida carregou uma paaa lista enorme de comando! ai me pergunto que será? instalado??