+ Responder ao Tópico



  1. ao amigos do forum estou precisando e ajuda de vcs pra melhorar meu script de um load balance pcc com 4 links adsl em bridge rb 750 ..

    alguns tem muito mais experiencia no assunto .. que podem ajudar


    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan1 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan1 password= profile=default service-name="" use-peer-dns=no user=9936611215@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan2 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan2 password= profile=default service-name="" use-peer-dns=no user=9936611215@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan3 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan3 password= profile=default service-name="" use-peer-dns=no user=9936611619@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan4 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan4 password= profile=default service-name="" use-peer-dns=no user=9936611619@
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.4.4
    /ip dns set secondary-dns=8.8.8.8
    /ip dns set allow-remote-requests=yes

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan1
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan2
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan3
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan4
    # ip firewall mangle------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=LINK2
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=LINK2
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=LINK2

    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Local
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan1 new-connection-mark=adsl_wan1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan2 new-connection-mark=adsl_wan2_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan3 new-connection-mark=adsl_wan3_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan4 new-connection-mark=adsl_wan4_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan1_conn disabled=no new-routing-mark=to_adsl_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan2_conn disabled=no new-routing-mark=to_adsl_wan2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan3_conn disabled=no new-routing-mark=to_adsl_wan3 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan4_conn disabled=no new-routing-mark=to_adsl_wan4 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan1_conn passthrough=yes per-connection-classifier=both-addresses:4/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan2_conn passthrough=yes per-connection-classifier=both-addresses:4/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan3_conn passthrough=yes per-connection-classifier=both-addresses:4/2
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan4_conn passthrough=yes per-connection-classifier=both-addresses:4/3
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan1_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan2_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan3_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan3 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan4_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan4 passthrough=yes
    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan1 routing-mark=to_adsl_wan1 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan2 routing-mark=to_adsl_wan2 comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan3 routing-mark=to_adsl_wan3 comment="Link2"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan4 routing-mark=to_adsl_wan4 comment="Link3"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan1 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_wan2 scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=adsl_wan3 scope=30 target-scope=10
    /ip route add comment="Link3" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=adsl_wan4 scope=30 target-scope=10
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback

  2. Citação Postado originalmente por juniorcarvalho Ver Post
    ao amigos do forum estou precisando e ajuda de vcs pra melhorar meu script de um load balance pcc com 4 links adsl em bridge rb 750 ..

    alguns tem muito mais experiencia no assunto .. que podem ajudar


    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan1 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan1 password= profile=default service-name="" use-peer-dns=no user=9936611215@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan2 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan2 password= profile=default service-name="" use-peer-dns=no user=9936611215@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan3 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan3 password= profile=default service-name="" use-peer-dns=no user=9936611619@
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=wan4 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_wan4 password= profile=default service-name="" use-peer-dns=no user=9936611619@
    Por que você seta o mtu em 1480 e mtu em 1480?
    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.4.4
    /ip dns set secondary-dns=8.8.8.8
    /ip dns set allow-remote-requests=yes

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan1
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan2
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan3
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_wan4
    # ip firewall mangle------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=LINK2
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=LINK2
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=LINK2

    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Local
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan1 new-connection-mark=adsl_wan1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan2 new-connection-mark=adsl_wan2_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan3 new-connection-mark=adsl_wan3_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_wan4 new-connection-mark=adsl_wan4_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan1_conn disabled=no new-routing-mark=to_adsl_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan2_conn disabled=no new-routing-mark=to_adsl_wan2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan3_conn disabled=no new-routing-mark=to_adsl_wan3 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_wan4_conn disabled=no new-routing-mark=to_adsl_wan4 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan1_conn passthrough=yes per-connection-classifier=both-addresses:4/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan2_conn passthrough=yes per-connection-classifier=both-addresses:4/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan3_conn passthrough=yes per-connection-classifier=both-addresses:4/2
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=adsl_wan4_conn passthrough=yes per-connection-classifier=both-addresses:4/3
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan1_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan2_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan3_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan3 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_wan4_conn disabled=no in-interface=Local new-routing-mark=to_adsl_wan4 passthrough=yes
    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan1 routing-mark=to_adsl_wan1 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan2 routing-mark=to_adsl_wan2 comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan3 routing-mark=to_adsl_wan3 comment="Link2"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan4 routing-mark=to_adsl_wan4 comment="Link3"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_wan1 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_wan2 scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=adsl_wan3 scope=30 target-scope=10
    /ip route add comment="Link3" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=adsl_wan4 scope=30 target-scope=10
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback
    Me parece tudo normal a não ser pelo item que citei acima.
    Esta funcionando?



  3. Qual o problema?

  4. Amigo você falou que quer melhorar? o que você quer é failover? se um link cair o outro assumir ? não entendi muito bem.



  5. o que ta acontecendo é que os 4 links estao conectados mais so tah usando 1 link

    no winbox só mostra conectado 1 pppoe queria usar os 4 de uma vez






Tópicos Similares

  1. Respostas: 118
    Último Post: 20-01-2016, 22:48
  2. Respostas: 2
    Último Post: 18-08-2013, 16:53
  3. DDNS + PCC + Modem Bridge + Mk 3.x = Problema
    Por admskill no fórum Redes
    Respostas: 3
    Último Post: 23-11-2009, 22:07
  4. problemas com LB em Adsl
    Por Projeto_Destino no fórum Redes
    Respostas: 7
    Último Post: 04-07-2008, 00:29
  5. Balanceamento entre adsl(bridge) e LinkDedicado
    Por andersonscinfo no fórum Redes
    Respostas: 6
    Último Post: 02-01-2008, 13:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L