+ Responder ao Tópico



  1. #1

    Padrão regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    # ip address --------------------------
    /ip address add address=192.168.100.1/24/24 interface=Rede Local

    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=link 1 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_link 1 password=internet profile=default service-name="" use-peer-dns=no [email protected]
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=link 2 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_link 2 password=internet profile=default service-name="" use-peer-dns=no [email protected]

    # ip dns --------------------------------
    /ip dns set primary-dns=200.204.0.10
    /ip dns set secondary-dns=200.204.0.138
    /ip dns set allow-remote-requests=yes


    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no

    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_link 1
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_link 2

    # ip firewall mangle------------------------

    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=Rede Local new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=Rede Local new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=adsl_link 1 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface="Rede Local" new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface="Rede Local" new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=adsl_link 2 routing-mark=Rota1

    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    # Fim LoopBack por link----------------------

    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface="adsl_link 1" new-connection-mark=adsl_link 1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_link 2 new-connection-mark=adsl_link 2_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_link 1_conn disabled=no new-routing-mark=to_adsl_link 1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_link 2_conn disabled=no new-routing-mark=to_adsl_link 2 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Rede Local new-connection-mark=adsl_link 1_conn passthrough=yes per-connection-classifier=:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Rede Local new-connection-mark=adsl_link 2_conn passthrough=yes per-connection-classifier=:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_link 1_conn disabled=no in-interface=Rede Local new-routing-mark=to_adsl_link 1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_link 2_conn disabled=no in-interface=Rede Local new-routing-mark=to_adsl_link 2 passthrough=yes

    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_link 1 routing-mark=to_adsl_link 1 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_link 2 routing-mark=to_adsl_link 2 comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_link 1 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_link 2 scope=30 target-scope=10

    espero ter ajudado.

  2. #2

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Valeu amigo!!!



  3. #3

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    vlw amigo!!! isso vai ajudar muita gente!!!

  4. #4

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Rapaz, isso ai vai me ajudar demais! Ah tempos procuro por isso!
    Parece que o fórum está sendo utilizado com a intenção para qual foi criado, ajudar sem complicações!
    Obrigado amigo!



  5. #5

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Colega muito bom mesmo, vai ajuda muita gente.. rs como eu.. esse esquema é pra modem em bridge é isso?
    Obrigado.

  6. #6

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Citação Postado originalmente por vanderleisistema Ver Post
    Colega muito bom mesmo, vai ajuda muita gente.. rs como eu.. esse esquema é pra modem em bridge é isso?
    Obrigado.

    isso é pra modem em bridge, pois ai o mk que gerencia tudo. abraço



  7. #7

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    DNS da telefonica;

  8. #8

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Olá, estou chegando agora e preciso de uma ajuda pois estou confuso.
    Veja bem: tenho um link ADSL Velox Empresarial (6Mb), chegando em um modem roteado que vai para um server BrazilFW, que por sua vez está ligado a um switch que serve a rede.

    Gateway (server BrazilFW): 192.168.0.1

    Quero colocar uma RB750G recebendo este primeiro modem e também um outro, roteado, de um segundo link ADSL Velox Residencial (1Mb), para load balance, failover e td que tiver direito.

    Primeira dúvida: é possível fazer isso com dosi links Velox?
    ("...O Interessante é que Modens ADLS, tipo Velox, em modo Bridge (mikrotik discando) funcionam, mesmo tendo o mesmo Gateway. (Acho que deve ser pelo fato de além da Interface fisica do link, quando criamos o PPPoE-client, ele se torna uma nova interface, dai no script do balanceamento eu escolho o PPPoE-Client como gateway, e não a interface fisica que recebe o link. Entendeu? "...)

    Outra dúvida é em relação aos IPs:
    Tem uma dica aqui no forum que diz assim:
    EthLinkA = Interface do primeiro link
    EthLinkB = Interface do segundo link
    EthLinkC = Interface do terceiro link
    EthClientes = Interface dos clientes

    Quando em modo roteado:
    10.1.10.129 = Ip do modem A
    10.1.10.161 = Ip do modem B
    10.1.10.193 = Ip do modem C

    Endereços das interfaces no Mikrotik ROS
    10.1.10.130/27 = Ip da interface EthLinkA
    10.1.10.162/27 = Ip da interface EthLinkB
    10.1.10.194/27 = Ip da interface EthLinkCGrato.

    Estou confuso nesta parte de IPs... quem vai ser o que... estes valores aí serviriam prá mim?



    Em tempo: É necessário que os modens estejam todos em bridge ou podem estar em router?
    Última edição por EltonGuedes; 11-03-2011 às 23:51.



  9. #9

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Amigo uso essa configuração a algum tempo e realmento funciona em perfeita harmonia nunca deu problema nem pau se um link cair o outro assume todo o trafego até o outro voltar muito bom mesmo.
    isso ai vai ajudar muita gente que não consegue fazer PCC loadbalance

  10. #10

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    a pergunta e a duvida é a seguinte tenho um serve discando em modem bridge, como iria funcionar esse servidor com loadballance? e como ficaria a configuração do serve que tem hotspot com autentificação? me ajuda por favor! antes que voce me pergunte tenho adsl com 5 e outra adsl com 1 mega da oi velox.



  11. #11

    Padrão Re: regras pcc loadbalance com 2 links funcionando em perfeita harmonia

    Colega não é indicado colocar loadbalance com hotspot , pois da problema , isso te falo de experiencia propria, separa isso compra um RB450 ou 450g que da conta legal so pra load.


    Mais tb tenho duvidas sobre o loadbalance com links com carga diferente , um de 5 MB ou tro de 10 15 sei la , to vendo isso agora aqui , quero pegar um link empresarial para jogar a sujera nele , ou melhor as portas usadas por p2p.