+ Responder ao Tópico



  1. Ola pessoal,

    Estou com a seguinte dificuldade com o SQUID.

    Tenho 2 proxy de saida de internet, um administrativo e outro para outros setores, no browser indentifico se quero usar um ou outro, ate aqui tudo esta funcionando tanto um como o outro.
    Quando fui aos outros setores que possuem classe e ip diferentes da administração a internet nao funciona com proxy SQUID, tentei pingar e apresentou time out, tentei traceroute e nada tambem.

    Exp.:

    ADM setor1 setor2
    IP - 10.0.0.0 10.0.1.0 10.0.2.0
    Gw- 10.0.0.1 10.0.1.1 10.0.2.1

    Config Lan1 server SQUID - 10.0.0.22
    Config Lan2 server SQUID - 200.xxx.xxx.xxx gw 200.xxx.xxx.1

    Dentro da rede da ADM realizo a troca do ip no browser e funciona no dois proxy´s, no setor1 e 2 nao funciona se apontar para o ip do SQUID.

    O que poderia ser que esteja faltando ou errado nas configurações?

    Obrigado.

  2. Oi alexandrobat

    Possuo uma rede com aparentemente as mesmas configurações suas, e funciona 100%, seguindo a sua explicação acho que talvez vc tenha esquecido de criar as placas virtuais para o gateway de cada endereço, por esse motivo ele não pinga.
    para criar placas de rede virtual vc tem que criar um script e colocar o seguinte comando :

    ifconfig eth1:1 10.0.1.1
    ifconfig eth1:2 10.0.2.1
    ifconfig eth1:3 10.0.3.1
    ifconfig eth1:4 10.0.4.1

    e assim por diante... obs : no meu caso a eth que vai para os clientes é a eth1

    outra coisa importantíssima, não esqueça a mascara de rede, pois uma máscara 255.0.0.0 enxerga todas as demais redes, mais uma 255.255.255.0 só enxerga uma categoria, ex:

    ip : 10.0.1.2
    masc : 255.255.255.0

    só vai enxergar outro ip dentro do escopo 10.0.1.xxx

    agora ...

    ip : 10.0.1.2
    masc : 255.0.0.0

    vai enxergar o escopo 10.xxx.xxx.xxx

    espero ter ajudado.

    André
    Gbytes Solutions
    Última edição por Gbytes; 11-02-2011 às 11:26.



  3. Obrigado Andre pela resposta, fica para conhecimento.

    Depois de muito pensar, percebi que o problema estava no roteamento dos pacotes, o que fiz para resolver:

    # route add -net 10.0.1.0 netmask 255.255.255.0 gw 10.0.0.1
    # route add -net 10.0.2.0 netmask 255.255.255.0 gw 10.0.0.1
    (caso exista outras redes roteadas pelo router principal da rede basta adicionar as redes)

    E liberar no firewall:

    # iptables -A INPUT -p tcp -s 0/0 --dport 80 -i IFINT -j ACCEPT

    Feito isso, tudo flui perfeitamente.

    Obrigado pela atenção de todos.
    Alex...
    Última edição por alexandrobat; 11-02-2011 às 13:49.

  4. Amigo,
    O seu problema com certeza tem a ver com a rede e não com o proxy.
    Primeiro faça as rede se cominicarem para testar o proxy.






Tópicos Similares

  1. Servidor DHCP para varias redes
    Por flon no fórum Servidores de Rede
    Respostas: 3
    Último Post: 14-12-2005, 12:29
  2. squid apenas para rede interna
    Por PolacoCWB no fórum Servidores de Rede
    Respostas: 6
    Último Post: 14-10-2005, 18:25
  3. DHCP - várias redes
    Por bouncer no fórum Servidores de Rede
    Respostas: 7
    Último Post: 03-08-2005, 21:58
  4. squid-autenticação várias vezes
    Por ninja_du no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-03-2004, 21:25
  5. Squid varias redes
    Por ronei no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-02-2004, 09:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L