Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde.
    Depois de dar uma pesquisada boa aqui no forum, achei um script de auto mac pra Hotspot, mas não tinha nada específico pra PPPoE, então resolvi adaptar as regras que eu achei para o meu caso. Segue abaixo o script:

    :foreach h in=[/ppp active find] do={
    :global name [/ppp active get $h value-name=name];
    :global mac [/ppp active get $h value-name=caller-id];
    /ppp secret set $name caller-id=$mac
    }

    O que esse script faz? Caso você conecte um cliente em PPPoE sem cadastrar o mac do indivíduo, assim que ele conectar, um tempo depois o script pega o mac dele, e adiciona no profile dele, evitando assim que outro mac logue com o usuário e senha daquela pessoa. O tempo é determinado pelo scheduler que você criar pra esse script. Aqui no meu caso, eu agendo ele de 15 em 15 minutos.

    Script testado em Mikrotik 4.16

    Abraço a todos!
    Última edição por horusosbourne; 17-02-2011 às 09:34.

  2. Obrigado pelo script amigo. Testado e aprovado no Mikrotik 5.18 e 5.25.



  3. Obrigado amigo testado e aprovado verção 6,25
    no caso de o cliente trocar o mac ele ira pegar o novo mac automaticamente certo?

    Valeu

  4. Citação Postado originalmente por elvysjr Ver Post
    Obrigado amigo testado e aprovado verção 6,25
    no caso de o cliente trocar o mac ele ira pegar o novo mac automaticamente certo?

    Valeu
    Acredito que não, porque o cliente não irá conseguir autêntica se trocar de MAC.



  5. Isso mesmo, se o cliente entrar com outro MAC vai ser bloqueado pelo MK, ele teria que ligar para o provedor e falar que quer recadastrar o novo mac.






Tópicos Similares

  1. Script auto cadastro do MAC
    Por Alex20cf no fórum Redes
    Respostas: 2
    Último Post: 14-10-2014, 19:57
  2. ip + mac + pppoe tutorial
    Por mdcsp no fórum Redes
    Respostas: 4
    Último Post: 12-01-2010, 15:16
  3. Ajuda em script 1 usuario pppoe/user-manager
    Por airtonveiga no fórum Redes
    Respostas: 1
    Último Post: 29-03-2009, 15:16
  4. Contrloe por MAC - PPPOE
    Por Kalley no fórum Redes
    Respostas: 5
    Último Post: 05-03-2008, 01:25
  5. Script Auto Guard para bloqueio automático
    Por Super_Diaulas no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-08-2005, 16:59

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L