+ Responder ao Tópico



  1. #1

    Wink Dependencias entre pacotes

    Bom dia

    Estou com alguns problemas para resolver dependencias de pacotes no debian 6 kernel 2.6.32-5-amd64. Pretendo instalar o virtualbox-4.0; mas quando mando instalar me aparece a seguinte mensagem de erro:
    "...
    Os pacotes a seguir têm dependências desencontradas:
    virtualbox-4.0 : Depende: libqt4-network (>= 4:4.5.3) mas 4.4.3-1+lenny1 está para ser instalado
    Depende: libqt4-opengl (>= 4:4.5.3) mas 4.4.3-1+lenny1 está para ser instalado
    Depende: libqtcore4 (>= 4:4.6.1) mas 4.4.3-1+lenny1 está para ser instalado
    Depende: libqtgui4 (>= 4:4.6.1) mas 4.4.3-1+lenny1 está para ser instalado
    Recomenda: libsdl-ttf2.0-0 mas não é instalável
    Recomenda: dkms mas não é instalável
    Recomenda: linux-headers mas não é instalável
    Recomenda: gcc mas não é instalável
    Recomenda: make mas não é instalável
    Recomenda: binutils mas não é instalável"

    Tentei instalar estas dependencias manual mas o sistema me retorna a mensagem que o pacote mais atual já está instalado...

    tentei também usar # aptitude -y install ... para resolver as dependencias mas me retorna esta mensagem:

    "Os pacotes a seguir possuem dependências não satisfeitas:
    virtualbox-4.0: Depende: libqt4-network (>= 4:4.5.3) mas 4.4.3-1+lenny1 está instalado.
    Depende: libqt4-opengl (>= 4:4.5.3) mas 4.4.3-1+lenny1 está instalado.
    Depende: libqtcore4 (>= 4:4.6.1) mas 4.4.3-1+lenny1 está instalado.
    Depende: libqtgui4 (>= 4:4.6.1) mas 4.4.3-1+lenny1 está instalado.
    As seguintes ações resolverão estas dependências:

    Manter os pacotes a seguir em suas versões atuais:
    1) virtualbox-4.0 [Não Instalado]"

    Desde já agradeço!

    Vilson Jorge

  2. #2

    Padrão Re: Dependencias entre pacotes

    tenta fazer uma instalação forçada, já que as versões que vc tem são superiores, acredito que não vai dar problema.
    #aptitude -f install virtualbox
    ou use a opção -d para fazer o download apenas, então tente instalar com o dpkg forçadamente ou com nodeps.



  3. #3

    Padrão Re: Dependencias entre pacotes

    e ai, rolou a instalação???

  4. #4

    Padrão Re: Dependencias entre pacotes

    Lamentavelmente não. No Debian 6 estou dispensando a instalação do VBox... se em algum equipamento preciso do Vbox estou usando o Lenny.


    Obrigado pela força;

    Abr



  5. #5

    Padrão Re: Dependencias entre pacotes

    Tem um link pra download para a versão 6 do debian no site, chegou a tentar com esta ao invés de usar a do repositorio?
    http://download.virtualbox.org/virtu...ueeze_i386.deb

  6. #6

    Padrão Re: Dependencias entre pacotes

    Opa!! parece-me que o rolo está longe de terminar... instalei mais de uma versão do VB. Instalar instala certo o problema está na hora de executar a aplicação... depois de selecionar o SO que vou instalar na VB, a qtde de memória, o tamanho do disco, etc... qdo vou iniciar a instalação esta me aparecendo este bug

    RTR3Init failed with rc=-1912 (rc=-1912)

    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

    '/etc/init.d/vboxdrv setup'

    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

    Já lí muita coisa a respeito, muitos posts na internet mas nada tem resolvido...
    ainda bem que não tenho tanta pressa!

    Alguém já resolveu isso?
    O kernel que estou usando é o 2.6.32-5-amd64 #1 SMP Wed Jan 12 05:14:59 UTC 2011 x86_64 GNU/Linux


    atenciosamente;

    Vilson Jorge
    Última edição por vjorge; 13-05-2011 às 14:19.