Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Soluções para ACK alto

    Pessoal

    Que tal juntarmos aqui a soluções encontradas para os problemas com ACK alto.

    Poste seu(s) caso(s) e como resolveu.

    Abraço

    Sucesso a todos

  2. #2
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Soluções para ACK alto

    ack alto normalmente e por causa de ma instalação ou radio não esta aguentando passar a banda necessaria



  3. #3

    Padrão Re: Soluções para ACK alto

    Ack alto, ruido, interferencia, obstaculo (zinco, arvore, caixa d'agua), pigtail, cartao, ap do cliente... muito a se analisar.

    Boa sorte

  4. #4

    Padrão Re: Soluções para ACK alto

    Às vezes até trocando o modo de B/G para B ou G só já cai o ACK.
    Ou se está em B passar para B/G.
    Esta situação da alteração do modo já aconteceu algumas vezes comigo, mas não entendi o motivo.
    Realmente tem muita coisa que pode causar isso.
    Mas básicamente está dizendo que a conexão não está fluindo normalmente.



  5. #5

    Padrão Re: Soluções para ACK alto

    O inferno do ACK é que no inicio da conexão ele sempre começa em 30ms depois vai subindo até a conexão tornar-se infernal. Em nossa região esse problema ocorre devido a grande interferência sofrida após a implantação do projeto cidade digital, onde foram instaladas torres próximas umas das outras com painéis de 17Dbi, detalhe as torres ficam no máximo 1.5Km uma da outra, ou seja o sistema foi projetado para causar interferência e "explosão" do ACK nas proprias torres da prefeitura e mesmo de quem não tem nada haver com o pato...

  6. #6

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por paulojrandrade Ver Post
    Ack alto, ruido, interferencia, obstaculo (zinco, arvore, caixa d'agua), pigtail, cartao, ap do cliente... muito a se analisar.
    Básicamente o que eu percebo na minha rede tbm!

    Conversando com colegas de outro provedor eles me disseram que tinham muitos problemas de ack alto, pois um usuário conectava com 150 de ack e ia ao longo do tempo interferindo nas conexões da mesma wlan e que para resolver eles davam um kick na conexão ruim e o usuário conectava melhor...

    Para resolver de forma automática eles acharam um script que colocam para rodar de tempos em tempos que avalia o ack do registration e caso esteja >90 kicka a conexão altomaticamente!

    Deste modo usuários com ack alto não afetam conexões boas e caso com os kick o usuário não fique bom ele vai entrar em contato com a empresa, daí é só avaliar o problema no local.

    Segue o script que eles me passaram e eu utilizo em alguns APs:
    Código :
    # Interface
    :global iface ""
     
    # Indice da interface
    :global indice 0;
     
    # Limite do ACK
    :global ack 90;
     
    # MAC do cliente
    :global mac "";
     
    :foreach i in=[/interface wireless find] do={
     
        :set iface [/interface wireless get $indice name];
     
        :foreach i in=[/interface wireless registration-table find interface=$iface] do={
     
            :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
                :set mac [/interface wireless registration-table get $i mac-address];
                /interface wireless registration-table remove $i;
                :log info "KICK-ACK: $iface / $mac (ack acima de $ack ms)";
            };
     
         };
     
         :set indice ($indice + 1);
     
    };

    Para utilizar o script basta ir em System -> Scripts -> +:
    Código :
    Name: kill-ack    #Nome a ser chamado depois
     
    Policy:
        [ x ] reboot    [ x ] read
        [ x ] write     [ x ] policy
        [ x ] test      [ x ] password
        [ x ] sniff     [ x ] sensitive
     
    Source:
        AQUI VOCÊ COLA O COD.

    Depois para automatizar a execução dele basta ir em: System -> Scheduler -> +:
    Código :
    Name: Kill ACK 
    Start Date: Jan/01/1970
    Start Time: startup   # Quando rebootar já sobe o script
    Interval: 00:05:00    # Intervalo de 5 minutos, pode variar
    Delay: 00:00:00
    On Event: kill-all    # Nome atribuido ao script, se mudar lá não esqueça de mudar aqui tbm
    Policy:
    [ x ] write
    [ x ] read
    [ x ] test

    Caso queria chamar no terminal para não ficar dependendo do tempo do script, basta no terminal digitar:
    Código :
    /system script run kill-ack

    Sempre que for kickada alguma conexão o script anunciará no log.

    Pronto!

    []s
    Última edição por cleberoliveira; 22-03-2011 às 11:00.



  7. #7

    Padrão Re: Soluções para ACK alto

    Cara vc já usa esse script??? Eu já ví diversos como este porém morro de medo de dar uma zika e acabar derrubando todos clientes associados... Caso use passe para nós se realmente compensa usar esse tipo de script e se não carreta algum problema de processamento ou algo do tipo mas RB´s.

  8. #8

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por evertonsoares Ver Post
    Cara vc já usa esse script??? Eu já ví diversos como este porém morro de medo de dar uma zika e acabar derrubando todos clientes associados... Caso use passe para nós se realmente compensa usar esse tipo de script e se não carreta algum problema de processamento ou algo do tipo mas RB´s.
    Uso sem problemas... vale dar uma adaptada para sua realidade, mas eu utilizo e não dá lag nem sobrecarga, é a mesma coisa que você ir manualmente e kickar todas as conexões com ack > do estipulado, no caso do meu script eu uso 90.

    Tem gente que adiciona a função para mandar e-mail informando o usuário kickado e etc, eu não vejo vantagem pois eu sempre acompanho os logs dos mks.

    []s



  9. #9

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por evertonsoares Ver Post
    Cara vc já usa esse script??? Eu já ví diversos como este porém morro de medo de dar uma zika e acabar derrubando todos clientes associados... Caso use passe para nós se realmente compensa usar esse tipo de script e se não carreta algum problema de processamento ou algo do tipo mas RB´s.
    E no caso de usar Nano em bridge no POP, como faria algo parecido?
    Talvêz fixando o ACK em um valor razoável, como 60 por exemplo em vêz de deixar no automático?

  10. #10

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por 1929 Ver Post
    E no caso de usar Nano em bridge no POP, como faria algo parecido?
    Talvêz fixando o ACK em um valor razoável, como 60 por exemplo em vêz de deixar no automático?
    No caso de Nano eu tentaria desenvolver algo via ssh com key para que meu server linux de tempos em tempo entrasse na lista de nanos-ap e checasse o ack, caso > kick... mas isso tudo uma grande suposição... teria que entrar via ssh e tentar fazer manualmente, caso seja possível fica fácil automatizar...

    []s



  11. #11
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Soluções para ACK alto

    Eu usava esse script do ack, um que foi feito pelo Alexandre Correia, mais pra mim nao funciona mais pelo motivo abaixo.

    Bom vocês ja devem ter percebido que nas novas versoes do RouterOs, nao existe mais a opçao ACK, no lugar dela existe uma opçao distance, que basicamente é a mesma coisa (Eu acho, nao tenho certeza ok).

    Alguem ja viu em algum lugar um script que faça a mesma funçao do script do ack ?


    Abraços a todos.

  12. #12

    Padrão Re: Soluções para ACK alto

    Pra mim a solução de ACK Alto é criar mais celulas de sua rede para atender os clientes mais proximos as torres, deixar de antender o Zé que esta longe da sua torre, e ou montar uma nova torre mais proxima do Zé. As vezes o cliente que tem a pior qualidade de sinal é o que deseja pagar mais para ser seu cliente, ele tmb será o seu problema de ACK e suporte.



  13. #13
    Correndo atrás... Avatar de Leonardo
    Ingresso
    Aug 2009
    Localização
    Próx. a Brasília
    Posts
    152

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por evertonsoares Ver Post
    Cara vc já usa esse script??? Eu já ví diversos como este porém morro de medo de dar uma zika e acabar derrubando todos clientes associados... Caso use passe para nós se realmente compensa usar esse tipo de script e se não carreta algum problema de processamento ou algo do tipo mas RB´s.
    Este script funciona perfeitamente, uso ele há muito tempo jah tenho 5 rb 433 em bridge todas com este script configurado para ack acima de 40 derrubar, isso no modo B ja no modo G tem q configurar pra maior ack.



    Citação Postado originalmente por edcomrocha Ver Post
    Eu usava esse script do ack, um que foi feito pelo Alexandre Correia, mais pra mim nao funciona mais pelo motivo abaixo.

    Bom vocês ja devem ter percebido que nas novas versoes do RouterOs, nao existe mais a opçao ACK, no lugar dela existe uma opçao distance, que basicamente é a mesma coisa (Eu acho, nao tenho certeza ok).

    Alguém já viu em algum lugar um script que faça a mesma funçao do script do ack ?

    Abraços a todos.

    Voce sabe apartir de qual versao nao tem essa opção de ack? voce acha que compensa fazer um upgrade em minhas rbs? aqui uso 4.10 e 4.11


    Forte abraço.

  14. #14
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Soluções para ACK alto

    A versao certa nao me lembro bem, mais sei que na 5rc tem em todas.

    Eu só atualizo algumas RBs, pois a versao ainda é rc.

    So atualizo todas quando a versao ja esta stable.

    ai vai de cada um.

    Abraços.



  15. #15

    Padrão Re: Soluções para ACK alto

    Script funciona pois existe alguns clientes que exatamente no momento da conexão pega alguma interferencia ou a celula sobrecarregada no momento exato ai o script derruba e ele volta bem evitando a deterioração da celula, mas tem que ficar atento pois se o cliente tiver com problema no tx do radio ou pigtail ruim ou bico da antena com agua no caso das famosas aquario o ack nunca fica bom ai o cliente e derrubado constantemente. Mas quando todos clientes estao ruins tem que revisar a torre mesmo muitas vezes cartão com defeito.
    Aqui nas 3 cidades que atendemos esta impraticavel o nivel de ruido e nem em 5.8 esta tendo canais livres, no meio do ano passado começamos a colocar rockets e nanos M5 e até o mes passado estava indo bem com planos de até 2mb mas esse mes a coisa já degringolou de novo, voltamos a ter perdas de pacotes em algumas redes mesmo com o famoso airmax ligado. Trocamos de canal funciona por alguns dias até o concorrente colocar o dele em cima e assim vamos aos trancos e barrancos, e olha que minhas celulas tem no maximo 35 clientes.
    Assim não sei onde vamos parar.

  16. #16

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por JorgeAldo Ver Post
    Essas gambiarras são parecidas com isso :

    O político foi pego roubando. Solução, aprovar uma comissão oficial para todos os políticos.

    NÃO, temos que acabar com a corrupção, que no nosso caso consiste em :

    1 - Melhorar o ganho das antenas nos clientes com ruido (quanto mais ganho, mais diretividade, quanto mais diretividade, menos enxerga ruído).
    2 - Usar painéis setoriais ao inves de omnis.
    3 - Aumentar o numero de POPs.
    4 - Mudar a polarização.

    etc

    O problema fundamental é o mesmo, só que ele se manifesta de formas diversas, inclusive na forma de ACK Alto.

    Querer resolver o ACK alto sem tocar na infraestrutura é tentar dar um paliativo e conviver com o problema real.
    Concordo plenamente com o Jorge, não podemos utilizar esse script e não verificar a parte da infra, mas é como nosso amigo tecnic falou:

    Citação Postado originalmente por tecnic Ver Post
    Script funciona pois existe alguns clientes que exatamente no momento da conexão pega alguma interferencia ou a celula sobrecarregada no momento exato ai o script derruba e ele volta bem evitando a deterioração da celula, mas tem que ficar atento pois se o cliente tiver com problema no tx do radio ou pigtail ruim ou bico da antena com agua no caso das famosas aquario o ack nunca fica bom ai o cliente e derrubado constantemente. Mas quando todos clientes estao ruins tem que revisar a torre mesmo muitas vezes cartão com defeito.
    No meu caso utilizo o script e sempre estou de olho nos logs e nas ligações de clientes, muito kick e cliente ligando da mesma repetidora, já foco na infra para ver se está tudo ok, caso esteja tudo ok, daí é verificar o equipamento do cliente.

    No caso de ter mais celulas e não atender o "Zé que esta longe da sua torre", todos sabem que é o melhor, porem muitas vezes é um preço a se pagar, pois geralmente não temos lucro o suficiente para criar uma celula para a região ainda, mas também não podemos dispensar os clientes. Lógico que a partir do momento que temos um volume de cliente bacana aí compensa abrir uma celula para atender exclusivamente a região.

    Fica a critério de cada provedor, a final das contas cada rede é uma rede e cada caso é um caso, não podemos utilizar o script achando que vai fazer milagre, mas também não podemos descartar soluções que podem nos ajudar a contornar problemas eventuais.



  17. #17
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Soluções para ACK alto

    ack alto ja tem solução rocket m5 na base e nano m5 no cliente 1 ms de comunicaxion e coisa linda de deus

  18. #18

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por naldo864 Ver Post
    ack alto ja tem solução rocket m5 na base e nano m5 no cliente 1 ms de comunicaxion e coisa linda de deus
    Qual setorial da UBIQUITI você utiliza com o rocket para sua base?

    Hoje eu tenho Alguns nanos M5 como aps e 2 Rockets com BaseStation AM-5G17, estou fazendo gerencia através do Mikrotik, ligando os nanos ou rockets direto nas ethers e para PTPs eu utilizo sempre Rocket Dish para longe e nano-bridge para ptps próximos.

    Realmente até hoje não tive problemas com cliente conectados no Rocket, porem estou pesquisam o que vale mais a pena, fazer célula 360 com nanoM5 ou 3 rockets com Setoriais BaseStation 5G-19 (120 graus) pois é a única homologada.

    Alguém tem alguma sugestão?

    []s



  19. #19
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Soluções para ACK alto

    eu uso rocket m5 com setorial 5g 19 tambem e muito bom cara não vou trocar de jeito nenhum por outro equipamento acho que não compensa nano na torre e melhor colocar 3 rockets com 3 setorial de 19 ja da pra cobrir 360 graus a area

  20. #20

    Padrão Re: Soluções para ACK alto

    Citação Postado originalmente por naldo864 Ver Post
    eu uso rocket m5 com setorial 5g 19 tambem e muito bom cara não vou trocar de jeito nenhum por outro equipamento acho que não compensa nano na torre e melhor colocar 3 rockets com 3 setorial de 19 ja da pra cobrir 360 graus a area

    Qual o maior número de clientes que você tem conectado em um rocket com a 5g 19? e qual a distancia você procura atender tbm?

    []s