+ Responder ao Tópico



  1. #1

    Padrão Problemas nas rotas Linux <-> PPPoE Mikrotik

    p { margin-bottom: 0.21cm; } Bom dia!
    Pessoal tenho o seguinte quadro:
    Link EBT Fibra -> Servidor Linux -> Concentrador PPPoE Mikrotik -> Clientes
    Onde estou distribuindo ips valido e fixo por rotas e usando o squid em tproxy!
    Ate ai esta tudo funcionando perfeitamente onde preciso criar as rotas para os ips funcionarem nos clientes que a regra todos ja sabem!
    route add -net 189.87.**.* netmask 255.255.255.0 gw 172.16.0.2
    route add -net 189.87.**.* netmask 255.255.255.0 gw 172.16.0.2
    route add -net 189.87.**.* netmask 255.255.255.0 gw 172.16.0.2
    route add -net 189.87.**.* netmask 255.255.255.0 gw 172.16.0.2
    Observei que de uns tempos pra K ocorre de ter perca de pacotes e procurei por loop por conflito de ip e nada, ativei o protocolo stp nos mikrotik e switch e nada! fiz um teste e desativei todas as rotas e o problema foi resolvido! porem os clientes com ips valido não funciona por falta de rota!
    Alguém passou por isso ou tem alguma dica!

  2. #2

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Cara... O que voce precisa ai eh OSPF entre o teu roteador e os servidores PPPOE...

    Da uma estudada nisso... Fica tudo dinamico e voce nunca mais vai ter que digitar rota nenhuma... Cada vez que alguem conectar o servidor PPPOE vai informar a rota pra frente e tambem vai remover quando o cliente cair...



  3. #3

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Teria algum material?

  4. #4

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Deixa eu mostrar o como esta configurado!
    Cisco 2801 usando as 2 fast ethernet on na FastEthernet 1 esta configurada o ip wan embratel e na FastEthernet 2 esta configurada 2 blocos de ips sendo que a classe 189.23.53.***/26 sendo que o ip 189.23.53.**3 uso na Fast 2 para atuar como gateway do servidor ao roteador onde no servidor uso o ip 189.23.53.**4.
    Ja nos 4 blocos /24 que disponibilizo aos clientes não tem nenhum ip da faixa configurada no roteador apenas setei rotas no roteador da seguinte forma
    ip route 189.87.66.0 255.255.255.0 189.23.53.**4
    ip route 189.87.67.0 255.255.255.0 189.23.53.**4
    ip route 189.87.68.0 255.255.255.0 189.23.53.**4
    ip route 189.87.69.0 255.255.255.0 189.23.53.**4



  5. #5

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Sim, isso te obriga a fornecer classe X ao PPPOE Y e classe Z ao PPPOE W... Sei como é, eu era assim antes.

    Chegou uma hora onde resolvemos fazer redundância de PPPOEs, então ligamos o cabo na rua e fizemos um anel... O cliente ficava "vendo" os 2 servidores. O problema com isso era o cliente que tinha IP fixo... Se ele conectasse pelo servidor errado ele não tinha rota de volta.

    Pra isso serve OSPF, RIP, etc... Eles tornam o roteamento dinâmico (OSPF sendo o melhor neste caso pois atua mais rápido). O cliente se conecta em um servidor e esse servidor anuncia para frente que o IP X esta nele... Automaticamente todos os servidores da mesma área OSPF criam uma rota local assim "ip-cliente 255.255.255.255 ip-pppoe-server".

    Dá uma lida aqui:
    Cisco Certified » Tutorial OSPF - Parte 1

    Mas no Mikrotik é ridículo de tão fácil que é implementar isso...

  6. #6

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Pode passar e-mail ou msn?



  7. #7

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Se quizer uma força ai
    [email protected]

  8. #8

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    nada resolvido!
    E o negocio mais estranho que ja vi



  9. #9

    Padrão Re: Problemas nas rotas Linux <-> PPPoE Mikrotik

    Ninguém tem alguma dica?
    O estranho e que quando retiro a rota do roteador
    Código :
    ip route 189.87.66.0 255.255.255.0 189.23.53.**4
    Fica normal! ou seja, quando o cliente esta com ip valido mesmo da problemas e quando retiro as rotas fica normal!